Reset password of gui user

Hi thank YOU very much for this project, i really apreciate the sharing of your wisdom.

My YunoHost server:

Hardware: VM at home
YunoHost version:

I have access to my server : direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I simply forgot the pass of the only user i had created in the gui.

I am/was able to login via console with root user then used this command:
yunohost tools adminpw

but this changed the admin password and that is not the user of the gui

how can i reset the password of the user of the gui (i know what user is. i just forgot the password)?

Thank You!

Hi !
If I’m not mistaken, with your admin password you are able to log in to your admin page. Something like
And then you can change your user password in the Users page.

Thank you for your answer but already tried that and it says wrong password.

I double checked and from console or ssh i can login succesfully with user root or with user admin (after that command both have the same password) so i can confirm i know the right password but it is not working in the web interface…

Is your yunohost api up ?

systemctl status yunohost-api

If no restart it:

systemctl restart yunohost-api

Sorry to hear that, but I don’t know what you should do :frowning:
I hope @ljf answer will help you.

Could you run the services diagnosis ?

yunohost diagnosis run services

Yes i can but i have a lot of errors because i am in the middle of some changes in my domain and dns.
EDIT: some error are not real! I read this post so i decided to check the ports using this website and they are open!

But for the sake of this post:

Is there a particular error that i should look for that could make me unable to change the gui user pass or reset it having access through console as root ?

tell me if you want me to paste results of the diagnosis anyway, I just wanted to avoid flooding.

Thank You !

Share them with the “Share with YunoPaste” green button, and paste here the link to the page. Sensitive information are anonymized.

When you say you have already tried replacing the password, you are talking about this form, correct?

If so, can you try through the command line?

yunohost user update titus -p --debug

1 Like

Which gui do you speak about ? The user portal on /yunohost/sso/ or the webadmin on /yunohost/admin/ ?

1 Like

:man_facepalming:t3: Forget it. It seems it was an ID 10T problem or the classic “problem between the screen and the chair” aka the user, me…

Digging up i found that 2 different address almost at the same time @ljf posted them! and as i had changed the admin pass to the same root pass (from console) i was able to log into the gui and change the user password.

MY Problem is Solved (it was not a problem of yunohost).

I will be asking more questions on another subjects hoping they won’t be so dumb! This topic can be closed.

Thank You Very much for the help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.