Rendre public FreshRSS

#1

Bonjour à tous et toutes,

je cherche comment rendre publique Fresh RSS afin de pouvoir utiliser l’API et ainsi synchroniser les flux RSS avec mon téléphone portable ?

Je n’ai pas trouvé de solution à ce problème pour le moment, mais si quelqu’un à une piste je veux bien essayer. Merci d’avance.

A+ @Plumf

#2

Bonjour @Plumf,

Il y a une procédure en fin de page ici https://github.com/YunoHost-Apps/freshrss_ynh (je n’ai pas essayé) et @genma a ecrit sur le sujet aussi https://blog.genma.fr/?Yunohost-FreshRSS-et-EasyRSS-pour-Android

Bonne chance :slight_smile:

2 Likes
#3

@Gofannon, la procédure de @genma est similaire à la proposition sur la page github. Cependant après avoir déterminé le mot de passe pour l’api et que je check si l’api fonctionne voilà ce que me renvois la page /api/greader.php :
Screenshot_2019-03-20%20https%20actus%20open-plug%20eu

et si j’appel juste la page /api/ :

Est ce que quelqu’un à déjà rencontré ce problème ?

A+, @Plumf

#4

@Plumf, je viens de suivre la documentation sur la page github et ça fonctionne bien depuis mon téléphone.

Sur la page api, j’ai ça:

freshrss

Dans ta capture d’écran, il semble y avoir un problème dans la configuration de FreshRss. Sur mon serveur, dans le fichier /var/www/freshrss/data/config.php, la variable “base_url” est vide

image

Quelques pistes pour ton soucis:

  1. Est-ce que tu as bien la dernière version de Freshrss installée? (faire les mise à jour depuis l’interface d’administration Yunohost)
  2. Sur ton téléphone, tu as bien mis l’adresse complète? https://exemple.tld/rss/api/greader.php
#5

J’avais ouvert la même discussion (en anglais) à FreshRSS / Webserver configuration for using mobile app

Je vais tester les conseils de @Gofannon et modifier la valuer de la variable “bas_url” et je vous tiens informé.

Merci !

I open the discussion about the same topic at FreshRSS / Webserver configuration for using mobile app

I will try the advice of @Gofannon to check and modify the “base_url” variable
I’ll keep you informed.

Thanks !

#6

Bonjour @croulibri,

Je n’avais pas vu ton message en anglais

Il y a peut être une coquille dans la manière d’installer FreshRSS. Voir cette ligne du script d’installation https://github.com/YunoHost-Apps/freshrss_ynh/blob/master/scripts/install#L66

Ping @plopoyop qui travaille / a travaillé sur l’empaquetage de FreshRSS

1 Like
#7

Effectivement, dans mon fichier ./data/config.php j’avais dans la variable
'base_url' => 'adresse_de_mon_serveur//rss', (avec les deux barres // …)
au lieu de 'base_url' => '',

En corrigeant cela, j’ai maintenant tous les indicateurs au vert sur la page /api/

Merci @Gofannon !

J’ai envoyé un message à @plopoyop pour lui indiquer nos échanges et suggestions.

2 Likes
#8

Salut,
J’ai suivi la conversation de loin, je bouge pas mal en ce moment et donc je ne suis pas trop présent.
Je suis en train de cleaner le package en utilisant les dernières recommandations. Je pense qu’avec les derniers helpers ce problème devrait être corrigé.
Je n’ai pas encore eu le temps de tout tester comme il faut et j’ai des soucis quand j’utilse package_checker en local (je n’ai pas les mêmes résulats que la CI)

Mais promis le package est encore maintenu (en particulier sur le suivit de version de freshrss).

4 Likes
#9

Pour compléter et complexifier la discussion…

En fait, si je suis connecté à Yunohost et que je teste https://exemple.tld/rss/api/ alors j’ai tous les signaux verts !
Si je ne suis pas connecté à Yunohost et je teste https://exemple.tld/rss/api/ alors j’ai des points d’interrogations à la place des “check” vert

Et si connecté ou pas, je teste https://exemple.tld/rss/api/greader.php/check/compatibility alors je tombe invariablement sur FAIL get HTTP Authorization header! Wrong Web server configuration.

Et je ne peux toujours pas me connecter avec l’appli mobile FreshRSS (https://git.feneas.org/christophehenry/freshrss-android)

Bref, nous aurons besoin des lumières de @plopoyop pour résoudre durablement ces soucis de connexions.

Je vais quand même tester ce soir en rendant l’application publique avec
yunohost app setting freshrss is_public -v 0
Peut-être cela résoudra-t-il ce problème de connexion…

#10

Bonjour,

Une nouvelle version de FreshRSS vient de sortir (https://f-droid.org/fr/packages/fr.chenry.android.freshrss/)
… et la connexion marche désormais !

Il me semble donc que la recommandation de @Gofannon de modifier le fichier ./data/config.php pour changer la variable
'base_url' => 'adresse_de_mon_serveur//rss', (avec les deux barres // …)
avec 'base_url' => '',

suffit à rendre FreshRSS accessible aux appli extérieures utilisant l’API.

Merci merci !

FreshRss with EasyRSS
#11

Hello @croulibri cela n’a pas fonctionné chez moi, juste l’api fever fonctionner mais pas greader ?
J’ai pourtant suivi la recommandation de @Gofannon

Avez vous des pistes ? Je vais tenter une reinstallation ce soir

#12

Qu’est-ce qui s’affiche quand tu vas sur la page /api/ ? Tu pourrais poster une capture d’écran comme je l’avais fais? (Ou dire si tu as les coche vertes déjà)

Pour info, FreshRSS est installé chez moi sous cette forme : https://example.com/news/

Pour info, les coches vertes ne s’affichent que je suis connecté à YunoHost. En mode navigation privée, j’ai des points d’interrogation à la place

#13

La réinstallation n’a rien donné, problème identique. Voilà ce que ça donne avec le fichier config.php :
Sans%20titre

Tout en sachant qu’en laissant la ligne d’origine j’en suis toujours à ce problème là :

#14

Salut,
Peux tu nous copier la dernier version de ton fichier : /var/www/freshrss/data/config.php stp.

A priori, j’ai une erreur dans le package (j’espère avoir le temps de résoudre le problème bientôt) qui donne une mauvaise valeur pour base url.

J’ai l’impressin que les API fonctionnent, soit quand le paramètre n’est pas mis, soit quand sa valeur nest pas fausse. (si je ne me trompe pas, il y a un double / mis quelque part).

1 Like
#15

Salut @plopoyop voici la version de config.php

<?php
return array (
'salt' => '53aeca72c097c84137ee6ca11179cf3c2680eb77',
'db' => 
array (
'type' => 'mysql',
'host' => 'localhost',
'user' => 'freshrss',
'password' => 'mGFOkXpAnvWecXZMAOGCdBS5',
'base' => 'freshrss',
'prefix' => 'freshrss_',
'pdo_options' => 
array (
 ),
 ),
'environment' => 'production',
'base_url' => '',
'title' => 'FreshRSS',
'default_user' => 'plumf',
'auth_type' => 'http_auth',
'api_enabled' => true,
'pubsubhubbub_enabled' => true,
);
#16

La base url n’est pas renseignée, si j’ai bien compris c’est nécessaire pour le bon fonctionnement de l’app mobile

#17

La base URL c’est mon le domaine de l’application ? actus.monserveur.ndd ??