FreshRss with EasyRSS

en
#7

thks @tiemay but not worked the link.
i try to edit the opml file and split categories to less feeds,not worked, change the ttrss -reader app for version 1.84.1 from f-droid seems working better than the version i have installed before.
the feeds load and after a while they disappear in categories,and become in a grey color,the total number of all articles dont match with the browser,sometimes fetch all the category but they disappear without doing nothing.
i still think this is a problem with the api dealing with some urls,maybe if try delete more categories…or just find what urls the api dont deal well i can make this usable.
better stay with the browser,the app for android need more code work.

#8

Do you have any issues with a different rss feed reader like quiterss?

This script might help you find problematic feeds:

#!/bin/bash

##
# Required packages: xml2 wget subversion python 2.2 or later
##

# Set this to the location of your opml file.
opmlFile="./my.opml"

# Make sure feed validator is downloaded and ready.
if [[ ! -e ./feedvalidator-code/ ]]; then
  echo "[info] downloading FeedValidator..."
  svn checkout svn://svn.code.sf.net/p/feedvalidator/code/trunk feedvalidator-code
fi

# bash alone isn't good at parsing xml, so lets format it in a way bash can better manage.
echo "[info] parsing opml file..."
xml2 < "${opmlFile}" > "${opmlFile}.flat"
urls=( $(grep '@xmlUrl=' "${opmlFile}.flat" | cut -d '=' -f2- ) )

echo "[info] making sure RSS feed URLs exist..."
for url in "${urls[@]}"; do

  echo "[checking] ${url}"
  # wget -O - -q downloads the rss feed to stdout, then >/dev/null sends stdout to Tartarus.
  wget -O - -q "${url}" >/dev/null

  if [[ ! ${?} == 0 ]]; then
    echo "ERROR: there was a problem downloading: ${url}"

    # Remove broken urls from list so they don't try to get validated below.
    urls=( "${urls[@]/${url}}" )
  fi
done

echo "[info] validating existing RSS feed URLs..."
for url in ${urls[@]}; do
  python ./feedvalidator-code/feedvalidator/src/demo.py "${url}"
done


You’ll need xml2, wget, subversion, and python 2.2 or later installed for it to work. It uses the same RSS validator as on w3c, though unfortunately, the local version seems to only spit out the warnings and errors, and doesn’t summarize them like the web application does. This page has a list of the errors and warnings the validator may throw.

#9

Look nice quiterss,but not have api for android.
i think i tried some months ago and never get this feedvalidator working,that you are talking about.
But maybe i will try tomorrow again, in other machine.
thanks for your answer,Tiemay

#10

What I meant to ask was, if you import the opml file to quiterss, does quiterss give any errors?

Where you able to run the script I posted?

#11

hey tiemay,
i dont see why i need to install another feed reader,im using yunohost,the app need to be prepared to work here,and the quiterss is not build for use here,you can check here the example how to build a app for yunohost: https://github.com/Kloadut/example_ynh
do you use yunohost? is not dificult make a app if you want! see u:)

#12

I’m just wondering if your opml file works ok with a different feed reader, because if it does, then the issue probably isn’t the opml file, or your feeds.

#13

yes works in every feed reader.

#14

Easyrss app for android is working with yunohost.

Need to configure password for api in freshrss “Profile” menu
(e.g., for mobile apps)

The url for easy rss is :
https://yourdomain/rss/api/greader.php

.

#15

for me it’s still not work, I configure a password for api, I have activate the api, but connection still failed from easy rss (I install it from Fdroid).

#16

sorry cant help you more,maybe you are not putting the correct url,here works im using from fdroid too.
here the thread https://github.com/plopoyop/freshrss_ynh/issues/7

#18

@cabbes I just found out what was wrong:
Edit this file: /etc/nginx/conf.d/yourdomain.d/freshrss.conf

And under PATH_INFO add this line:
fastcgi_param PATH_TRANSLATED $document_root$fastcgi_path_info;

It’s working for me

#19

@thomas mine nginx freshrss.conf ,dont have the line,and works with no problems,can you tell me ,what advantages i will have adding that line?

#20

I don’t know what are the advantages of this line precisely. FreshRSS wasn’t working with EasyRSS and I found that line in the issues on the FreshRSS Github and now it’s working That’s all :smile:

#21

uhmm…glad that is working for you now,you put me here trying to find what´s for that line…we are always learning in life,well for me, if works don’t mess with it, i move ahead and keep going:)

#22

Following this works fine.
Thanks

#23

Not for me :confused:

even if I add
fastcgi_param PATH_TRANSLATED$document_root$fastcgi_path_info;

in /etc/nginx/conf.d/yourdomain.d/freshrss.conf

#24

Same problem here, cannot make easyrss work with freshrss :(. really strange…

EDIT: my bad, it’s working perfectly after following this:

#25

I think I have found a bug in raspberry yunohost implementation for freshrss with the api (to use with easyrss).

I had a yunohost installation on a virtualbox image and freshrss + api for easyrss worked fine.

Then I migrated the configuration of this installation on a freshly installed yunohost on raspberry and freshrss + api did not work: I am obtaining this error checking the api in freshrss configuration:

FAIL get HTTP Authorization header! Wrong Web server configuration."

First php-fpm was lacking, so I installed but it was not working the same.

I checked also the official documentation for freshrss (https://freshrss.github.io/FreshRSS/en/admins/02_Installation.html) and there is a little difference with the yunohost nginx configuration.

The line in

conf.d/domain.d/freshrss.conf

is

fastcgi_pass unix:/var/run/php/php-fpm-freshrss.sock;

Instead in official documentation is

fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;

but this does not work in raspberry.

Any ideas?

FreshRSS / Webserver configuration for using mobile app
#26

Maybe have a look at Rendre public FreshRSS

For the Android App FreshRSS, the solution was to modify the file ./data/config.php pour changer la variable
'base_url' => 'adresse_de_mon_serveur//rss',
with 'base_url' => '',

It might be the same problem for EasyRSS

#27

No, as I wrote in the another thread, it does not work form me on a raspberry installation.

It worked fine on a virtualbox installation.