Raspberri Pi 4 en ARMv7 au lieu de ARMv8

Salut à vous,

Un truc m’échappe à propos de l’architecture sur Rasp Pi 4.
Déjà, ce modèle est censé être un ARMv8 (64bits)

Via le site j’ai installé cette image:
64 bits - Rpi 3, 4 or zero 2W
https://build.yunohost.org/yunohost-bullseye-11.0.10-rpi-stable.img.zip

Mes logs confirment que je suis bien en v11 cependant lorsque je vérifie dans la console, le système me répond armv7 (32bits).

Je voudrais être en 64 bits car certaines appli ne supportent plus le 32 bits.

Est-ce que j’ai loupé quelque chose ?

Par avance merci.

Bonsoir,

Si tu souhaites repartir de “zéro” ou presque tu peux regarder par ici :

Le lien actualisé :
https://downloads.raspberrypi.org/raspios_lite_arm64/images/raspios_lite_arm64-2022-09-26/
ou bien directement
https://downloads.raspberrypi.org/raspios_lite_arm64/images/raspios_lite_arm64-2022-09-26/2022-09-22-raspios-bullseye-arm64-lite.img.xz

Sinon, si tu souhaites essayer de garder le plus de choses possibles (ça dépend des applications installées), tu peux regarder ici :

Grosso modo le principe est de faire une sauvegarde via YunoHost (Sauvegardes, Archives locales, Nouvelle sauvegarde), la télécharger ailleurs que sur ton Raspberry Pi (ceinture), (et bretelles) voire pour essayer de faire un coup de “dd” ou un clonage complet de la carte SD au cas ou, tout réinstaller de zéro sur une base 64 bits (Installer YunoHost | Yunohost Documentation) et de restaurer ta sauvegarde préalablement téléchargée (https://yunohost.org/fr/backup#restaurer).

ppr

1 Like

Merci beaucoup pour ton aide.
Radical comme résolution :smile:

Ca n’explique pas le bouzin, parce que je pense m’y être bien pris, mais ca peut effectivement résoudre le soucis.
Je vais faire des tests sur une autre SD que je viens de commander et reviendrai poster mes retours :wink:

Salut,

Je suis reparti sur une full install de l’image Yunohost 64bits, histoire de voir si ca me remettait en 32bits pour x raison.
Cette fois mon serveur est bien reconnu en arch64.

Bon, maintenant c’est la galère du backup qui ne fonctionne pas de 32 en 64 pour les apps et des bugs divers.

Bref, ca n’explique pas pourquoi j’étais en 32bits mais on va dire qu’au moins c’est réglé.

Merci.

Regarde de ce côté : Migration 32 bits to 64 bits - #3 by tituspijean

1 Like