Problem with upgrade


My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version: ?? i don’t know
I have access to my server : direct access via keyboard
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : when trying to upgrade

So my yunohost webadmin was really slow and I couldn’t charge the upgrade page so I ran the update via console with ssh. But I think this is where I messed up I upgrade with sudo apt-get dist-upgrade and it removed

yunohost python-requests (due to yunohost) openssl (due to yunohost) ca-certificates (due to yunohost) libnss-ldapd (due to yunohost) libpam-ldapd (due to yunohost) postfix (due to yunohost) postfix-ldap (due to yunohost) postfix-policyd-spf-perl (due to yunohost) postfix-pcre (due to yunohost) dovecot-core (due to yunohost) dovecot-ldap (due to yunohost) dovecot-lmtpd (due to yunohost) dovecot-managesieved (due to yunohost) dovecot-antispam (due to yunohost) rspamd (due to yunohost) metronome (due to yunohost)

Now I don’t have access in ssh, not even in local. I can’t make yunohost command : its says

yunohost : command not found

When I turn on the raspberry it ask me to make the postinstallation configuration.
When I try to it doesn’t work via console and web in local

So I search for similar problems so tried to sudo systemctl status yunohost-api. It told that

unit is masked

so I tried to touch /etc/yunohost/installed but nothing happend and api still masked.
So I tried to apt install yunohost-admin and then it told me :

Some packages could not be installed. This may mean that you have requested packages have not yet been created or been moved out of Incoming.

AND that

yunohost-admin: depends : yunohost(>= 4.0.0~alpha) but it is not going to be installed. E : unable to correct problems, you have held broken packages

What can I do ?

Thanks in advence

(Text in English below)

Bonsoir, pour la version de Yunohost il faut faire :

sudo yunohost -v

Et sinon pour les mises à jours la documentation conseille :

sudo yunohost tools update


sudo yunohost tools upgrade --system


Good evening,
for the version of Yunohost it is necessary to do

sudo yunohost -v

And if not for updates the documentation advice :

sudo yunohost tools update


sudo yunohost tools upgrade --system


Hello Gaëtan, je ne peux pas faire de commande yunohost, cela me dit que

yunohost : command not found

Merci de votre aide
Bonne soirée à vous


Même avec un sudo devant ?


So I tried to apt upgrade and then apt install yunohost but it doesn’t work :

Oui même avec sudo


Ok par contre pour l’installation de Yunohost il faut suivre la documentation. Mais si il y était déjà pas besoin de le réinstaller.

Voyons le résultat de cette commande :

ls -al /home/


What does this says ?

apt install yunohost metronome postfix dovecot-core openssl

J’ai tous les utilisateurs et les fichiers yunohost

I have all the users and yunohost config files


Et que donne :

apt --fix-broken install

You need to downgrade the openssl version (not sure how you managed to install it in the first place … when yunohost is about to be uninstalled, apt is supposed to warn you that this is probably not what you want and ask you to type ‘Do as I say!’ if you’re absolutely sure that this is your intention …)

Anyway …

Let’s look at the available openssl version with apt policy openssl

Then downgrade to the vanilla debian version (it should be the version which does NOT has all the super-complex ~20201212.21blabhablha.gbpc1d96 prefix …) with :

apt install openssl=<the_appropriate_version> --allow-downgrades


I think :

apt install openssl=1.1.1d-0+deb10u4 --allow-downgrades

1 Like

I’m going to test that tomorrow around 18:30, it’s gating late

Good night
And thanks for helping !


Good night, okay, we’ll see that tomorrow.


I done it and then apt install yunohost-admin
For now it says

su : user admin does not exist

and the progession doesn’t move anymore

I can now made yunohost command so I did the system upgrade
And when I make yunohost user list I can see all the users except apps user and admin

Ok I continue to try to make it work and everything seems back. Thanks a lot for your help !!

But when I try to make a backup it says

user “admin” is unknown

So I can’t make app upgrade
I can log into the admin interface but not with ssh

And I also have a problem with openssl

Failed to get status information via dbus for service postgresql@11-main, systemctl didn’t recognize this service (‘NoSuchUnit’).

And I can’t migrate:

    1. Migrer les anciennes règles de trafic réseau vers le nouveau système basé sur nftables
    1. Migrer les bases de données de PostgreSQL 9.6 vers 11
    1. Migrer les configurations php7.0 vers php7.3
    1. Mise à niveau du système vers Debian Buster et YunoHost 4.x

What can I do ?
Thanks in advance