Postfix : connection refused

,

Hi all,

After a migration to YUNOHOST 2.4, I have issue with mails :

here is a sample of my mail log :
postfix/smtp[3357]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused

Mail returned with connection refused and I cannot log into roundcube any more.

DATABASE ERROR: CONNECTION FAILED!
Unable to connect to the database!
Please contact your server-administrator.

I check this topic [RESOLVED] Mail returned with connection refused and restart amavis too, but looks like it’s not enough.

I create a new user to test, and it’s the same.

I don’t know what to check / try to fix this.

Postefix / dovecot or ldap configuration error ?

Any idea ?

Thanks
Cyril

yunohost: 2.4.2
yunohost-admin: 2.4.2
moulinette: 2.4.0.1
ssowat: 2.6.0

It’s like in this post : [SOLVED] Mail : Amavis FAILED: Unix utility file(1) not available

It’s because of amavisd-new that wasn’t installed
So I ran this

and now I can use my mail with thunderbird.
But I can’t use Roundcube.

In the log /var/www/roundcube/logs/errors

I can see :
[27-Oct-2016 17:27:56 +0200]: <2fjf1s8k> DB Error: [1146] Table 'roundcube.carddav_addressbooks' doesn't exist (POST /webmail/?_task=mail&_action=plugin.newusersave)

Looks like I need this to create missing tables :

But I don’t have dbinit/mysql.sql in the carddav folder.

Okay … It’s working now.
I just remove Baikal and roundcube and reinstall it, I haven’t done anything else and it’s working … I can login to roundcube.

I still have 2 others issues : I can’t login to Agendav (Erreur interne du serveur) and I getting email about "Le suivi de l’état du serveur n’est pas activé"
But I may create new topic to follow this error … should I ?

Cyril

Finally it’s not working at all. I don’t receive any email and I cannot use my calendar.

I’m restarting from scratch.

Emails and calendar are store in Thunderbird. I did a back of events in an ICS files.

Cyril