Post-installation AVANT mise à jour

,

Bonjour,

Je souhaite faire une remarque qui pourra sûrement aider du monde.

J’ai en effet cassé toutes les installations que j’essayais en suivant le tuto qui indique qu’il faut procéder aux mises à jour avant la post-installation :

https://yunohost.org/#/install_on_olinuxino_fr

Au bout d’un certain nombre de tentatives, par chance, je me suis dit que j’allais faire le contraire et tout fonctionne parfairement et c’est très propre !

Alors j’ai fait une demande pour modifier le tuto mais le lien qui m’a été envoyé pour confirmer mon adresse mail ne fonctionne pas…

Je laisse donc l’information ici.

Bonne soirée.

Salut,

ben du coup c’est pas le comportement attendu, ca devrait marcher :s …

Pourquoi est-ce que ça “cassait toutes les installations” ?

J’avais expliqué comme je pouvais le soucis dans ce post :

Pour résumer, impossible d’installer quelque application que ce soit, des messages d’erreur à tout va et même chose lorsque j’essayais d’afficher les infos sur un utilisateur nouvellement crée ou bien lorsque j’essayais par exemple : yunohost service status…

Ça a été reproductible plusieurs fois et réglé dès que j’ai fait la post-install avant les mises-à-jour. Je crois me souvenir que la post-installation n’allait d’ailleurs pas au bout avec plusieurs messages d’erreur lorsque je la faisais après l’upgrade.

Sinon, tant que j’y pense, j’avais aussi fait l’erreur de formater ma carte SD en ext4 au lieu de FAT32 et ça ne bootait pas, donc je pense que ça peut être pas mal de rajouter ce détail dans le tuto.

Hmoké, c’est assez mystérieux tout ça x) Ça mériterais qu’on investigue de notre côté pour régler ça…

Donc pour résumer, tu as :

  • pris une carte OLinuXino
  • flasher ta SD
  • booter la carte
  • fais un update et dist-upgrade
  • fais la postinstall

et là tu as eu pleins de problème ?

C’est tout à fait ça.
Je vais voir si éventuellement je peux reproduire le soucis dans une virtualbox.