Plex app - Support

,

Hi,

First of all, thanks for the great work :slight_smile: I really enjoy playing with YunoHost.

Now, I need help :wink:

I’m working on a new plex app script, as the one proposed on YunoHost app list is not working at all and contains losts of mistakes.

My script is working, installation, domain integration.

The only problem I have is that currently Plex SSL connexion is broken. If you connect to your plex server trough the web app over SSL, you will not be able to do anything,

Is their a way to force an app to be launched in HTTP and how to integrate that in my app package

Thanks for your help

Nova

Thanks to Kload issue has been resolved,

I’ve added the following line to the install script:
sudo yunohost app setting plexmediaserver skipped_uris -v “/”

SSO is desactivated so plex will handle authentification on his own

Package for plex is fully working now and can be installed from the following url:

Hi

I get 502 Bad Gateway error after installation.

Hi Kanku,

Do you install it at subdomain root or not?

@novakin Please note that it is not a free and open source app. Thus it won’t be integrated as an official app.

But thank you for the work! :slight_smile:

Yes no problem, i still have some small problems with my app anyway :)))))

Kanku, can you please update packages, remove and reinstall the app?

@Novakin I reinstalled with path to install as root, but it is giving the same error 502 Bad Gateway.

@kanhu can you please launch the following command: sudo service plexmediaserver start?

And then try again to access your app.

it works now but , I can not login plex media server nor my other installed packages work.

Do you have a plex account ? If you dont please sign up here

@Novakin can I install the package to any other path than root (eg. /media) ?

@kanhu unfortunately this is not possible for the moment.

hi, when i lauch the command you talk about, i got this : Plex already running…
But i still can’t access to the app, i got 404 not found, any idea ?
thx,

Hi, did you installed on a dedicated domain or subdomain ?

Please also check the github readme, https://github.com/Novakin/plexmediaserver_ynh

You will find some usefull info.

I just have tested on a VM with an local domain, it is working fine.

Keep me updated if it still does not work

Thx for your quick answer,

so i uninstalled plex, and when i try to reinstall following the instructions, i got an error :

  • domain=okokok.nohost.me
  • path=/
  • sudo yunohost app checkurl okokok.nohost.me/ -a plexmediaserver
  • [[ ! 0 -eq 0 ]]
  • sudo yunohost app checkport 32400Error: Port 32400 is not available
  • [[ ! 22 -eq 0 ]]+ exit 1

I tried to open the 32400 port manually (with the YH tool), but it does not change anything,
any idea ? thx :slight_smile:

Can you at least connect to plexmediaserver via your local ip ?

https://192.168.xxx.xxx:32400/web

Please also check the firewall in the admin panel, desactivate the upnp and open ports 32400

hum, and i may have installed first this plex : https://github.com/Chao-Man/plexmediaserver_ynh
(the one that i uninstalled), if it may help

Maybe you should try delete the package once again, delete the concerned domain, erase ports from the firewall look for any file linked to plexmediaserver and the domain in order to delete them, and then try to install it again.

Hi again,
i deleted manually the previous package, nothing left on the server, and tried again to install your plex on ynh. but i got the same error about the port.

don’t what to do with these ports, im not sure to understand what you mean by “erase ports from the firewall”

Did you try to remove the open ports before launching the installation ?