Pi Zero - manual installation of metronome fails


#1

I tried to follow the steps for installation for the Raspberry Pi Zero on https://yunohost.org/#/install_on_raspberry including the metronome Installation by hand:

Either with or without sudo it fails @0.1 line 5:

~/metronome-debian-3.7.9-33b7572-1 $ sudo dpkg-buildpackage -rfakeroot -uc -b -d
dpkg-buildpackage: warning: using a gain-root-command while being root
dpkg-buildpackage: source package metronome
dpkg-buildpackage: source version 3.7.9+33b7572-1
dpkg-buildpackage: source distribution testing
dpkg-buildpackage: source changed by Jérôme Lebleu jerome@yunohost.org
dpkg-buildpackage: host architecture armhf
dpkg-source --before-build metronome-debian-3.7.9-33b7572-1
fakeroot debian/rules clean
dh --with quilt clean
make: dh: Command not found
debian/rules:7: recipe for target ‘clean’ failed
make: *** [clean] Error 127
dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2

(in general: 1st line must be executed with sudo?!)

The Pi Zero has the latest headless Raspbian Jessie lite Image 2017-01-11 from https://www.raspberrypi.org/downloads/raspbian/

Any ideas?


Glances is running but unable to connect
#2

@no.1 Hmm that’s weird, these steps were working without any problem with the Raspbian from september. It seems that you are missing the dh-make package, run sudo apt-get install dh-make to fix that and try again.

If that didn’t work, then these commands should do the trick:

wget -q https://raw.githubusercontent.com/likeitneverwentaway/rpi_buildbot/master/metronome_3.7.9+33b7572-1_armhf.deb

dpkg -i metronome_3.7.9+33b7572-1_armhf.deb

apt-mark hold metronome

Good luck!


#3

Hi,
You need to install dh-autoreconf and quilt:

apt-get install dh-autoreconf quilt
:wink:


#4

Echec sur mon Raspberry pi zero w :
Le paquet libssl1.0.0 n’est pas installé.
dpkg: erreur de traitement du paquet metronome (–install) :
problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour systemd (232-25+deb9u1) …
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) …
Des erreurs ont été rencontrées pendant l’exécution :
metronome


#5

Thanks fir the tip…

But it didn’t help for my raspberry pi zero w

Same problem with metronome


#6

Hi @arnal ,

Try to install YunoHost from the last Jessie image :
https://downloads.raspberrypi.org/raspbian_lite/images/raspbian_lite-2017-07-05/

Old french “how to” there :
https://avignu.wiki.tuxfamily.org/doku.php?id=documentation:yunohost-jessie-v2.5.x-rpi3b

WARNING : you have to check your /etc/apt/sources.list before update/upgrade in order to DO NOT upgrade to Stretch.

ppr


#7

Thanks ! I’ll use your tip and tell you if I can install Yunohost on the raspberry pi zero w :slight_smile:


#8

I have the same issue but I’m not getting further than this:

pi@raspberrypi:~ $ sudo apt-get install ./metronome_3.7.9+33b7572-1_armhf.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'metronome' instead of './metronome_3.7.9+33b7572-1_armhf.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 metronome : Depends: libssl1.0.0 (>= 1.0.0) but it is not installable
             Recommends: lua-zlib but it is not going to be installed
             Recommends: lua-bitop but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

here are some devices stats
Linux raspberrypi 4.9.80-v7+ #1098 SMP Fri Mar 9 19:11:42 GMT 2018 armv7l GNU/Linux

neofetch

  .',;:cc;,'.    .,;::c:,,.    pi@raspberrypi
 ,ooolcloooo:  'oooooccloo:    --------------
 .looooc;;:ol  :oc;;:ooooo'    OS: Raspbian GNU/Linux 9.4 (stretch) armv7l
   ;oooooo:      ,ooooooc.     Model: Raspberry Pi 3 Model B Rev 1.2
     .,:;'.       .;:;'.       Kernel: 4.9.80-v7+
     .... ..'''''. ....        Uptime: 2 hours, 51 minutes
   .''.   ..'''''.  ..''.      Packages: 481
   ..  .....    .....  ..      Shell: bash 4.4.12
  .  .'''''''  .''''''.  .     CPU: ARMv7 rev 4 (v7l) (4) @ 1.2GHz
.'' .''''''''  .'''''''. ''.   Memory: 67MB / 927MB
'''  '''''''    .''''''  '''   ​
.'    ........... ...    .'.   ████████████████████████
  ....    ''''''''.   .''.     ​
  '''''.  ''''''''. .''''' 
   '''''.  .'''''. .'''''. 
    ..''.     .    .''.. 
          .''''''' 
           ...... 

#9

Hi @lil5 ,

YunoHost is not yet fully compatible with Stretch … but it might be soon.
For now, you can try to install YunoHost stable based on Jessie.
A translate tutorial here in order to
https://avignu.wiki.tuxfamily.org/doku.php?id=documentation:yunohost-jessie-v2.7.x-rpi_en
I hope it could helps you.

ppr