Glances is running but unable to connect


#1

Another small topic after my installation (on a C.H.I.P. NTC, fresh Installation, with latest updates) is running with a subdomain (instead of localhost/internal IP):
If I click on Diagnosis a “diagnosis_monitor_system_error” appears at the top of browser window and a Monitoring click reports an “Connection to glances not possible”. Glances is running due to the diagnosis report:

{
“host”: “Debian 8.7”,
“kernel”: “4.4.13-ntc-mlc”,
“packages”: {
“yunohost”: “2.4.2”,
“yunohost-admin”: “2.4.2”,
“moulinette”: “2.4.0.1”,
“ssowat”: “2.6.0”
},
“system”: {},
“services”: {
“glances”: “running (enabled)”,
“udisks2”: “inactive (not-found)”,
“nslcd”: “running (enabled)”,
“metronome”: “running (enabled)”,
“ssl”: “inactive (not-found)”,
“postfix”: “running (enabled)”,
“rspamd”: “running (enabled)”,
“yunohost-firewall”: “running (disabled)”,
“nsswitch”: “inactive (not-found)”,
“rmilter”: “running (enabled)”,
“slapd”: “running (enabled)”,
“dnsmasq”: “running (enabled)”,
“fail2ban”: “running (enabled)”,
“yunohost-api”: “running (enabled)”,
“mysql”: “running (enabled)”,
“avahi-daemon”: “running (enabled)”,
“dovecot”: “running (enabled)”,
“redis-server”: “running (enabled)”,
“nginx”: “running (enabled)”,
“php5-fpm”: “running (enabled)”,
“ssh”: “running (enabled)”
},
“applications”: {
“owncloud”: “OwnCloud”,
“wordpress”: “WordPress”,
“jirafeau”: “Jirafeau”,
“kanboard”: “Kanboard”
}
}

Any ideas what I should check or provide (logs/other output)?


#2

Try to replicate the issue, maybe something will come up in /var/log/yunohost/yunohost-cli.log or yunohost-api.log.


#3

Thanks a lot for your input. I wil try that later on.
I found a working Pi Zero Image so currently I’m working on that (which replaces also my metronome request for the time beeing Pi Zero - manual installation of metronome fails). Now I have another topic about reverse proxy to a NAS but that’s a different Story.
Thx again for your help