Pi-Hole not working after install & configuration

:uk:/:us: Pi-hole not working after install

My YunoHost server

Hardware: Raspberry: Pi4B 8GB
YunoHost version: 4.3.6.2
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain: not applicable

Description of my issue

Dear community,
I installed Pi-Hole for Yunohost a few times with different combinations (3.X, last available). Currently, I am only able to install the last avaliable version, normal access is given via SSH and webUI to the raspberry as well as to other applications.
I included Upstream DNS provider as well as changed local DNS to the IP of the raspberry at my router (Fritz!Box (EN) - Pi-hole documentation).

Problems (link to error log Sign in to GitHub · GitHub):

Right now I have no idea how to solve this. Based on online description & guides it should be easy to use Pi-Hole with Yunohost.
So my last hope is the commnity :slight_smile:
Did anybody have similar problems? Any idea what I can try next?

Thank you in advance,
Markus

Hi Markus,

Welcome to the forums!

Could you tell:

What do you mean by ‘different combinations’? The Pi-Hole version that shows up on my Yunohost (also 4.3.6.2), is 5.x instead of 3.x… Wait, in the readme it says:

That is the version you got now, right?

More specific, local network via DNS/local name resoluton (to other computers in the LAN) as well as by IP, and for the internet, neither DNS nor IP?

Is there missing something behind Pi-hole webUI? So, according to Yunohost, Pi-hole is not running. I guess that starting the service has no effect? Do you know how to check the logs (perhaps in the Yunohost web interface, otherwise via SSH, journalctl, for example) after that?

Finally, Pi-hole can run as a DNS and a DHCP server, but DHCP is optional. If you do not need local name resolution, you could keep DHCP in your Fritzbox. You do not mention that your Yunohost has a static IP, is that the case?
Could you try

  • disabling DHCP on Pi-Hole
  • enabling DHCP on Fritzbox
  • give Yunohost a static IP in Fritzbox
  • make your computer use Yunohost/Pi-hole as DHCP (either by pointing Fritzbox’s DNS to Yunohost’s IP, or by pointing your computer’s DNS to Yunohost)

Does that give different results?

Sorry for all the questions. Good luck!

Sorry, not a good description on my end.

No, at the Pi-Hole install page in Yunohost one can choose between “3.X” and “last available”
I went with “last available”, since for 3.X there was an install error.
Just tried again during lunch break with the same result (log for 3.X install https://paste.yunohost.org/raw/tulizofofe). With “last available” install worked again.


Comment: 5.4|~ynh1 is not a field I can change.


With “last available” I have the following versions installed:

I was able to access the modem (via fritz.box or IP), the raspberry via static IP and an openwrt (dumb) access point via IP as well.
The raspberry is connected via LAN, not directly but via an access point: modem/Fritzbox–>OpenWRT (dumb access point)–>raspberry

Not Pi-Hole itself, loghttpd and dnsmasq are the only Yunohost services on the admin page which are not running. Funny thing is that I am able to access Pi-Hole web interface, define white-/blacklist, run debug, … so normal access is given.
I restarted the raspberry, the services (always with an error and they stayed excited) and there also was “restart” opion in Pi-hole webUI. Nothing changed

Not right now, but I think I need to dig into it (especially the 3.X install error).

Yes, gave the raspberry a static IP via modem/Fritzbox

My current setup was that I always kept the DHCP with the Fritzbox (so in case there is something wrong with the server I can fix it faster). Pi-Hole DHCP was alwys disabled.

I will try this tonight and report back

No worries, this is the only way to proceed :slight_smile:

Thank you for your input and help!

Tried the DHCP in Pi-Hole. Deactivated it on the modem/Fritzbox and activated it in Pi-Hole. After reconnecting to the network no internet connection was possible. I was still able to access the modem/Frotzbox via IP and fritz.box via WiFi. as well as raspberry via SSH (also WiFi).

Most unfortunate!

Reading the readme on the Yunohost-Pihole package, it might be broken now. With Pihole bringing its own dnsmasq, maybe the maintenance work was more of a rewrite in order to not break Yunohost, and the package got unmaintained as a result:

  • Pihole 3.x won’t install, because something is broken (according to what you tell, I did not test it myself);
  • Pihole 5.x will install, but breaks Yunohost

You could have a look at Adguard instead. I am not familiar with it, but it is listed as adblocker in the app catalog.

Pihole 5.x will install, but breaks Yunohost

I experienced this.

I have a small SMC computer and installed Diet Pi on it and Pihole. It supports my core Yunohost server on my network.

It was handy having Pi-hole on Yunohost before, but it’s not working well now.

1 Like

Thank you both for your replies

The one thing I did not want to hear but need to hear :wink:
I will start from scratch and after setting up only basic Yunohost (and this time making a backup image of the SD card) I want to install Pi-Hole again. First the 3.X version and testing the system. After this using the backup image and try the same with the 5.X/latest version. I want or maybe need to know which one works

I will try this over the next week and will report my findings - just in case anybody has similar problems and fstumbles into this thread.

@arkadi: so 3.x was working fine and after an update you had problems? is 5.x working not at all or with some problems?

Good luck!

Out of interest: what is your first priority? Having an adblocker running, having a platform for your online presence, or having the specific combination of Yunohost with Pihole, or of course another goal?

3.x was working pretty well for a long time. I had to reinstall and used the new version but then a yunohost update kinda broke my installation. I did a fresh install of Yunohost and things worked better so I didn’t risk reinstalling Pihole. Wasn’t sure whether to do 3.x or 5.x. Too much uncertainty for me atm. I had extra SBC lying around so made a little pihole.

Short answer: combination

Long answer: as with so many things it is work in progress with many variations. Previously had adblock on my OpenWrt Router and a modem from my ISP. But I was not satisfied with the ISP modem and the WiFi was not that good. Then the raspberry came, which I wanted to use as an Google Photos alternative (via Photoview) and Nextcloud. When I read about Yunohost, I wanted to go into this direction, since the package was much more interesting (and easier :slight_smile: )

Next adaptation came when I ordered a used Fritzbox 7530 (where OpenWrt is available) and received a 7590. I went with it, replaced my ISP modem, used the “old” OpenWrt as a dumb access point (for WiFi roaming, real mesh is atm not possible) and want to use the Raspberry as an adblocker. Now the WiFi is much better, but the adblocker is missing for the moment. On the upside: I have a new project with the Raspberry configuration :wink:

1 Like

Thanks for the info. Let’s see how it goes with, finished the fresh Yunohost install and just started the process for 5.X installation

1 Like

Hey, I didn’t know that! Nice :slight_smile:

I just had a look and found 7530, does it also run on 7590?

In the long answer, I don’t read that it has to be Pihole as an adblocker. Did you have a look at Adguard? (I tried embedding an ‘install with Yunohost’-link, don’t get startled when you click it)

It’s nice of course to get Pihole running against the odds, or to repair the app for everyone while busy, but on the other hand: it’s also nice to just get the ad blocking sorted and continue expanding your Yunohost :stuck_out_tongue:

1 Like

Just wanted to give an update in case somebody has a similar issue. Even after fresh setup of the pi, I was not able to get either Pi-Hole (3.x or 5.x) or Adguard to work with Yunohost.
Of course there is the high probability of a wrong congiguration on my end :wink:

Now I moved on from Yunohost to Docker/Portainer and it works. I will miss Yunohost, it made my life so easy, since it was really easy to use and maintain. I also really liked the simple (in a positive way) landing page, SSO feature and user management.
Finaly, a big thank you to the Yunohost developers and community, it is a wonderful server software :+1:

@wbk: Thanks for the tip, I now use this instead of Pi-Hole. Looks really good :slight_smile:

Last time I checked 7590 was not supported and I don’t have the technical skills to set it up myself. But in case it gets supported in the future, then there will be even more possibilities :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.