[Overleaf] Open-source online real-time collaborative LaTeX editor

Overleaf for YunoHost

Integration level Working status Maintenance status

Install Overleaf with YunoHost

Lire ce readme en français.

Overview

Overleaf is an open-source online real-time collaborative LaTeX editor.

Screenshots

Screenshot of Overleaf

Documentation and resources

Developer info

Please send your pull request to the testing branch.

To try the testing branch, please proceed like that.

sudo yunohost app install https://github.com/YunoHost-Apps/overleaf_ynh/tree/testing --debug
or
sudo yunohost app upgrade overleaf -u https://github.com/YunoHost-Apps/overleaf_ynh/tree/testing --debug

More info regarding app packaging: Introduction to packaging | Yunohost Documentation

2 Likes

Overleaf has recently been repackaged.
If you have an old version of the Overleaf package, I would be glad to know if the upgrade works fine.

The testing update is available by running sudo yunohost app upgrade overleaf -u https://github.com/YunoHost-Apps/overleaf_ynh/tree/testing --debug

Some observations about this update:

  • I did not try to upgrade from the latest working version (because it’s not working anymore). So I don’t garantee it will successfully upgrade (nor that your actual projects will successfully migrate).
  • I removed LDAP integration because it was difficult enough to make the package work already. BUT emails should work (tested on my end).
  • It’s working for now. I don’t garantee new versions will be easily upgradable.

You are welcome to install Overleaf by running sudo yunohost app install https://github.com/YunoHost-Apps/overleaf_ynh/tree/testing --debug

2 Likes

I just tried to do the update, and it didn’t work:
Variable $jwt_key wasn't initialized when trying to replace __JWT_KEY__ in /var/www/overleaf/variables.env

Here is the log of the update try:
https://paste.yunohost.org/raw/jisudiwomu

On the other hand, what’s funny is that, after the update failure and the removal of Overleaf by the update script, I’ve tried to install it, and it worked.

Is this package working on RPi hardware running 64bit RaspiOS?

Oh indeed, thanks for your feedback! I forgot to set the setting for upgrades from older versions.

As you installed “from scratch”, it then worked. Happy for that, I hope you will enjoy it!

It only works on a Yunohost OS, ARM should work, but it seems it doesn’t for now… Feel free to test and let us know!

I tried but it didn’t work:
https://paste.yunohost.org/raw/egazeliwaw

Yes okay, it’s because you are on ARM64… I have to find a solution…

1 Like

It seems to be the same issue as explained in this thread:

Here is my log after a failed installation on a 24GB server with ARM cpu (ampere)
paste.yunohost.org/raw/upevavebad

@Tho

I have removed testing which workes well for some time to install stable version. Unfortunately, it does not work properly. After the installation it works but any updates or installation of additional packages causing this:

To fix this, I had to reinstall Overleaf. But after reinstallation I wanted to add some new packages and I have this problem again.

I have tried to restart all overleaf services (sudo systemctl restart overleaf*) but still not working.

Can you provide service logs right after triggering the error?

Yes could you please share your logs (ideally from all overleaf services)?

Also: how do you install your additionnal packages?