OCC and Nextcloud

In this (now closed) post the use of OCC is discussed. But the solution there doesn’t work for me. Maybe because of a newer version of php…

In it that post the wiki is referenced as a place to learn more about OCC. But in the wiki there is no longer anything about OCC…

Just for my own, and other references, this command worked for me to change the default dashboard layout for all (new) users

$ sudo yunohost app shell nextcloud

$ php8.2 --define apc.enable_cli=1 occ user:setting admin dashboard layout "welcome"

3 Likes

It should be

yunohost app shell nextcloud
php occ user:setting admin dashboard layout "welcome"
2 Likes

dosch’s command works for me as well, while tituspijean’s doesn’t. Thought I’d say so in case it helps.

1 Like

Well it does not help me, since you do not show the error you get. :stuck_out_tongue: Are you up to date, also?

1 Like

Oh! Sorry, I entirely missed that somehow. I’ll grab the error right now!

nextcloud@yunohost:~$ php occ
Error in argument 1, char 1: no argument for option -
Usage: php [options] [-f] <file> [--] [args...]
... [php usage info trimmed]
apc.enable_cli=1: command not found
Full error without php usage trimmed
nextcloud@yunohost:~$ php occ
Error in argument 1, char 1: no argument for option -
Usage: php [options] [-f] <file> [--] [args...]
   php [options] -r <code> [--] [args...]
   php [options] [-B <begin_code>] -R <code> [-E <end_code>] [--] [args...]
   php [options] [-B <begin_code>] -F <file> [-E <end_code>] [--] [args...]
   php [options] -S <addr>:<port> [-t docroot] [router]
   php [options] -- [args...]
   php [options] -a

  -a               Run as interactive shell (requires readline extension)
  -c <path>|<file> Look for php.ini file in this directory
  -n               No configuration (ini) files will be used
  -d foo[=bar]     Define INI entry foo with value 'bar'
  -e               Generate extended information for debugger/profiler
  -f <file>        Parse and execute <file>.
  -h               This help
  -i               PHP information
  -l               Syntax check only (lint)
  -m               Show compiled in modules
  -r <code>        Run PHP <code> without using script tags <?..?>
  -B <begin_code>  Run PHP <begin_code> before processing input lines
  -R <code>        Run PHP <code> for every input line
  -F <file>        Parse and execute <file> for every input line
  -E <end_code>    Run PHP <end_code> after processing all input lines
  -H               Hide any passed arguments from external tools.
  -S <addr>:<port> Run with built-in web server.
  -t <docroot>     Specify document root <docroot> for built-in web server.
  -s               Output HTML syntax highlighted source.
  -v               Version number
  -w               Output source with stripped comments and whitespace.
  -z <file>        Load Zend extension <file>.

  args...          Arguments passed to script. Use -- args when first argument
                   starts with - or script is read from stdin

  --ini            Show configuration file names

  --rf <name>      Show information about function <name>.
  --rc <name>      Show information about class <name>.
  --re <name>      Show information about extension <name>.
  --rz <name>      Show information about Zend extension <name>.
  --ri <name>      Show configuration for extension <name>.

apc.enable_cli=1: command not found

Naturally, I changed my actual hostname to yunohost. And yes, I am fully updated.

Sorry about that - as well as the delayed response. I was typing out my response when my house’s power suddenly went out! Luckily it came back on soon.

1 Like

That’s very interesting, thank you!

Here is my output:

nextcloud@yunohost:~$ php occ
Nextcloud 28.0.6

Usage:
  command [options] [arguments]

Can you share the output of yunohost app setting nextcloud phpflags ?

No problem!

root@yunohost:~# yunohost app setting nextcloud phpflags 
--define;apc.enable_cli=1
root@yunohost:~# 

That’s all, hope it helps.

1 Like

That semi-colon is unexpected. Let’s fix that: yunohost app setting nextcloud phpflags -v "--define apc.enable_cli=1"
If you still have it, can you share the logs of your last Nextcloud upgrade?
You may then try again the previous commands.

1 Like

I’ll try that command. How do I get the logs for the upgrade?

Edit: Did the command and php occ worked completely as expected!

1 Like

Great!

Look into the Tools > Logs menu of the webadmin.

Sadly, I do not have the logs for my last Nextcloud upgrade. But just in case, here’s the log for my last system package upgrade. Let me know if there’s any other ways I can help!

Hello I have the same here

 yunohost app setting nextcloud phpflags
--define;apc.enable_cli=1

Your suggestion works, yunohost app setting nextcloud phpflags -v "--define apc.enable_cli=1" ! thanks

It’s really a pleasure use this, non need remember, look for all the line needed before…

1 Like

Bug confirmed to be coming from me, I’ll make a bugfix from Nextcloud’s next release.

3 Likes

Great thanks. I will wait for the update to resolve this post :
Super merci. Je vais attendre la mise à jour pour résoudre ce post :

You can safely run the fix command above by yourself. :wink: