"No space left on device": no free space on root partition

My YunoHost server

Hardware: VPS bought online
YunoHost version: 4.1.5
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

Hi all,
again, I ran into this problem: Apparently, there is no disk space left, but there is lot of unallocated disk space.

df -h shows this output:

Filesystem      Size  Used Avail Use% Mounted on
udev            3.9G     0  3.9G   0% /dev
tmpfs           798M   81M  718M  11% /run
/dev/sda3       8.8G  8.8G     0 100% /
tmpfs           3.9G     0  3.9G   0% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           3.9G     0  3.9G   0% /sys/fs/cgroup
/dev/sda2       976M   80M  829M   9% /boot
tmpfs           798M     0  798M   0% /run/user/1007

I cannot uninstall Yunohost apps nor install parted.
Are there any hints how to free some disk space?

Thank you in advance

Not sure what you mean by “lot of unallocated spaces”. All the “tmpfs” and “udev” filesystem are kinda ~internal stuff and not actual filesystems … The only relevant lines are /dev/sda3 and /dev/sda2

You can try to free up some space with apt clean which will delete some cached files

1 Like

Yeah there is no space left. Also, if this is a VPS, which one are you using? and why does it only give you 8 GB of space?!?

Also can try apt-get autoremove

You won’t be able to free up that much space though IMHO.

My VPS has 160GB of disk space. No idea why Yunohost only takes 8-9GB.

I am using Netcup “VPS 1000 G9 12M”. This includes 160GB SSD and 8GB RAM.

sudo apt-get autoremove:

Reading package lists... Error!
E: Write error - write (28: No space left on device)
E: Write error - write (28: No space left on device)
E: The package lists or status file could not be parsed or opened.

I tried to remove some Yunohost apps or test user accounts using the web admin interface, which all didn’t work due to the “full disk”.
I managed to connect with FileZilla over sftp. I could delete some files or directories, but I am not sure which ones are safe for deletion (test user accounts or apps).

can you paste the resul of fdisk -l ?
I think that the whole disk has not been fully partitionned

1 Like

fdisk is not installed:

-bash: fdisk: command not found

Yes, the disk is not fully partitioned. I thought, this would be managed by Yunohost.

No it doesn’t because Yunohost is just “a layer on top of Debian” … and Debian won’t handle the partitioning for you either … Thing is, usually when you buy a VPS it’s already properly partitioned and have nothing to do. A VPS with only 8 GB for the main root partition is kind of a joke and I’m always surprised that some VPS provider just roll with this … OR the 160GB you are mentioning is a storage extension and your VPS provider should have explained how to mount it … (But still, a VPS with 8GB for the root partition is still wtf)

1 Like

What would be a decent set of partitions for running Yunohost?

Just having a root partition with > 16 GB would be fine - or maybe 32 GB if you intend to have many apps. If you intend to have quite a lot of data - for example multimedia files - then you need to have some space for /home according to the expected usage (idk, for example if you expect to have many video file for whatever reason, maybe 100 GB on /home is important)

But anyway reworking the partition and mounting od data directories is doable later in the future - the main thing is that the root partition should not be full, because reworking the partitioning and mounting of the root partition is another story.

If you don’t have any specific plan in mind, just allocate all the space available to your root partition and you’re good to go (but I don’t know much how you’d do that in the context of your VPS, that’s somewhat specific to your VPS provider …)

1 Like

Waiting for the response of my VPS provider…

1 Like

I managed to enlarge the root partition to the complete space available by using a virtual GParted DVD on my VPS to boot from. Thank you!

Now Yunohost is running, the main apps seem to work.

But there ist an error on the web admin page: when trying to show the apps page (“https://mydomain.tld/yunohost/admin/#/apps”), no app is shown, but this error message:

Failed to read info for wordpress : exceptions must be old-style classes or derived from BaseException, not str

this is repeated for every app, about seven.

The final message is: Keine installierten Apps. (i.e.: no installed apps):

Over ssh, all apps are listed perfectly, it takes a while, though.

What can I do to repair the web admininstration of my apps?

You mean when running yunohost app list ?

Regarding the error message on the webadmin, do you see anything else ? (I think a screenshot may be helpful)

Yes, running yunohost app list listed all apps.

Meanwhile, the web admin is working well, too. So I cannot give a screenshot. I still know, there were several red lines, each with the above mentioned text:
Failed to read info for wordpress : exceptions must be old-style classes or derived from BaseException, not str, apparently for each of my apps, not only wordpress. There was no stack trace as the message complained not having an exception.

Now, I noticed, there is one service which is not running: uwsgi. It cannot be started.
The log files are here:


I am new to pastebin. This one should work:


Maybe if you run yunohost app info <someappname> --full or yunohost app list --full

(that will display a huge bunch of lines which you don’t have to share - but what i’m interested in is if errors are showing up)

The thing about uwsgi sounds unrelated