No domains and other issues

Hello fellow yuno hosters

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version: 11.0.10
I have access to my server : through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

I am trying to do a first install on my raspi 3. After initial install i have access via browser and it prompts me to complete install with admin password and domain. I asked now for multiple domain names for and, but none are available. They are not short or very generic this is why i am wondering if something is not right?

Kind regards,

i went further with yunohost.local and wanted to add a new domain afterwards. The error seems to be related to the submitted JSON?

2022-12-28 13:01:32,448: ERROR - Beschädigtes JSON gelesen von (reason: Expecting value: line 1 column 1 (char 0))

After trying to forward the necessary ports, which seems atm not possible with my ISP and router, i dont have access to the user interface nor the admin interface anymore. Raspi is running and booted fine, idk what the issue is. Can anybody comment?


i am little confused about your situation,
you had an access to the admin panel and then lost access cause of port forwarding?

please answer these questions so it will be easier to build a strategy,

  1. do you have a computer aside your raspberry?
  2. what kind of router do you have?
  3. can you access the raspberry through ssh at least?

hello, thank you for replying. please see answers:
1 yes
2 Sagemcom FAST5460
3 no, it says: port22 connection timed out

Hi And welcome,

first, we will leave the domain issues aside for now due there are no relations to the fact that you can’t access your server locally nor by a browser or by ssh,

i am not familiar with your type of the router as such routers are not distributed in my country at all, these routers are defined here in my country as a “Triple Service” routers and due to they are extremely limited to the user, most of people refused to accept them no matter what,
“TripleService” routers do involve phone ATV/TBA and landline phone line along, which i just discovered a few days ago by helping another person here on the forum that these kind of routers do not support what so called "hairpinning ", which will never get to port redirection inside the LAN by the DHCP,
you can read his answer here:

but i still don’t know if its support hairpinning or not for sure, so lets don’t jump into conclusions,

but the missing (IF is true) hairpinning doesn’t supposed to avoid you from accessing your server at least locally through your computer,

so to the first question " 1. do you have a computer aside your raspberry?"
i am sorry i forgot to ask what OS is it install on that computer but it doesn’t matter anyway,

please log into your router’s interface, look for DHCP Clients wherever is it, and make sure your router “sees” your Yunohost server, then if does, get your Yunohost server IP, which is something like 192.168.x.x (On Class C) otherwise something like 10.0.x.x (On Class A),

if your router don’t “see” your Yunohost Server as a client, something really go on with your Raspberry pi and you should try physically changing the lan cable to another plug, or even try another cable, or it can goes for connecting your raspberry pi to a screen and keyboard in worse situation to do a deeper analyze for that device,
which to my opinion i think and hope you’ll not need to go too far that way,

please open a console on your computer, (any console)
whether its linux so open console / bash
whether its windows open CMD
once you have you already have your Yunohost Server (Raspberry pi device) ip
try to ping it by the command: (example ip, change with your own)
check if you’re getting any reply from it,
if you do, its time to check the open ports on Yunohost firewall,

now to do that we need to install a tool called nmap,

if you are using windows, download and install nmap by the next link:

if you’re using linux (debian based) install nmap by the next command:
sudo apt-get install nmap

on windows you should close CMD and reopen for nmap to work properly! please don’t forget,

now run the command:
nmap youryunohostlocalip -p 80

that should tell you if the port is “open” or “filtered”

filtered means as what its sound like, filtered by the firewall,
open means on the other hand that its open for inbound,

now if you do have port 80 open its time to check port 22 with the same command:
nmap youryunohostlocalip -p 22

anyway if port 80 and 443 are open, you should go to admin panel with your browser for http://youryunohostlocalip

if you now see your admin and you have already logged in, run the analyze and check if it gives you a warning about hairpinning,

the other guy got that error but he did click on “ignore” instead to ask what is it about, and after a very long investigation i did discovered that finally so maybe you also ignored that issue by mistake, check it just to make sure,

the first thing is we need to get the admin panel, once you have it already and you successfully logged into the admin panel just tell me and i will keep from there cause there is nothing i can suggest at this point,

or tell me at least what’s the status and what nmap shows.

Hi @izakis ,
thank you for taking your time and deal with my issue. I try to format for better readability.

Router port forwarding or hairpinning

In general the router should be able to do port forwarding as described in a manual i found Port Weiterleitung - SAGEMCOM FAST5460 Benutzerhandbuch [Seite 35] | ManualsLib

In my case, ipv4 forwarding doesnt seem possible, only ipv6 and “external ip not available”, see screenshot:

Router is provided by Vodafone, your Triple Service assumption might be right by having a custom firmware.

2nd/3rd party PC OS

Currently i have possibility to use Win10, Kubuntu and MacOS

Router <–> Yunohost

Yes, in my list for connected devices i see the raspi.

Poking yunohost server

1 browser (kubuntu, firefox) → ______not accessible (time out)
2 browser (kubuntu, firefox) → yunohost.local: ____not accessible (cannot access)
3 ping (kubuntu, konsole) → ________accessible
4 nmap (kubuntu, konsole) → -p 80: _not accessible

The really interesting part is, that in the beginning i had access via poking scenario 1. Self diagnosis was feedbacking me that ports are closed. So i went to router and tried to open the ports, but as these are meant for ipv6 ofc it was not meant to be. And now this is the result.

Thank you again for your help!

Hello mika

Everything in what you wrote indicate that this router doesn’t support hairpinng,
the reason it doesn’t support ipv4 and do support ipv6 is because a PoIP requires a larger ip range, and that router is not meant to be used for a server hosting in mind, (Any server),
but do support wider range of corporate services,
such as Phone, ipTV, and so on and so forth,

The server replies on a ICMP requests but that does mean nothing, but the router do recognize and registered the device in its own DHCP server,
that’s the basic we have always to check before we proceed and taking any advanced steps,

nmap indicates by its message, “Blocking our ping probes”
if that happen from a remote machine, that means there is no binary loop or no icmp transcode,
in a simple language, that means devices on that router are able to communicate with each other only with the router’s Help and permission,
-Pn reverse the mathematical transcript calculation and sends requests in a mirror mode, then in that condition you will get icmp reaction but that’s just because you looping the requests, in real life they are all dropped by the router’s built in firewall,

as in that situation no chance whatsoever to hosts a server with this router,

sorry mika,
might the best thing to do is to check with your provider what alternative are stands for you.

best regards.

Hi again izakis,
thank you for making things clear. As i was already not 100% happy with the current router i just ordered AVM FRITZ!Box 6690 Cable. Should work with my provider and should be capable.

Best regards

i am not so sure about it, be careful with these kind of routers, they are good but some models have the same problem, only “ipv6” available, make your research before.

its all in German I cant understand nothing but this is the official description:

Got it, hooked it in and got access to yunohost.local

Did update and diagnosis, got this as output, ports still issue:

So i just open these ports for this device in the router settings? Or are these the filters in yunohost?

yes you should open the specific ports for your server,
better give it a static ip so it will never change,

i am happy :slight_smile:

1 Like

sure, glad it being solved,
if you ever reboot your router or your server there is a big chance your server ip will be changed, the router will assign another ip to it, so the port forwarding will not be pointed to your server anymore,
if you want to set a static ip for your server you can do so by:
nano /etc/network/interfaces

take a look how its supposed to be look like:

if its not clear what do you need to do just paste here a screenshot of your interfaces file and i will write it as its supposed to be.

Hi izakis,
thank you for minding. I have a setting in router management where it says “always assign same ip to this network device”. I am interpreting this as a permanent solution bound to the mac address of the device. I will test this, in case of alternating ip i will edit the interfaces.d file, which is empty atm in my case.

sure, that’s a new function makes routers interfaces easier for users,

interfaces not interfaces.d, its never empty for anybody,
anyway MAC reservation should be enough.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.