No access to Grocy after update


My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.2.10 (stable)
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Today I’ve updated my Grocy 4.0.3~ynh2 to 4.1.0~ynh1
There was no error message during the update.
After the update I tried to access Grocy via a Webbrowser, but it only shows me a blank empty page. No content at all.
The web page inspection tool of the browser indicates

500 - Internal Server Error

I’ve also tried the Android app and it also doesn’t work.

Do you have an idea what I could do?
Maybe I have to apply the solution given in this forum here?

rm -r /var/www/grocy/data/viewcache/*

The rm solution is already applied during upgrade: grocy_ynh/scripts/upgrade at d5ce2971a459fb99787e01ce0f4e7e0179c1f36e · YunoHost-Apps/grocy_ynh · GitHub

The app properly passed upgrade test, not sure what went wrong on your end.

Thanks for checking.

I did restore my backup and all of a sudden there were a bunch of OS/Yunohost related updates available ( postfix, DB, libs, etc.). I did a few Yunohost updates before the Grocy update already. So I was surprised to see so many additional Yunohost updates (about 20 or so).
Anyways, I did update those and update Grocy again (no error again). I still ended up in the same situation as before.
I’ve checked the viewcache folder and it was not empty. There were about 100 php files with cryptic names.
Apparently those files were not deleted during the Grocy update. I deleted them with the rm command , rebooted the server but the issue still remains there.

I did a restore my backup and Grocy 4.0.3~ynh2 is working fine.
Apparently I can’t get the update to work with my installation.

BTW: the web browser inspector error indicated a crs error (cross site same orgin or something). That would indicate a Yunohost web proxy issue to me. But I’m not sure about that.

Same problem here, i’ve done the system update after upgrading grocy.

Same thing in the viewdata directory, it’s full of php files, since it has not change anything, i’ve restore the old version, and it’s working with 4.0.3

Same problem. Upgrade broke the app.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.