Nextcloud Upgrade : Impossible ( Exception: Updates between multiple major **********s and downgrades are unsupported. )

My YunoHost server

Hardware: RPI 3
YunoHost version:
I have access to my server : Through SSH & through the webadmin & direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

( I think everybody here understands english but I can translate this topic in french would you need it ) ( also thanks for the attention <3 )

Description of my issue

I tried to update my Nextcloud instance through :

sudo yunohost app upgrade nextcloud

Here’s the log : . Error seems related to this :

Exception: Updates between multiple major **********s and downgrades are unsupported.

I am indeed using version 13.0.2, and upgrade should lead to v15.0.11 .

I found some hack on Nextcloud forums to bypass the problem, but the solution has been said to only fix upgrades between minor versions, and this is not the case here ( idea is to remove the version check, which is brutal ).

Some people here in the forum were able to fix this specific issue by deleting Nextcloud and reinstalling it, but I don’t understand where all users datas and permissions are, so I’m afraid of losing them if I do so. Otherwise, stored datas are on an external USB stick, and I’ve got a backup (and you sure know why :smiley: ).

Third solution was to keep the 13.0.2 version which is fine to me, but the interface is asking for an upgrade and therefore I cannot access it. I think this might be related to a php or nginx update but I’m not really good at this things.

Second solution might be the easiest way to go through but I prefer ask for assistance as I didn’t find what was the problem yet and do not want to mess it up until situation is hopeless.

Regards, D.

( PS : I might not have access to internet again until next monday, please forgive my silence )

/!\ Possible duplicate of Mise à jour manuelle d'application / gestion de versions .


sudo -u nextcloud php /var/www/nextcloud/occ app:disable user_external

says that there is no such app ( user_external ) installed.

Thans to @nimch, I was able to update to version 14.0.4 using this command :

sudo yunohost app upgrade nextcloud -u

But this error was raised several times, and again when I tried to reload nginx :

sh: 0: getcwd() failed: No such file or directory

Ok it seems it only needed a reboot. Now, Nextcloud main page leads to a beautiful :

Internal Server Error

Trying to get to the version 15 through regular update failed.
Log is available here : but I don’t have time to have a look for now.

I have a similar problem: trying to upgrade nextcloud through the command line

yunohost tools upgrade --apps

gives me this error:

Attenzione: Job for fail2ban.service failed because the control process exited with error code.                                                   
Attenzione: See "systemctl status fail2ban.service" and "journalctl -xe" for details.                                                             
Attenzione: -- Logs begin at Thu 2019-10-17 08:04:20 CEST, end at Thu 2019-10-17 17:22:55 CEST. --
Attenzione: ott 17 17:22:35 systemd[1]: Reloading Fail2Ban Service.
Attenzione: ott 17 17:22:54 fail2ban-client[22101]: ERROR  NOK: (21, 'Is a directory')
Attenzione: ott 17 17:22:55 systemd[1]: fail2ban.service: Control process exited, code=exited status=255
Attenzione: ott 17 17:22:55 systemd[1]: Reload failed for Fail2Ban Service.
Attenzione: /usr/share/yunohost/helpers.d/logging: riga 90: args_array: variabile in sola lettura

At you can find the full log.

This is an unrelated issue, related to shaarli (at least that’s my guess)

You can try this fix

1 Like

Yes, the workaround of that fix worked fine!

Thanks a lot!

Alright but that’s not your topic and we did not solve the initial issue, so please don’t mark my answer as resolving the thread…

In last @Dindoleon’s log, there are numerous errors related to a customized data path, like

2019-10-17 14:55:25,900: WARNING - PHP Warning:  fileperms(): stat failed for /media/stockage/nextcloud_data/data/nextcloud.log in /var/www/nextcloud/lib/private/Log/File.php on line 137
2019-10-17 14:55:25,901: DEBUG - Ensure there is a file called ".ocdata" in the root of the data directory. 

Standard installations refer to /home/, so that’s a difference. That being said, what filesystem is behind your specific directory, and what are the permissions?

Well, “stockage” is an USB stick which used to contain all the nextcloud datas but when I tried to access it today, everything was empty… I will try to investigate.

The data directory is still on the USB drive. I think it is, indeed a permission problem. But I logged in as the main user (the one who has access to the Web Interface). I think that the Nextcloud upgrade through the

sudo yunohost app upgrade nextcloud -u

command messed up the permissions.

Plugging the USB stick again got it back…

Error: nextcloud is not installed
when trying to update it :slight_smile: .

So I ran the install command again but this line :
Warning: [WARN] Another app already uses the domain to serve a caldav/carddav feature. You may encounter issues when dealing with your calendar or address book.
seems to imply that it was really installed in fact (I have no other app using the caldav/carddav feature).
And here we go : .

drwxr-xr-x 3 root root 4096 Jan 7 2019 nextcloud_data
Everybody can read though.

Unsuccessful installation removed everything related to nextcloud, so installating it again went fine. I tried to modify the data directory, using :
nano /var/www/nextcloud/config/config.php
After reloading Nginx, accessing the app leads to Internal Server Error.

sudo -u nextcloud php occ files:scan --all

An unhandled exception has been thrown:
RuntimeException: Could not get appdata folder in /var/www/nextcloud/lib/private/Files/AppData/AppData.php:86
Stack trace:
#0 /var/www/nextcloud/lib/private/Files/AppData/AppData.php(107): OC\Files\AppData\AppData->getAppDataFolder()
#1 /var/www/nextcloud/lib/private/Template/IconsCacher.php(78): OC\Files\AppData\AppData->getFolder('icons')
#2 [internal function]: OC\Template\IconsCacher->__construct(Object(OC\Log), Object(OC\Files\AppData\Factory), Object(OC\URLGenerator), Object(OC\AppFramework\Utility\TimeFactory))
#3 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(81): ReflectionClass->newInstanceArgs(Array)
#4 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(98): OC\AppFramework\Utility\SimpleContainer->buildClass(Object(ReflectionClass))
#5 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(119): OC\AppFramework\Utility\SimpleContainer->resolve('OC\\Template\\Ico...')
#6 /var/www/nextcloud/lib/private/ServerContainer.php(132): OC\AppFramework\Utility\SimpleContainer->query('OC\\Template\\Ico...')
#7 /var/www/nextcloud/lib/private/Server.php(980): OC\ServerContainer->query('OC\\Template\\Ico...')
#8 /var/www/nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php(118): OC\Server->OC\{closure}(Object(OC\Server))
#9 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(117): Pimple\Container->offsetGet('OC\\Template\\SCS...')
#10 /var/www/nextcloud/lib/private/ServerContainer.php(132): OC\AppFramework\Utility\SimpleContainer->query('OC\\Template\\SCS...')
#11 /var/www/nextcloud/lib/private/Repair.php(148): OC\ServerContainer->query('OC\\Template\\SCS...')
#12 /var/www/nextcloud/core/register_command.php(143): OC\Repair::getRepairSteps()
#13 /var/www/nextcloud/lib/private/Console/Application.php(118): require_once('/var/www/nextcl...')
#14 /var/www/nextcloud/console.php(95): OC\Console\Application->loadCommands(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#15 /var/www/nextcloud/occ(11): require_once('/var/www/nextcl...')
#16 {main}

The issue is possibly related to this topic : . But OP didn’t give the solution.

This is related to a permission problem.

Finally, this was a chair-computer interface problem, I didn’t write the correct path inside the config.php file.

The scan went well, but I still have an internal error when trying to connect to the Nextcloud.

After five reboots, everything is up and I have access to my files, users are still here and groups are still in effect, though they are not visible inside the user tab of the interface. I think I will have to edit them manually anyhow.

So ! If you have a problem of this kind with Nextcloud, we still didn’t find the right fix.
What you could do is :

I think you will lose the groups inside the interface, but they will still be active. I’ll try to document the method if I have the courage to find a way to remove the old groups. You will also lose any add-on you installed. Good luck with it.

Thanks for watching, show is over.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.