Nextcloud not working on nextcloud-desktop, tested on debian and fedora

After upgrading nextcloud from 25.0.3 to 25.0.4 everything is working well except from the client on linux machines, it shows a message of “unknown error” when I try connecting to my domain on nextcloud-desktop client. On the website and on mobile client it works fine.
Inside the web interface I found this in the logs:

Error: Undefined array key "s01" at /var/www/nextcloud/apps/user_ldap/templates/part.wizard-server.php#10
/var/www/nextcloud/apps/user_ldap/templates/part.wizard-server.php - line 10:


/var/www/nextcloud/apps/user_ldap/templates/settings.php - line 73:

require_once("/var/www/ne ... p")

/var/www/nextcloud/lib/private/Template/Base.php - line 180:

include("/var/www/ne ... p")

/var/www/nextcloud/lib/private/Template/Base.php - line 150:


/var/www/nextcloud/lib/private/legacy/OC_Template.php - line 181:


/var/www/nextcloud/lib/public/AppFramework/Http/TemplateResponse.php - line 213:


/var/www/nextcloud/apps/settings/lib/Controller/CommonSettingsTrait.php - line 130:


/var/www/nextcloud/apps/settings/lib/Controller/AdminSettingsController.php - line 83:


/var/www/nextcloud/apps/settings/lib/Controller/CommonSettingsTrait.php - line 149:


/var/www/nextcloud/apps/settings/lib/Controller/AdminSettingsController.php - line 68:


/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 225:


/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 133:


/var/www/nextcloud/lib/private/AppFramework/App.php - line 172:


/var/www/nextcloud/lib/private/Route/Router.php - line 298:


/var/www/nextcloud/lib/base.php - line 1047:


/var/www/nextcloud/index.php - line 36:


This sounds like an issue with the desktop client and not the server app. Sometimes I have had to logout on the desktop client app and log back in. Others times I have had to completely remove the nextcloud desktop cache and config directory completely and then set up syncing all over again. It seems to be a bug in the Linux desktop client. Here are some debugging tips I found: Appendix C: Troubleshooting — Nextcloud Client Manual 3.7.3 documentation

I tried doing that, purging the nextcloud-desktop client from my machine with debian, also .config .local and .cache files. Then installing the appimage, but same error.

I really need to fix it and fast…I have the backup of nextcloud 25.0.3, the previous version, but if I try to restore it it says nextcloud already installed, so it seems I need to uninstall then restore the backup with the previous version. How likely is it to break things?

As long as you have the data backed up, you can remove nextcloud and restore the backup. I have tried this with other apps and it worked really well.

Are you running nextcloud version25.0.4 and it works fine for you, syncing with a linux desktop app?

I did the upgrade last night to 25.0.4 and my debian 11 laptop is still syncing properly.

So I ended up restoring the 25.0.3 version of pre update backup, but the problem persists. No it makes me wonder if it could be the recent updates of php

I found the solution! Cannot connect to yunohost nextcloud with nextcloud client - #2 by HoldMyGin
I had removed the ‘nextcloud’ on visitors permission. Not sure why it’s needed for clients in order to connect. Just added back and all working as before


Visitors permission is needed for client apps so they can connect directly to nextcloud without using the SSO interface. They know how to “speak” nextcloud, but not yunohost :stuck_out_tongue_winking_eye: I wonder why it needs the Nextcloud permission when the Nextcloud api permission is there too.

1 Like

Yes, not very intuitive but learned a new one. Thanks mate

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.