Nextcloud "gone" after a failed upgrade

My YunoHost server

Hardware: OVH dedicated server
YunoHost version:
I have access to my server : Through SSH, through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue


  • I tried to upgrade from 4.4 to 11, it failed (problem with mariadb-db-server-10.3.
  • I ran sudo apt install --fix-broken as suggested here.
  • I ran successfully the migration from 4.4 to 11.
  • I tried to upgrade Nexcloud, it failed.

Here is the the log:

I’m a little bit worried, the Nextcloud app has disappeared from the Webadmin list of applications :confused:

Thank you very much for any help!

Hmokay so let’s start by fixing the backup restoration:

WARNING - 136  This backup archive can not be restored because it comes from a too-old YunoHost version.

This is due to a bug that I thought was fixed … To fix this, you should find the info.json file corresponding to your nextcloud backup archive:

sudo ls -thor /home/yunohost.backup/archives/*nextcloud*json

the last file listed should correspond to the pre-upgrade backup

If you open the file with

sudo nano /home/yunohost.backup/archives/....the_json_file

you will find inside the json that there’s a key named from_yunohost_version, followed by something gibberish … eg "from_yunohost_version": "SOMETHING"

Replace the SOMETHING with

After this, restoring this archive should work

BUT before restoring, we should also investigate why yunohost thinks dpkg is broken :

sudo dpkg --audit

Once all of this is solved, we should investigate why the upgrade itself failed :

DEBUG - Exception: Updates between multiple major versions and downgrades are unsupported.

and this message is kinda puzzling because according to the log, it’s following the expected upgrade path, ie. upgrading from 22.x to 23.x before upgrading to 24.x …

Thank you for you quick reply!

  • In case someone goes through the same issue, there is a little typo here:
    sudo ls -thor /home/yunohost.backup/archives/*nextcloud*json (archives)
  • If that is of any help, in my case, the from_yunohost_version value was BASH_XTRACEFD:.
  • sudo dpkg --audit returns nothing at all :confused:

No crazy rush in restoring my Nextcloud, so I don’t mind being the guinea pig, in case it is helpful for later.

Indeed, fixed in the original post, cheers :+1:

Hmmmokay so let’s try restoring Nextcloud then

I’ve never done that, so double-checking:

Home > Backup > local > nextcloud–2-pre-upgrade1 > Restore, right?


All good and restored now!

Should I do anything now? Or should I just try again to upgrade?

Otherwise, if we can’t see a solution, I don’t mind just creating a new Nextcloud instance! I’ve tried upgrading again, same problem (obviously, but I wanted to try anyway :smiley: )

if it helps I just (5min ago) upgraded my nextcloud instance on Yunohost and the script upgraded from 22.0.1 to 24.0.5 without a single trouble.

I believe you could try again :slight_smile:

Strange the error seems to be “Updates between multiple major versions and downgrades are unsupported” but nextcloud_ynh scripts does upgrade one by one.

Hello, I tried again, no luck :confused:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.