[Navidrome] - Music folder permission denied

My YunoHost server

Hardware: Kimsufi KS4
YunoHost version: 4.2.4
I have access to my server : Through SSH | through the webadmin

Description of my issue


(Sorry for the double post on the Navidrome topic)

I am using Navidrome with a music folder created with Syncthing.
It was working great since last update 0.42.1 (35027bbe).
Now, Navidrome can’t access my music folder anymore.

Here is the error:

INFO[0000] Configuring Media Folder                      
name="Music Library" path=/home/yunohost.app/syncthing/Musique

INFO[0000] Creating Image cache                          
maxSize="100 MB" path=/var/lib/navidrome/cache/images

ERRO[0000] Error stating dir                             
error="stat /home/yunohost.app/syncthing/Musique: permission denied" path=/home/yunohost.app/syncthing/Musique
ERRO[0000] Error loading directory tree                  
error="stat /home/yunohost.app/syncthing/Musique: permission denied"

ERRO[0000] There were errors reading directories from filesystem  
error="stat /home/yunohost.app/syncthing/Musique: permission denied"

ERRO[0000] Scan was interrupted by error. See errors above  
error="stat /home/yunohost.app/syncthing/Musique: permission denied"

ERRO[0000] Error importing MediaFolder                   
error="stat /home/yunohost.app/syncthing/Musique: permission denied" folder=/home/yunohost.app/syncthing/Musique  
ERRO[0000] Errors while scanning media. Please check the logs 
INFO[0000] Finished full rescan  

I’ve tried to change the permission of this folder:

sudo chmod -R o+r Musique
drwxr-xr-- 345 syncthing syncthing 12288 Apr 28 18:31 Musique                                                                                  

But no success.

Any help welcome, thanks!


Do have test to give execution right to nobody group ?

sudo chmod -R 755 /home/yunohost.app/syncthing/Musique

And restart navidrome


1 Like

Thanks, I did that but same error.

And the rights are OK on the parent directories ?

ls -l /home/yunohost.app
ls -l /home/yunohost.app/syncthing


1 Like

Try o+rx instead

1 Like

Thanks both of you, I had to change the rights ( o+rx) to the /syncthing folder, changing only /Musique did not work.

chmod -R o+rx /home/yunohost.app/syncthing

Perhaps a issue with the acl rights ?
Do have see this post : [Résolu] Changer permissions d'une app (Syncthing) sur un dossier - mondedie.fr
Sorry, I’m not using syncthing, just an idea…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.