Mysub.noho.st unreachable / Could not update IP address to DynDNS

, ,

Hello lovely people,

(Reponses en français: pas de problème!)

My server is unreachable via its mydomain.noho.st address. I still have access via SSH and the LAN address.

Diagnosis flags a DNS issue:

DNS records (dnsrecords)
=================================

[ERROR] Some DNS records are missing or incorrect for domain xxxxxxxx.noho.st (category basic)
  - This domain's DNS configuration should automatically be managed by YunoHost. If that's not the case, you can try to force an update using 'yunohost dyndns update --force'.
  - The following DNS record does not seem to follow the recommended configuration:
    Type: A
    Name: @
    Current value: x.x.x.x
    Expected value: x.x.x.x.

I tried updating, with and without --force (same output either way):

$ sudo yunohost dyndns update
Info: Updated needed, going on...
Outgoing update query:
;; ->>HEADER<<- opcode: UPDATE, status: NOERROR, id:      0
(...snip...)
host.noho.st.		3600	IN	CAA	128 issue "letsencrypt.org"

; Communication with 80.67.172.144#53 failed: operation canceled
; Communication with 2001:910:1410::1#53 failed: operation canceled
Info: The operation 'Update the IP associated with your YunoHost subdomain 'xxxxxxx.noho.st'' could not be completed. Please share the full log of this operation using the command 'yunohost log share 20220224-091756-dyndns_update-xxxxxxx.noho.st' to get help
Error: Could not update IP address to DynDNS

The share is at https://paste.yunohost.org/raw/yuserikane.

I can ping 9.9.9.9, wikipedia.org, and dyndns.yunohost.org without problems.

On the other hand:

$ ping6 wikipedia.org
connect: Network is unreachable

$ ping6 dyndns.yunohost.org
connect: Network is unreachable

Possibly related: I recently added a subdomain for the first time, and Let’s Encrypt certs.

Any help would be much appreciated!

My YunoHost server

Hardware: Old computer at home
YunoHost version: 4.3.6.2
I have access to my server : Through SSH | webadmin | direct access

Some further details:

  1. IPv6

Yuno’s diagnosis has always reported that this server does not have working IPv6 – I never bothered to follow that up since it didn’t seem to be a problem.

  1. regen-conf nameserver addresses

Something else I wonder about is that I’ve noticed that when I sudo yunohost tools regen-conf --with-diff --dry-run the diff shows that the same addresses will both be added and removed, e.g.

+nameserver 195.160.173.53
+nameserver 2001:910:800::40

but further down:

-nameserver 195.160.173.53

and

-nameserver 2001:910:800::40

If I actually run regen-conf, then reboot the server, then do the dry run again, I get another, similar diff.

  1. In case anyone was wondering, these two values cited in the diagnosis output in my last post are different in the unredacted version:

I’m having the same issue since this morning at 5:30. l’m receiving emails about the dyndns

; Communication with 80.67.172.144#53 failed: operation canceled
; Communication with 2001:910:1410::1#53 failed: operation canceled
Impossible de mettre à jour l'adresse IP sur le domaine DynDNS

I had the same mail long ago but it was for a short time. But now l’m still receiving this email and my dns didn’t update. I tried to update from the cli but it failed.
I didn’t try to reboot

me too, i’m surprised to say

So, I have edited the nginx config file of one of my subdomains a long time ago. Since then I was receiving the warning about the modified file. The changes were just comments.
I was receiving the error message about the dyndns today.
sudo yunohost tools regen-conf nginx --force fixed the dyndns error and it has updated the ip.
Don’t know why

The DynDNS service hosted on the YunoHost infra was down, and thanks to Bram it’s now up and running again.

2 Likes

So for me it was a pure coincidence.

All is well now on my end. Thanks Bram!

looks to be down again

Same here. Though another yunohost dyndns update has fixed it for me again – for now.

Makes me wonder if some of the functions provided by the central Yunohost servers (e.g. remote diagnosis, maybe dyndns) could be packaged up for self-hosting. ˉ_ツ_/ˉ

Seems to be down again. yunohost dyndns update gives

; Communication with 80.67.172.144#53 failed: operation canceled
; Communication with 2001:910:1410::1#53 failed: operation canceled

The host 80.67.172.144 is reacheable (by ping) but port 53/udp is closed

I have two domains in my server. One from registrar and one from yunohost. The first one is the default. I’m receiving mails about dyndns can’t communicate with ip… The yunohost dyndns server seems to have problems now. We’ll have to wait for it to be fixed.
Thanks for the volonteers. And if there is anything we can do to help let us know.

Same here

args:
domain: null
dry_run: false
force: true
ended_at: 2022-03-11 11:21:21.509672
error: “Konnte die IP-Adresse f\xFCr DynDNS nicht aktualisieren”
interface: cli
operation: dyndns_update
parent: null
related_to:

    • domain
    • maindomain.tld
      started_at: 2022-03-11 11:21:20.523316
      success: false
      yunohost_version: 4.3.6.2

============

2022-03-11 12:21:20,560: INFO - Updated needed, going on…
2022-03-11 12:21:20,562: DEBUG - Reusing IPv4 from cache: xx.xx.xx.xx
2022-03-11 12:21:20,563: DEBUG - Reusing IPv6 from cache: xx:xx:xx:xx:xx:xx
2022-03-11 12:21:21,430: DEBUG - initializing ldap interface
2022-03-11 12:21:21,434: DEBUG - Hydrating config with current values
2022-03-11 12:21:21,434: DEBUG - Formating result in ‘export’ mode
2022-03-11 12:21:21,437: DEBUG - Now pushing new conf to DynDNS host…

down again for me too. and yunohost dyndns update fails.

i wonder if it’s possible for this to be sorted out at our end? can we just roll our own dyndns cron / cli tool maybe.

could be good if this was managed on each individual install rather than centrally, so there’s no single point of failure.

YunoHost DNS server has been fixed. Let us know if your issue persists.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.