Mastodon update failed, then restore backup failed

My mastodon update failed, and restoring a backup is also failing. I have no clue why is this happening and how to restore the system.
Would anyone be so kind and have a look at the logs? Living without my mastodon account for now :frowning:

Log from restoring:

Full log from initial failed install/restore:

My YunoHost server

Hardware: Old computer
YunoHost version:
I have access to my server : Through SSH

all i can say is same thing happen to me, lost everything, backup failed to restore. i then switched to MissKey but oof bad android apps. next time i mastodon, its outside yunohost in its own VM.

1 Like

Hi dudenas,


Did you try whether Mastodon still be installed at all?

I had matrix-synapse getting broken and unable to restore when upgrading a few times, but in the end and with some help I could get it back to work. I hope your Mastodon can be revived as well!

1 Like

Thanks for the idea!
I tried to install mastodon to a different subdomain (I still have hope to restore my installation with my account). And it failed! Sadly, the log is as mysterious as the previous ones… I can make no sense of it myself…

Mastodon new installation failure log:

it would be really sad to realize that YunoHost is a poor choice for Mastodon.
I’ll try to stay hopeful for a few days.

Me neither.

After my previous post, I saw another thread where the upgrade of Mastodon ran awry, and some earlier threads about being unable to install Mastodon.

Sorry not to be of any more help!

1 Like

I got a similar issue (see: [Solved] Upgrade the 'mastodon' app' could not be completed) and it was solved by removing the file /opt/rbenv/shims/.rbenv-shim who had a wrong owner and launching the update script again.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.