Lost access to Syncthing GUI after setting username/password


My YunoHost server

Hardware: Old laptop
YunoHost version: 4.3.5
I have access to my server : Through the webadmin and SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : Yes, maybe
If yes, please explain: Old machine, i386, had to install Yunohost on top of Buster

Description of my issue

Hi there!

After setting the username/password of the Syncthing GUI, I lost access to the interface altogether.

After tweeking a bit around in the syncthing config.xml

  • tried changing from to (and back)
  • tried changing the username to an actual YH username in case it was somehow connect to the LDAP (and back)
  • restarting the service after each tweak

However the most I achieved was getting a login dialog at which no user/pass combinations seems to work.

The syncthing installation is on the same network, so also tried login in through another network, but the result was the same.

Does anyone have any idea of what might be causing this?

Thanks in advance.

Issue similar to

Ok got it, so I had to remove username and password lines from the config files, then syncthing GUI again was accessible through the ynh user panel.

Followed tips here: Resetting syncthing GUI password - Plugins - openmediavault

So there apparently better way to restrict access to syncthing is letting LDAP do the job and manage permissions in ynh.

1 Like

Still if anyone has any idea if it’s possible to set up the Syncthing GUI password for an extra layer of security, it would be appreciated.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.