Cannot reach Syncthing web-ui

My YunoHost server

Hardware: Older amd64 PC. Yunohost is installed on bare metal
YunoHost version:
I have access to my server : Through SSH, through the webadmin and I have direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : No (I have ddclient running tho, not sure it counts)

Description of my issue

I might simply be extremely retarded, but I just installed Syncthing and I cannot reach the Web-ui :cry: I tried looking for similar cases but everyone seems to have figured it out. Please don’t bash me if it’s trivial and I’m just being an ass …

This is what I get when I navigate to the /syncthing endpoint on my server:

I’m honestly lost what the problem could be. Any kind of hints would be a great help.

Thanks for the help in advance!

What happens when you try to fill in the form with your username and password? Can you make sure that your user has the permission to access Syncthing (via the config panel within the webadmin)?

Earlier, the Syncthing permission didn’t even show up on the dropdown menu. I did a reinstall and after it wasn’t added to the menu a second time I left to do some house cleaning.

I just came back and the permission is finally present in the menu, however I still get the login form as shown above.

When I provide my credentials it simply asks again and doesn’t do anything at all.


Okay so I’m leaving this here for completeness sake. I have no idea what I did and it just started working. I have a few possibilities in mind:

  • Maybe my password couldn’t contain chars like the dollar sign $
  • It’s also possible you need to access the GUI from the yunohost login screen and not through the admin panel for the first time (to allow setup maybe?) ( I mean the login screen where only the apps are visible in a tile, I’m unsure what it’s called)
  • Maybe reinstalling it did the trick somehow :slight_smile:

If you need help, these are what I did to get it running and I can’t really tell which one of them did it so I recommend you try all of the above.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.