Kimai 1.17.1 can't log in after update

Hello all,

My YunoHost server

Hardware: VPS bought online
YunoHost version: (stable)
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I have updated Kimai2 from 1.11.1 to 1.17.1 and I can’t log in nor register a new user.

Here are logs

When I try to log in I get “Invalid credentials” and when I try to register a new user I get " Something is wrong.
A critical error occurred, please try again. You may have found a software problem, please contact your administrator if the problem persists."

Thank you!


I have also installed a new Kimai2 instance and when registering a new user I get same error as in the post above.


Yunohost : VPS
Connect via SSH
Default install

i got the same issue here.
After upgrade 1.11.1 to 1.17.1 all work ok. After a reboot > cant login anymore

UPDATE : it’s not the reboot - deconnect and reconnect > Invalid credentials

Log upgrade to 1.17.1 :


the same with me:

YunoHost (stable)
Kimai2 1.17.1~ynh1

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

So @ericg pushed an update to Kimai2 1.18.2.
I’m quoting them now:

You can wait for the branch to be tested by the CI or install the app to test it yourself.

sudo yunohost app install

You can also try to upgrade your installed version of Kimai2 (this is not guaranteed to work…)

sudo yunohost app upgrade kimai2 -u

I have upgraded Kimai2 1.17.1 to 1.18.2 manually as above and it worked perfectly!

1 Like

the same with me: :grinning: Thanks a lot! :orange_heart:


So, Thanks to @agichim

First try, upgrade 1.11:x to 1.18.x > not working > error while upgrading.

Second, upgrade 1.11x to 1.17.x > directly upgrade to 1.18.x with

sudo yunohost app upgrade kimai2 -u

Login ok !


i also have updated to version 1.18.2 and it looked good, but now i cannot create any invoices or export Items.
When i hit search, in the invoice section, the page is refreshed but no List of Items.


i have the same problem after update my yuno host, but i can not open the download link, because ther is nothing to open.
is there any other link? i have to loggin but i can not do that.
Please help me

Thanks Ferre

I don’t know if your issues are related to the removal of SQLite support in the testing branch version… (SQLite is not supported upstream anymore in Kimai2 since version 1.14)

please see → Testing by ericgaspar · Pull Request #51 · YunoHost-Apps/kimai2_ynh · GitHub

i can loggin with an other acc, but not with admin acc
so its not easy to find the problem

Oh kimai is blocked only admins and highter

hallo again
can anyone send a new Link please
at the old one is no target
i need the update/ upgrade to 18.x please

Thanks at all

kimai2 version 1.18.2

kimai2 version 1.20

Hey ericg
you are the one and only for me at moment


kimai2 runs verry well and log in is all right now


thanks for the hard work, i now updated to kimai 1.20.
But i can still not create invioces.

no error, no data. The page with inviocecreation is being reloaded.
i’ve tried with Firefox and Edge, but no defference.
Nothing in the Log.
Export is also empty.

Yunohost GUI upgrade from Kimai 1.20 to 1.20.2 doesn’t work. I also tried CLI upgrade and doesn’t work. Here’s the log through the CLI upgrade.

Hi @ericg and @tituspijean,

I have 2 instances of Kimai. My own instance “alex” was on version 1.20 and I could update to 1.20.2 fine through the webadmin. In my previous comment I couldn’t update as I was on Yunohost version 4.x so I believe that now the update worked because I updated to Yunohost version 11.x.

But the second Kimai instance is on 1.11.1 and it doesn’t let me update it. I tried understanding what the issue could be but I struggle. I did try to update to “old_testing” branch which is version 1.19.7 through the CLI but no luck. “Testing” branch seems to be same as the “master” branch.

Here are the logs: