Installation WordPress impossible

,

Merci quand même ; mais ma honte est double (voire plus), parce que je viens de re-re-re-re-tenter une installation, et je me rends compte que malgré les ports correctement configurés je me retrouve de nouveau avec un “504 Gateway time out”. !!!:cry::angry:
Je n’ai pas avancé donc d’un poil !

That’s not about ports. There’s no reason the problem would be fixed.

The only fix would be to resolve localhost to 127.0.0.1

Let’s try those commands:

host localhost

cat /etc/hosts

cat /etc/nsswitch.conf

cat /etc/resolv.conf

cat /etc/network/interfaces

ls /etc/network/interfaces.d/

Bonjour, ( désolé, hier il faisait beau…).

> localhost

localhost has address 127.0.0.1
localhost has IPv6 address ::1

> cat /etc/hosts

127.0.0.1 localhost
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

127.0.1.1 raspberrypi

> cat /etc/nsswitch.conf

passwd: compat ldap
group: compat ldap
shadow: compat ldap
gshadow: files

hosts: files myhostname mdns4_minimal [NOTFOUND=return] dns
networks: files

protocols: db files
services: db files
ethers: db files
rpc: db files

netgroup: nis
sudoers: files ldap

> cat /etc/resolv.conf

nameserver 127.0.0.1
nameserver 8.8.8.8

cat /etc/network/interfaces ( j’ai supprimé les lignes de commentaires , avec #)

source-directory /etc/network/interfaces.d

ls /etc/network/interfaces.d ===> Rien !

You confirm that your resolv.conf start by this comment ?

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN

Could you remove that line about 8.8.8.8, restart dnsmasq, then cat the file again please?

Aprés un

systemctl restart dnsmasq.service

cat /etc/resolv.conf = nameserver 127.0.0.1
That’s all folk !
So ?

Try this as well

sudo systemctl restart resolvconf.service

And cat again /etc/resolv.conf
If the file still the same, without 8.8.8.8, then try to dig localhost as we did before.

OK !
resolvconf.service relancé ===> /etc/resolv.conf OK, (sans 8.8.8.8) ===> et dig yunohost.com ainsi que dig 127.0.0.1 OK!

I don’t know where this 8.8.8.8 was coming from…
I think you can now retry to install wordpress, I guess it would work this time.

EDIT: Of course, do not keep the resolution of yunohost.com to 127.0.0.1

c’est-à-dire ?

I’ve told you before to add 127.0.0.1 yunohost.com into your /etc/hosts.
As it was just for test purpose, it you didn’t already remove it, you can now.

already done

Je te félicite pour ta patience, mais je commence sérieusement à désespérer : même résultat, même erreur (504 Gateway time-out) :disappointed_relieved::rage:

And what about a dig localhost now ?

dig localhost

; <<>> DiG 9.10.3-P4-Raspbian <<>> localhost
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29660
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;localhost. IN A

;; ANSWER SECTION:
localhost. 0 IN A 127.0.0.1

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Mon Apr 01 14:24:51 CEST 2019
;; MSG SIZE rcvd: 54

Ok…
So we will try differently then.

Let’s retry to install with this command:

sudo yunohost app install https://github.com/YunoHost-Apps/wordpress_ynh/tree/curl_debug

And print here the resultant log

Est-ce suffisant si je ne mets qu’à partir du moment où ça foire ?

Warning: 2019-04-01 14:43:23 URL:https://raw.githubusercontent.com/wp-cli/builds/gh-pages/phar/wp-cli.phar [5421617/5421617] -> “/var/www/wordpress/wp-cli.phar” [1]
Warning: Error: One or more database tables are unavailable. The database may need to be repaired.
Warning: !!
Warning: wordpress’s script has encountered an error. Its execution was cancelled.
Warning: !!
Warning:
Info: The operation ‘Install ‘wordpress’ application’ has failed! To get help, please share the full log of this operation using the command ‘yunohost log display 20190401-123823-app_install-wordpress --share’
Info: […] > Load settings
Info: [#…] > Remove dependencies
Warning: Removing database wordpress

You should have lines before with DEBUG at the beginning, that those lines that interest me.

excuse me
DebugWP.odt (24.8 KB)

je viens de me connecter en local mais graphique sur mon serveur, et OH!Surprise, je vois que WP est installé !!!??? mais pas d’icone visible sur la page des utilisateurs ; too bad ! ,ça progresse ( c’est WordProgresse que ça s’intitule ?)

It is !? But your previous install has failed !

Could you please retry, with the same url.
It probably won’t work but we should have a little bit more clue this time (I hope !)