Installation manuelle Yunohost 2.4 sur Raspberry Pi 1 B 512Mo - Failed

fr
#1

Petit retour d’expérience sur ma tentative d’install de la v2.4 sur un RPi v1 B avec 512Mo

Copie de Raspbian 8 Jessie sur la carte SD
(tests avec la dernière version en date : 2016-05-27
et aussi avec la précédente : 2016-05-10)

Tout ces commandes sont exécutées via une console ssh depuis un autre ordi du LAN.
Jamais le RPi aura un clavier et un écran branché en lui (oui j’aime bien cette formule :stuck_out_tongue: )

Donc :

sudo passwd pi
sudo passwd root

activation du compte root utilisé pour ssh

raspi-config

locale par défaut (tout en gardant l’anglais):
fr_FR.UTF-8

heure Paris

changement du hostname: raspnohost

Activation de “wait for network at boot”

reboot

ssh root@raspnohost

apt-get update ; apt-get dist-upgrade -y ; apt-get install rpi-update ; rpi-update ; reboot

Lancement installation manuelle Yunohost (en enlevant “sudo” des commandes, car compte root utilisé):
https://yunohost.org/install_manually_fr

Sur la fin, dans la console :

Failure !
The following error was caught during YunoHost installation :

Installation of Yunohost packages failed

Installation logs are located in /var/log/yunohost-installation.log

Et contenu de ce fichier :
http://www.anonpaste.net/?p=f878a

Pour info, j’avais testé cette même procédure sur un RPi 2, et ca passait… Je retente dans la foulée, et reviendrai vous dire!
EDIT: Tout est ok avec cette même procédure d’installation de base sur un RPi 2 …
EDIT2 : Carte mSD du RPi 2 (avec yunohost) branchée dans RPi 1 = OK

Problème Admin user lors de la post installation de Yunohost 2.4 sur raspbian jessie lite sur un Raspberry Pi 2B et 3
#2

As tu essayé en mettant comme nom de machine Yunohost ?

Cf: Installation de Yunohost 2.4 sur raspbian jessie minimal sur un Raspberry Pi 3

#3

Changement du hostname : pas mieux.
Installation préalable des quelques paquets proposés dans la “version RPi 3” : pas mieux.

Je dois avouer que ca commence doucement à être déprimant…
Donc je sens que l’installation va se faire depuis le RPi v2, et la carte va se cloner sur celle du RPi v1.

Franchement je n’arrive pas à comprendre ! Les dépots sont bien les identiques chez Raspbian ?
Pourquoi ce script d’install fonctionne-t-il différemment sur 2 matériels très proches… Il ne s’agit que de logiciels, pas d’histoires de drivers et autres il me semble ?!
Nom di diou ! :stuck_out_tongue: