Framaforms does not work

,

Bonjour,

I installed Framaforms. When installing it, I got a warning:

WARNING - /!\ Packagers! This app is still using the skipped/protected/unprotected_uris/regex settings which are now obsolete and deprecated... Instead, you should use the new helpers 'ynh_permission_{create,urls,update,delete}' and the 'visitors' group to initialize the public/private access. Check out the documentation at the bottom of yunohost.org/groups_and_permissions to learn how to use the new permission mechanism.`

When I open the app, it does not work, I have the same problem as the one described here: Anything I press in the starting page of Framaforms takes me back to the Yunohost Apps page.

As far as I understand, @olivierM solved it by installing the app in the root directory. In my case I do not want to have Framaforms installed in my root directory, but anyway I tried to see if that workaround worked for me too. It didn’t because Yunohost did not let me install it there.

Anyone knows how to solve the problem?

Cheers!

I tried again the workaround of installing it in the root directory, and this time it worked because I removed any other application in the domain.

So that’s good news, it works. But if anyone knows how to make it work in a specific directory, please let me know!

Thank you.

As a work around, you could add a second domain (or subdomain) and install on it. Installing on subdir is not the best things to do.

I understand now. I see it is explained at YunoHost • index
but I did not know that was the recommended way.
Thank you @ljf!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.