Forgot my admin password and the manual procedure don't work


i have my acess to root (via ssh keys) and i am trying to change webinterface admin password.
unfortunately i fail to do so…

i tried this "yunohost-reset-ldap-password"
root@vps:~# yunohost-reset-ldap-password
-bash: yunohost-reset-ldap-password: command not found

i also tried this
root@vps:~# yunohost user update -p 123 admin
Administration password:
and at this moment i didn’t know which password to input…

please advise :wink:

Hmmm, are you using the last version of YunoHost ? o.O

i installed it 2-5 month ago, never updated. i think it is fresh
root@vps:~# yunohost -v
yunohost: 2.5.6
yunohost-admin: 2.5.1
moulinette: 2.5.2
ssowat: 2.6.7

i also tried this commands for ldap approach:
#create hash
slappasswd -h {SSHA}
#add hash to ldap conf
vim /etc/ldap/slapd.conf
#added two lines (pass to be replaced by hashed pass from above)
rootdn "cn=admin,dc=yunohost,dc=org"
slapd restart
sudo systemctl restart slapd.service
#login from web didn’t work

i tried two times and rolled back (commented two lines in ldap.conf)

if my version don’t support XX "yunohost-reset-ldap-password"
maybe i can update yunohost from command line ?

Yes, you should do (as root) :

apt-get update
apt-get dist-upgrade

(and make sure before validating the dist-upgrade that it’s not going to remove any important package ;))

great, i fixed with

apt-get update
apt-get dist-upgrade

thank you !