"foo.noho.st" NOT accessible in local Wi-Fi -- but IS accessible externally

Hello all,
I’m a brand new YunoHost user and am stuck on a network / domain related problem:

My YunoHost server

Hardware: Raspberry Pi 4 8GB
YunoHost version: 4.3.6.2
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I have just successfully installed YunoHost on “foo.noho.st” and successfully installed a Let’s Encrypt SSL certificate for that domain.

  • I can access http://foo.noho.st from my (Windows) laptop on my local Wi-Fi
  • I can access http://foo.noho.st from FireFox on my Android phone, but only when the phone is connected through external internet from my service provider (LTE)
  • Surprisingly, I cannot access http://foo.noho.st from Firefox on my Android phone, when the phone is connected to my local Wi-Fi. Then I get the error “Secure Connection Failed” … “the authenticity of the received data could not be verified”
  • Same results with different browsers (Brave) on my phone, except instead of an error message I get the login page of my router (192.168.1.1)

I don’t understand how it’s possible that I can access my YunoHost on my phone from “the outside”, but not when my phone is “inside” on my own Wi-Fi.

What have I misconfigured here?

Thanks for you help!

Avenor

After completing your server installation, it is possible that your domain will not be accessible through the local network. This is an issue known as hairpinning - a feature that is not well supported by some internet routers.

To solve this issue you can:

  • configure your router’s DNS
  • or alternatively - your /etc/hosts files on your clients workstation

more here → Local network access to your server | Yunohost Documentation

Thanks, rungeard. I’m a newbie at all this:

I looked into my router’s many configuration menu items, but I can’t find something like DNS redirection to my server’s IP. The best I could find is in the screenshot.

Alternatively, you said I can edit the /etc/hosts file on “my client’s workstation.”

But Yunohost works fine on my laptop (“client”). The problem is that it won’t work on my phone in the local network. Is there a /etc/hosts file on Android phones?

Domain Name or Hosts could be the place in your screenshot. Otherwise you can also putt your server in DMZ that could also be a trick to solve your issue.

It’s possible → https://www.howtogeek.com/140576/how-to-edit-the-hosts-file-on-android-and-block-web-sites/
Note: This requires a rooted Android device.

1 Like

It worked! I tried under “Hosts”:

When I entered Host Name “foo.noho.st” and IP “192.168.1.49” and then rebooted the router, the Yunohost was found on the phone’s browser in both the local Wi-Fi and via LTE.

Thank you for your help!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.