[Flarum] A lightweight forum

Oui, cela fonctionne bien, il s’est bien mis à jour

Flarum 1.1.1
PHP 7.3.31-2+0~20211022.89+debian10~1.gbp745ac7
MySQL 10.3.31-MariaDB-0+

J’ai testé, tout va bien :slight_smile:

Du coup, je vous passe le lien du dernier post :slight_smile:

Et justement, comment peut-on faire “passer” cette image dans le lien (avec Flarum) ?

Dans le brouillon, il apparaît ce message :slight_smile:

Sorry, we were unable to generate a preview for this web page, because the following oEmbed / OpenGraph tags could not be found: description, image

Merci de cette mise à jour et de ton temps

Cordialement, jrd10

1 Like

Ah yeah sorry. We are missing a chown in the script. I will release a patch by tomorrow.

1 Like

New patch release !

  • Master branch status as of 2021-11-13: PR180
    • :bug: Fix file ownership
    • :bug: Make sure the version requirements for language extensions are loosen

@Aristid @jrd10 let me know if that fixes your issues. :wink: Please open a dedicated thread if not.

Nah. Adding extensions after installation just dont work. I’m upset haha. Seriously guys, please update the faq.

./composer.json has been updated
Running composer update vendor/extension --with-dependencies
Loading composer repositories with package information
Dependency “app/core” is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Root composer.json requires vendor/extension ^0.1.1 → satisfiable by tvendor/extension.
- vendor/extension requires vendor/extension ^0.1.0-beta.10 → found bla bla but it does not match your minimum-stability.

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

Fascinating. I am not sure how withholding information in your log can help me help you. Please open a dedicated App support thread and ping me there.

1 Like

Thanks… and sorry!

i think this is the 5th failed installation for the say. :face_holding_back_tears:
here’s the log.

as always, any help is more than welcome.

What do you mean?

It looks like it does not like your password. Can you try with only alphanumeric characters?
Does your current password have special characters?
It’s mainly an issue with Bash variables parsing. :confused:

sorry, just that it’s the 5th app i try to install today, but fail to.
missing context, my bad.

ok, it happened with another app as well, so i guess it is an issue related to yunohost then? or it might be that many apps don’t like that specific special character?
just trying to understand as a reference for future installations. eheh!

and you were right btw.
new password and it all worked. thanks. :heart:

I have 2 questions
1- How not to loose every additional installed extensions each time I upgrade Flarum ?
2- What is the command line procedure on yunohost to install properly them ?

composer require vendor/extension

don’t work, I do

sudo su
cd /var/www/$app
sudo -u $app php7.4 composer.phar require vendor/extension

1- Hello, by keeping posted on Do not remove all extensions while upgrading · Issue #168 · YunoHost-Apps/flarum_ynh · GitHub, hopefully I’ll find how to fix that someday.

2- “Don’t work” is quite useless. Share the outputs of the command.

bash: composer : commande introuvable

That is not the command shown on the first post and neither the one at the end of your first message. :confused:

This should work.

To update flarum i follow the steps shown in the official flarum documentation and updates work great without losing any extension. YNH update system is a bit confused about that but i just ignore the flarum updates it wants to perform.

Thanks, I succeed upgrading with your solution.
any way to remove flarum upgrade proposition from webadmin to prevent mistakes (it stills in 1.6.2) ?


Does this mean that all the extensions need to be installed again. I believe the settings are stored in the database, so it doesn’t requires for setting up all the extensions again, right?

By installed Flarum through Yunohost, we can still change the composer.json file, in order to set the flarum core version, right?

Yes, no worries. It’s a bit clearer in the ADMIN.md file of the app, I have updated the forum post.

You could to add extensions, but should not for upgrading the core. The core version is set by the upgrade script of YunoHost.

Thanks very much for your reply, and Updating the forum post.

Just want to share with what I did.

I have copy and pasted the following part in my flarum site( all but this line “tituspijean/flarum-ext-auth-ldap”: “*” )

“require”: {


and past in the config.php in the yunohost file.

Then run

sudo -u flarum php8.0 composer.phar update --prefer-dist --no-plugins --no-dev -a --with-all-dependenciesphp

and it worked to downgrade flarum from 1.8 to 1.4.

However, as the docs in the flarum site, after update, to run the following commands:

composer update --prefer-dist --no-plugins --no-dev -a --with-all-dependencies
php flarum migrate
php flarum cache:clear

I don’t know how to run the second and third. However, after I import database.

My site is migrate to Yunohost. I have made a post, and it worked. So Yay! :star_struck: One step closer to move my sites to Yunohost server.

Can anyone tell me how to run these command in Yunohost for flarum?

flarum migratephp 
flarum cache:clear

1 Like

Be careful while quoting commands, this can become disastrous.

sudo yunohost app shell flarum
# Will load Flarum's environment in a new shell
php composer.phar update --prefer-dist --no-plugins --no-dev -a --with-all-dependencies
php flarum migrate
php flarum cache:clear

Next time, for such a non-standard request (install, downgrade, upgrade), open a dedicate thread. :slight_smile: