[FitTrackee] Self-hosted outdoor activity tracker 🚴

FitTrackee for YunoHost

Integration level Working status Maintenance status

Install FitTrackee with YunoHost

Lire ce readme en français.


FitTrackee allows you to track your outdoor activities (workouts) from gpx files and keep your data on your own server.
No mobile app has been developed yet, but several existing mobile apps can store workouts data locally and export them into a gpx file.


Screenshot of FitTrackee

Documentation and resources

Developer info

Please send your pull request to the testing branch.

To try the testing branch, please proceed like that.

sudo yunohost app install https://github.com/YunoHost-Apps/fittrackee_ynh/tree/testing --debug
sudo yunohost app upgrade fittrackee -u https://github.com/YunoHost-Apps/fittrackee_ynh/tree/testing --debug

More info regarding app packaging: https://yunohost.org/packaging_apps


Note that this app requires a dedicated domain name. I will try again once my subdomain is fully enabled.

I installed FitTrackee.

The default admin user isn’t recognized.
So, I created/registered a new user. Login invalid.

I followed the guide to make that user an administrator (in case of the first created user needs to be the admin).

 pushd $install_dir/
    pipenv shell
    ftcli users update <user> --set-admin true

with the accurate path/username.

Login still invalid.

→ What did I miss ?

First of all, thanks for your feedback!

Is the login still invalid or does it only refresh to the login page?

I’ve come accross an issue where login won’t work untill you disconnect from the Yunohost portal.

Could you try this or try FitTrackee in a private window?

Hmm, the page doesn’t seem to refresh, I only get:

With the developer tools from my browser (Vivaldi / [F12]), I see a JavaScript (?) message:

> POST https://mysubdomain.name.nohost.me/api/auth/login 401

…but the page doesn’t reload, it’s only adding the message each time I click on the [Se connecter] button.

I tried on a private window, same result.

Mmmh could you try to create a new user and set the new as admin to be sure it’s not a credential fault?

Yes, I already did it:

Here is a new screenshot:

I guess that something is missing with JS ?

Mmmh strange…
Could you please telle me what was the exact result of

ftcli users update <user> --set-admin true


Is there a way to get back the results of older commands in the terminal/pipenv ?

I don’t remember the output, but I’m sure it was OK (some kind of confirmation that the command was validated).

PS: I did it again, result:
User 'blablabla" updated.

I tried to connect again, same result (Identifiants invalides)

Could you please send the logs from fittrackee.service and fittrackee_workers.service?



-- Journal begins at Wed 2022-12-07 14:50:41 CET, ends at Tue 2023-03-21 07:57:22 CET. --
mars 19 08:54:17 systemd[1]: Started fittrackee service.


[2023-03-19 08:54:17 +0100] [816816] [INFO] Starting gunicorn 20.1.0
[2023-03-19 08:54:17 +0100] [816816] [INFO] Listening at: (816816)
[2023-03-19 08:54:17 +0100] [816816] [INFO] Using worker: sync
[2023-03-19 08:54:17 +0100] [816967] [INFO] Booting worker with pid: 816967



-- Journal begins at Wed 2022-12-07 14:50:41 CET, ends at Tue 2023-03-21 07:59:01 CET. --
mars 19 08:54:17 systemd[1]: Started fittrackee task queue service.



Mmh yes I misconfigured showed logs a bit, could you have a look in /var/log/fittrackee/fittrackee.log ?

root@xxxxx:/var/log/fittrackee# cat fittrackee.log
2023/03/19 08:54:18 - fittrackee - WARNING - EMAIL_URL is not provided, email sending is deactivated.
2023/03/19 08:54:18 - fittrackee - WARNING - EMAIL_URL is not provided, email sending is deactivated.

So logs are normal…

Are there special characters in your login name or password ?

Installation failed :frowning:

full log here


2023-03-21 18:34:10,946: DEBUG - Loading .env environment variables...
2023-03-21 18:34:12,578: DEBUG - Creating a virtualenv for this project...
2023-03-21 18:34:12,578: DEBUG - Pipfile: /var/www/fittrackee/Pipfile
2023-03-21 18:34:12,700: DEBUG - Using /usr/bin/python3.9 (3.9.2) to create virtualenv...
2023-03-21 18:34:14,209: DEBUG - ModuleNotFoundError: No module named 'virtualenv.activation.xonsh'
2023-03-21 18:34:14,209: DEBUG - 
2023-03-21 18:34:14,219: DEBUG - ✘ Failed creating virtual environment
2023-03-21 18:34:14,220: DEBUG - [pipenv.exceptions.VirtualenvCreationException]:
2023-03-21 18:34:14,220: DEBUG - Failed to create virtual environment.

It seems to be an issue with the installation of virtualenv.
Could you try again after making sure your virtualenv installation is correct?

I never encounter this error so I can’t tell you exactly what do: I’m not an expert yet :sweat_smile:

No, everything is standard.

Last hope, did you try with another browser?
If it still not work, try to force upgrade the app with

sudo yunohost app upgrade fittrackee -f --debug

I’ve just tried a new installation (a second FitTrackee instance on my server), and it works as expected for me :thinking:

thank you.

I did (as root):

apt remove python3-virtualenv

then installation was successful :smiley: , I’ve installed from webadmin (FTR).

Personal ToDo now: I’ll try to link data directory to an existing nextcloud folder with .gpx files from FitoTrack and also import some data from garmin’s backup file.

Just for clarification:
when installing, yunohost-admin is prompted to set a yunohost user as admin, set tile portal text, etc. but after installation (admin doc info) we have to create an user from fittrackee web interface and then set they from CLI as fittrackee admin. I have set the same ynh-user as admin in both, and apparently worked fine, but what’s the point of setting it in the first time? (at installation point). Thank you!!! (I will report here any issue or problem)

1 Like

It should be, I think:
sudo yunohost app upgrade -f fittrackee --debug

It didn’t change anything, as the app was up to date.

PS: I uninstalled/reinstalled fittrackee, still no go.
I also have AdguardHome on my yunohost machine, can there be a conflict ? (I already disabled the adblocking stuff on my browser, Vivaldi)