[FitTrackee] Self-hosted outdoor activity tracker 🚴

@GoustiFruit have you set FitTrackee service available to Visitors?

I deleted access to Visitors (ynh group) and then I could not log in with the admin user in FitTrackee. Added it back and it worked fine.

Initially I wanted to limit access just to my YNH users (logged in) but it does not work, so I guess I have to disallow registration setting to false in the app config. I have CLI docs and there’s no reference to disallow regitration from there.

Edit:

Yes, that the option (the default one) I selected during the installation. I checked the groups, fittracker is in visitors and ynh users groups.

VERY UNLIKELY: a small bug/missing translation appears in YNH web UI:

→ should I try to install FitTrackee within the English UI ? :clown_face:

Glad it works now !

Actually, there is no in place import. So you have to upload every file (or zip containing multiple files) manually.
But you can change your data directory in the config_panel.

Yes, the admin user chosen during the installation has no incidence for now, but I expect that future releases will soon let me configure the admin user during the installation to get rid of the cli for Yunohost users :smiley:

I don’t use AdguardHome. Is there a way to try by disabling it?

Yes, this is the issue I refered to above. I don’t understand why I cannot login when connected on the Yunohost portal.

EDIT: when checking the commit, it’s not related to the .env. So I think your “workaround” is the regular way to go :slight_smile:

1 Like

No, this has nothing to do with your problem. But this UX issue will soon be fixed

1 Like

yes, that’s right.

It’s not that fittrackee service/app reads a directory on the fly looking for .gpx files, every .gpx workout has a reference in a database and has to be imported.

There’s a tool to create a job that imports from a directory, but it’s beyond my understanding how to make it work in YNH. I put it here for anyone’s reference.

Thank you.

new version 0.7.15 GitHub - YunoHost-Apps/fittrackee_ynh: FitTrackee package for Yunohost 🚴 Thank you!! :smiley:

edit: I was missing pipenv package :person_shrugging:


De todas formas,…

:es: incluye la tradución al español y al gallego.

He traducido ambas para darle un empujón al trabajo, pero ya he avisado en github de que la versión española no tengo pensado mantenerla en el futuro (en gallego si). De todas formas ya han traducido también cuatro o cinco cadenas de texto que aparecieron así que no creo que haya problemas.

1 Like

The latest package version (0.7.15~ynh3) resolves this issue :partying_face:

1 Like

thanks! :smiley:

I’ve created an user in visualcrossing weather service and set API key using FitTrackee admin panel in YunoHost webadmin.

Weather data is retrieved when new workouts are uploaded, not for past workouts when reviewed.

1 Like

Yes, I may update the messages to let admin know about this.

I dont’ retreive the information, but in my memories this behavior will be changed in the future to let a user add those infos for already uploaded workouts.

2 Likes

I don’t know when and what you changed, but I’m now able to login and access the dashbord :slight_smile:

1 Like

Thanks for the heads up!
The biggest change is that now the admin creation is directly in the installation script thanks to the new cli command available in the latest FitTrackee version.
Maybe it helped, or just the new Fittrackee version resolves the issue by itself.

Enjoy FitTrackee :smiley:

1 Like

Hi,

I managed to install it on my server but unfortunately I can’t upload the gpx file. The server message is unclear (the console doesn’t say much), but I increased the single file limit - from 10 to 100Mb.

I downloaded the original gpx file from strava / garmin connect (weight ~ 9 mb) and … still can’t upload. now the server returns information that the uploaded file is too large.

Hello @bobiko and welcome on the forum!

Thank you for your report.
This is because I haven’t touch at the default nginx configuration which only allows for upload files < 1mb.

Could you follow this steps in cli:
nano /etc/nginx/conf.d/fittrackee.domain.d/fittrackee.conf (change fittrackee.domain.d with your fittrackee domain and append .d at the end),

It will open the file, write

# Set max upload size
client_max_body_size 100m;

under location / {
(don’t forget the ; at the end)
(100m is for 100 mégabytes, you can change this value as you want, but try to be consistent with your setting in FitTrackee).

Then do ctrl+o (the letter, not zero) to save and ctrl +x to quit.
Then restart nginx by yunohost service restart nginx and try again. If you have set 100mb in FitTrackee, all files under 100mb should now be correctly uploaded.

I will see if I can easily propose this as setting in the config panel.

[forgot to say] until a proper implementation is done in the config_panel, you will have to repeat those steps after each FitTrackee package upgrade.

2 Likes

@Tho

thanks, after making a change in the nginx configuration it worked :wink:

I will add a few more observations, because maybe someone will have a similar problem. Generally, I park the domain in cloudflare, which provides all routing.

Before I made the suggested changes, it crashed once that the file was too large and twice in the console I saw error 520 (cloudflare). So for testing purposes I disabled the proxy.

now I turned it back on (after updating the nginx configuration) and … it makes no difference :wink:

to sum up, configuring the max file weight from the yunohost panel does not work? is read-only?

it still looks cool (I made a similar one but based on nextjs + md :wink:

good job! :slight_smile:

1 Like

oops! I’ve opened an issue in github to point to this nginx size problem :hushed:

Should I close/delete it?

Is it something we have to change manually or would it be set in future ynh-fittrackee updates? thanks

@bobiko @ghose could one of you please test this upgrade?
sudo yunohost app upgrade fittrackee -u https://github.com/YunoHost-Apps/fittrackee_ynh/tree/testing --debug

I’ve set a maximum of 20MB, which should handle the vast (if not all) majority of cases.

1 Like

@Tho

the update seems to be working fine. The question is, shouldn’t I roll back the changes to the nginx configuration on my server? (unless the update overwrites the configuration)

1 Like

If it’s working fine, then it’s good to go, thank you!

The nginx config has normally be updated with the latest template from the repository, overriding all your changes. This is normally noticeable in your upgrade logs: there must be something like “nginx was manually edited, old file is backuped” and the new file from the upgrade takes its place.

If you have a look at your nginx conf now, it must be 20m.

It would be nice if there was an app that would encourage me to do more again. To get on the bike or even to imagine the whole thing so far that the yunohost freaks meet to ride together sport so bike and exchange. The app would be the best app for that. We strengthen ourselves and at the same time yunohost