Failing to upgrade nextcloud

My YunoHost server

Hardware: Dell PowerEdge at home
YunoHost version: 4.2.6.1
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Attempting to upgrade Nextcloud from 20.0.8 > 21.0.2 . This fails with the following error log:

https://paste.yunohost.org/raw/oropineraq

Something that stands out to me (but I don’t know what it means) is this line:

WARNING - /usr/share/yunohost/helpers.d/user: line 184: 28909 Killed sudo -u “$user” “$@”

Thanks for any help fixing this problem!

Same issue here did you find a solution?

1 Like

No, I haven’t found any solution.

I’ve got the same issue. Maybe an Out Of Memory.
I have only 2Go of RAM and you ?
EDIT : confirmed by “/var/log/messages”

Jul 12 17:44:24 yuno kernel: [ 5446.587740] php7.3 invoked oom-killer: gfp_mask=0x6200ca(GFP_HIGHUSER_MOVABLE), nodemask=(null), order=0, oom_score_adj=0

EDIT2 : maybe related to https://help.nextcloud.com/t/update-to-nc-21-php-out-of-memory-killed/115326

1 Like

Que donne la commande :
free -h

1 Like

I have 16GB of RAM. I tried the solution from your link but it still failed. I watched ‘Top’ while it was trying to upgrade. I never used much RAM, but I did max out my 1GB swap, and my CPU.

Edit: I made a 5GB swapfile, and it still wasn’t enough.

              total        used        free      shared  buff/cache   available
Mem:           15Gi       1.1Gi        12Gi       136Mi       2.1Gi        14Gi
Swap:         975Mi       944Mi        31Mi

It’s not a memory issue.
Do you have other apps installed? Are system packages updated?
I read in the forum that some had problems with the php version, other apps using different versions of php.

1 Like

I’ve noticed this line in the log twice :
forbidden_path= /var/www /home/yunohost.app

Is that normal?

1 Like

Aside from Nextcloud, I have Airsonic, and Firefox Sync Server installed. I don’t know anything about whether that log entry is normal or not. Maybe the permissions are wrong for that file? But I don’t know what they should be, or why/how they would have been changed.

Edit: “Services” in the webadmin only shows one version of php (7.3-fpm).
Edit2: Forgot to mention that yes, all system packages are updated.

It seems you have the same issue as

1 Like

work with this tips (carefully !) : Add apc.enable_cli=1 in /etc/php/7.3/cli/conf.d/20-apcu.ini

https://help.nextcloud.com/t/solved-occ-command-php-fatal-error-allowed-memory-size-of-xxx-bytes-exhausted/108521/17

But it’s a manual change, I don’t like it…

3 Likes

Thank you! This absolutely solved the problem. Should I delete that line now?

You can, but the binary occ used to update your nextcloud or to put it in maintenance mode. So if you want to make any “admin” operation on your nextcloud, you cannot without this line. So, keep it today, I add this link to the issue on the package to get informations about that.

1 Like

Thx!
It solved the issue for me as well

Hello,
I had a message on the GUI saying :
Erreur: "500" Internal Server Error
Action: "PUT" /yunohost/api/apps/nextcloud/upgrade

And after in the logs
Backup failed, the upgrade process was aborted.

I solve it following your tips :slight_smile:

Thank You :+1: