Etherpad Lite package

,

The Etherpad Lite package, made by @beudbeud, is about to be integrated to the official list.

Sources: https://github.com/abeudin/etherpadlite_ynh

Installation

sudo yunohost app install https://github.com/abeudin/etherpadlite_ynh

Known issues

When those 3 things will be resolved, the package will be integrated.

Do not hesitate to help us by testing this package on your server and giving us feedbacks !

Does not work on my Banana Pi (OS=Bananian). I interrupted the installation, on a too long step.
Executing step that I interrupted:

+ sudo /var/www/etherpadlite/bin/installDeps.sh

Error message :

^CError: Operation interrupted
sudo yunohost app install https://github.com/abeudin/etherpadlite_ynh  8.22s user 1.68s system 2% cpu 6:00.84 total

Now… Can you tell me if I’ve better to remove the aborted installation (how?) or if I’ve better to leave it as is. As far as I see, my Yunohost instance is still working…

Thanks

^CError: Operation interrupted

You interrupted the process by typing CTRL-C :slight_smile:

Try again “as is”, or contact us on the support chatroom if you want a test instance to try “safely”.

OK… How else to stop than Ctrl-C ? I understood I had to be more patient. And tried again and… the installation finally completed. But… When I go in the application, I get a “502 Bad Gateway”. I will follow your advice and contact the support chatroom, probably this evening. Afterwards, you are human too, aren’you :wink: ?

Last: I want to say that despite its name, the installation of “Etherpad Lite”, including Node.js, is not “lite”.

Oh sorry, misread the part saying that you intentionally interrupted the installation…

To properly remove everything installed by etherpad, you can manually follow the commands contained in the remove script of the app:

Then try the installation again :wink:

I installed the app successfully without errors. Nice work.

Does Etherpad Lite lack the Style and Size menus? Why did you choose to package the Lite version instead of the full one?

The style and size menu seem to be removed from the last version of Etherpad Lite.


The etherpad Lite is far lighter than the “full one”, but above all it became the main project of etherpad.org. We better keep following upstream :slight_smile:

Salut,

Installation fonctionnelle sur YunoHost !

Merci beaucoup !

Hi,

Not sure i should answer here or create another entry. I tried to install etherpad today via @beudbeud package but i couldn’t access it after the install was successful. I have a nginx error: bad getway and found this in the logs:

2014/12/09 12:55:55 [error] 23356#0: *30244 connect() failed (111: Connection refused) while connecting to upstream, client: X.X.X.X, server: …, request: "GET /pad/ HTTP/1.1", upstream: "http://127.0.0.1:9001/", host: "…", referrer: "https://…" 

In etherpad logs, I have these:

Ensure that all dependencies are up to date...  If this is the first time you have run Etherpad please be patient.
npm WARN package.json async-stacktrace@0.0.2 No repository field.
npm WARN package.json channels@0.0.4 No repository field.
npm WARN package.json ejs@0.6.1 No repository field.
npm WARN package.json formidable@1.0.9 No repository field.
npm WARN package.json jsdom-nocontextifiy@0.2.10 'repositories' (plural) Not supported.
npm WARN package.json Please pick one as the 'repository' field
npm WARN package.json tinycon@0.0.1 No repository field.
Ensure jQuery is downloaded and up to date...
Clear minfified cache...
ensure custom css/js files are created...
start...
[2014-12-09 13:03:52.209] [ERROR] console - ERROR: Problem while initalizing the database
[2014-12-09 13:03:52.211] [ERROR] console - Error: connect ECONNREFUSED
    at errnoException (net.js:901:11)
    at Object.afterConnect [as oncomplete] (net.js:892:19)
    --------------------
    at Protocol._enqueue (/var/www/etherpadlite/src/node_modules/ueberDB/node_modules/mysql/lib/protocol/Protocol.js:135:48)
    at Protocol.handshake (/var/www/etherpadlite/src/node_modules/ueberDB/node_modules/mysql/lib/protocol/Protocol.js:52:41)
    at Connection.connect (/var/www/etherpadlite/src/node_modules/ueberDB/node_modules/mysql/lib/Connection.js:109:18)
    at Connection._implyConnect (/var/www/etherpadlite/src/node_modules/ueberDB/node_modules/mysql/lib/Connection.js:387:10)
    at Connection.query (/var/www/etherpadlite/src/node_modules/ueberDB/node_modules/mysql/lib/Connection.js:174:8)
    at exports.database.init (/var/www/etherpadlite/src/node_modules/ueberDB/mysql_db.js:59:6)
    at exports.database.init (/var/www/etherpadlite/src/node_modules/ueberDB/CacheAndBufferLayer.js:110:18)
    at exports.database.init (/var/www/etherpadlite/src/node_modules/ueberDB/CloneAndAtomicLayer.js:48:11)
    at Object.exports.init (/var/www/etherpadlite/src/node/db/DB.js:41:6)
    at async.waterfall.hooks.aCallAll.settings (/var/www/etherpadlite/src/node/server.js:62:8)
RESTART!

just changed the nodejs installation source.
Etherpadlite now works as expected on bananian

Etherpad isn’t running on subdomains, instead it returns a 502 error.
Test site : pad.courtial.me

ok just started from scratch again…

…in a ssh session on bananian I just ran

sudo yunohost app install https://github.com/m2f0u4d/etherpadlite_ynh

Worked 4 me as mentioned before
If you still get 502, run

curl -sL https://deb.nodesource.com/setup | bash -

before app install

Thanks for the tip, it now works.
Is there any admin panel in EtherpadLite? So we could change name of install, etc…

Edit the setting.json and modify:

"requireAuthorization": true,

Uncomment

  "users": {
    "admin": {
      "password": "changeme1",
      "is_admin": true
    },
    "user": {
      "password": "changeme1",
      "is_admin": false
    }
  },

Edit the nginx config file and add:

proxy_redirect         / /pad/;

after

proxy_pass             http://localhost:9001/;

Restart nginx and etherpadlite.
Acces to admin panel at /admin

But, the admin panel is empty…
I have an nginx error:

2015/05/29 00:03:03 [error] 8390#0: *517 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.1.67, server: crudelis-test.fr, request: "GET /pad/static/js/l10n.js HTTP/1.1", upstream: "http://[::1]:9001/static/js/l10n.js", host: "crudelis-test.fr", referrer: "https://crudelis-test.fr/pad/"

First, sorry for my bad english.

For fix the nodejs error, i have created a tutorial in my blog.
I have tested it in on my RaspberryPi server and it work for me.
http://blog.abhd.fr/wiki/mon-pense-bete/#nodejs (french)
https://abhd.fr/pad/p/r.716555d1ac33d95c0a65e4c1a033d791 (english)

Hi @Adrienb , the links are broken, could you reproduce the tutorial somewhere?

Thanks!

Hi,
i made an update of etherpadlite_ynh package because i need it on a 2.4 ynh instance
it works well so far on my testing server (proxmox deb8 container)
it’s my first package, i followed the documentation but there may be some errors …
backup and restore are not implemented yet, i’ll do it soon as ther’s not to much things to backup with etherpad
if some of you want to test it : https://github.com/bachy/etherpadlite_ynh
i wait for more test before i make a pull request
cheers

Cool! Not having this has been a real headache. Thanks.

de nada :slight_smile:
backup and restore script added, didn’t tested it …
and updated etherpad to 1.6.0