Error 400 Bad Request

After installing Yunohost – yunohost-bullseye-11.0.9-rpi-stable - on a Raspberry Pi 4 (Model B, 4 GB) I tried to update the system.
The following message appeared:

Error: "400" Bad Request
Action: "PUT" /yunohost/api/upgrade/system

Error message:
You cannot do this right now because dpkg/APT (the system package managers) seems to be in a broken state… You can try to solve this issue by connecting through SSH and running sudo apt install --fix-broken and/or sudo dpkg --configure -a.

So I tried “sudo apt install –fix-broken“ and “sudo dpkg --configure -a“ as recommended.
After rebooting the system the same error log appeared.
What else can I do to solve the problem?

Hi @ulido ,

Sorry I cannot answer your question.

I am also trying installing yunohost-bullseye-11.0.9-rpi-stable, but on a Pi3B+, and I am stuck like described in this thread:

Didn’t you encounter that “which user would you like to rename” issue?
Thanks and sorry for disturbing your thread…

Bonjour aoz. J’ai eu le même problème si on avez un moniteur connecté. Je me suis connecté au pi avec par exemple putty. l’installation fonctionne alors mieux. Aux côtés de. Il y a un bien meilleur projet. DietPi. Ceci est un projet allemand et malheureusement uniquement disponible en allemand. Tu peux facilement y installer nextcloud. Si tu as besoin d’aide demande juste. Meilleures salutations.

  1. sudo apt-get clean
  2. sudo apt-get autoremove
  3. sudo apt --fix-broken install
  4. sudo apt-get update --fix-missing
  5. sudo apt-get update
  6. cd /
  7. mkdir aleksfix
  8. cd aleksfix
  9. wget

10 . chmod -X


@izakis, to whom is your answer addressed?

both of you
its a script for people who has a problem keeping the migration to bulleye for some reasons written by aleks,

Thank you. But after running your script the same problem still exists. “Bad Request”. Sorry but I surrender.

its not my script its aleks’s script, it might not fit your situation and no reason ever to be surrender,

there are many details missing on your post,

lets restart from the beginning,
your’e getting bad request when and where?
on sso home page?
admin panel?
specific app page?

and where is your log?

sorry for the late response my yunohost server is off right now cause i am configuring OPNsense firewall so not getting notifications but i will leave this window open and wait for you whenever you reply i will get browser notifications

i just did read your message again,
so please lets make it clear,

you did install a fresh bulleye or upgraded from buster?
and you are getting bad request only on update page?
and everything works well but the update?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.