Empty 'Apps' page in the webadmin after upgrading to Bullseye

First of all thanks to the many who worked on #support Debian #support Yunohost on 11. for #apps & all the supporters here in the forum. I would especially like to thank @Aleks, who not only supports me well. On the one hand, unfortunately, there are a few problems with the apps since you can no longer see the one you installed. See first screen where all installed ones could be seen.

or as with Nextcloud, everything stays dark

So a question, how do I get the apps visible again?
Or that the programs that I have installed for domains with the programs are visible again? Do any of you have the same difficulty? And found a bug about it? Thanks @all

Sorry aim her ist the Konsole! Aim not good this ergebnis :roll_eyes:

Do you have an idea how I can fix this bug or anyone else here in the Yunohost forum

What I don’t understand, since I upgraded to the new Debian Bullseye, some apps can no longer be used! They are also no longer visible with the others that are still working and have also been installed under the Applications area.
What can you do now? I don’t know where to find the error. Has anyone else had this here in the forum? @ljf ljf @Aleks

@Aleks can you please help me how or where I can find this so that my apps or programs that I have installed can show up again? I’ve put two screenshots a little further up here. And the Nextcloud is no longer accessible at all. Thank you in advance

@Aleks kannst du mir bitte mal helfen wie ich oder wo ich das finde damit meine apps oder Programme, die ich installiert, habe wieder auftauchen können? Ich habe hier zwei Screenshots etwas weiter oben hinterlegt. Und die Nextcloud ist überhaupt nicht mehr erreichbar. Danke schön im Vorfeld

@carrabelloy : i have just provided you with instructions on how to get more debugging info about this issue … Just read the message …


we need the “Konsole” tab …

1 Like

It would help if you’re able to go to the “blank” app page in the webadmin, then open the developer console in your browser with F12, and go in the “Console” tab in what opens up. You should see some red error message, and it would be helpful to get a screenshot of this

1 Like

The errors are still there, and some apps no longer work. How Seax or Nextcloud or the apps can no longer be seen.
Has anyone had the same problem and found a solution to it? Because nothing is going right here anymore.

Yes, thank you very much, did it help or was it the wrong way? I still have the problem. But I think it’s a small bug… :face_with_monocle: :face_with_monocle: But who do I wait until the problem is found. :blush:So and so, electricity is getting expensive here! Maybe I’ll have to move’again, from the servers :blush: Nice to read they’re up and running now, everything? :face_with_monocle: It’s even better to read such messages about your own bugs. But in this case we also agree that Yunohost is the best program after all. And in this respect I wish you the best running system of all #announcement Yunohosts

Ja, danke sehr hat es geholfen oder doch den falschen Weg? Bei mir ist das Problem noch vorhanden. Doch denke ich, es ist ein kleiner Bug … :face_with_monocle: :face_with_monocle: Doch wen warte ich bis das Problem gefunden ist. :blush:So und so, Strom wird bei uns teuer! Vielleicht muss ich umziehen’abermals, vom Servern :blush: Es jetzt schön zu lesen bei ihnen läuft, alles? :face_with_monocle: Umso besser doch solche Nachrichten bei seinen eigenen Bugs zu lesen. Doch wir sind uns in dem Fall genauso einig, dass Yunohost das beste Programm doch ist. Und insofern wünsche ich ihnen das best laufende System aller Yunohost

If only everything were that simple. A part runs on Debian Bulleye. But a part doesn’t work. This also includes the application page in the admin area of ​​Yunohost, where the page remains white and does not show my apps that I have installed. In addition, some domains such as nextcloud & Searx give errors.

Do any of you have the same problem and how did you solve it or does anyone have an idea how I can fix the problem.

I don’t understand why some programs can’t be created. And the application is still not working. The admin panel still doesn’t show all the aplications. Does anyone have a problem like this?

@carrabelloy :

can you share the output of this (big) command:

PERMS=$(sudo yunohost user permission list | grep main); for APP in $(sudo ls /etc/yunohost/apps/); do echo "$PERMS" | grep -q "$APP.main" || echo "main perm for $APP is missing"; done


Nothing happens except bash

Nothing happens except bash

@carrabelloy : well yes since you didn’t properly copypaste the command …


@Aleks That’s correct, since I don’t know where here a value can always be evaluated as an input. Thank you for your help

@carrabelloy hmpf okay let’s do it a more brutal way then … Let’s look at :

sudo ls /etc/yunohost/apps/


sudo yunohost user permission list | grep main

1 Like

castopod__2 flarum nextcloud pixelfed rocketchat synapse wordpress__3
ecko friendica peertube prosody roundcube__2 wordpress
element mastodon phpbb riot searx wordpress__2