Dex (Outline) Update Error

My YunoHost server

Hardware: VPS bought online
YunoHost version:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: outline from to 0.74.0~ynh1 and dex 2.35.3~ynh2 to 2.37.0. and Minio

Description of my issue


While trying to update Dex I got “en error occurred inside the app upgrade script”.
While updating Outline, it was simply yunohost who stopped responding.
I tried upgrading each app separately and together both with superadmin and simple admin user and both frm ssh and webadmin.

Here is the error when upgrading all app with “sudo yunohost tools upgrade apps” from the SSH side with the admin user :

Do you have an idea of the cause of the issue or the right way to fix it ?

Best Regards,

2024-01-30 08:27:35,787: INFO - Installation of Go-1.19.13
2024-01-30 08:27:35,951: DEBUG - Downloading go1.19.13.linux-amd64.tar.gz...
2024-01-30 08:27:35,952: DEBUG - -> go1.19.13.linux-amd64.tar.gz                                                               
curl: (22) The requested URL returned error: 404
2024-01-30 08:27:36,446: DEBUG - 
2024-01-30 08:27:36,455: DEBUG - error: failed to download Go Linux 64bit 1.19.13.tar.gz
2024-01-30 08:27:36,455: DEBUG - 
2024-01-30 08:27:36,629: DEBUG - BUILD FAILED (Debian 11 using go-build 2.1.11)
2024-01-30 08:27:36,629: DEBUG - 

A 404 error, weird … could be a temporary network/web glitch idk, are you still experiencing the same issue if you retry ?

I got this :

Then the same error :

So absolutely no change whatsoever.

Does anybody have any other idea or test to find the cause of the error ?

Have you retried since then ?

DEBUG - ++ wget --tries 3 --no-dns-cache --timeout 900 --no-verbose --output-document=/var/cache/yunohost/download/dex/app
DEBUG - + out='Will not apply HSTS. The HSTS database must be a regular and non-world-writable file.
DEBUG - ERROR: could not open HSTS store at '\''/root/.wget-hsts'\''. HSTS will be disabled.

according to this website, the following fix would work:

chmod 644 ~/.wget-hsts

Thanks, it did fix the dex error. Dex is now successfully upgraded.

Now it is Minio which get an “an error occurred inside the app upgrade script”.

I did try to upgrade Outline too and it worked without any error, but without the right version of Minio it just returns an error when trying to access to the website:


The newest version of Outline doesn’t use MinIO anyway, so it isn’t related.
You may be experiencing this bug Can’t start (or restart) Outline service · Issue #103 · YunoHost-Apps/outline_ynh · GitHub that I’m currently correcting.
Could you please try the fix as described ?
Sorry for the inconvenience !


It did work this time.

I used sudo yunohost app setting outline language -v en_US before upgrading outline.

I had no need to change the .env file as it was already in en_US.

I still have Minio installed.
Can I remove it without any issue now as Ouline doesn’t use it anymore ?

Thank for the help


The update did work, but the result is kind of disappointing

Every single pages turned to this:

Please keep MinIO for the moment.
Please copy here the logs that you’ll find in the yunohost admin panel > tools > services > Outline


Each time something failed I was just reverting to the previous server save state.
And now when I retry again to install dex from the same state as before the error came back. And I have previously successfully upgraded it thanks to your command.

At least this time dex is not destroyed after the fail and manage to revert back to its working state.


So this time it is without dex upgraded, as previously mentionned, but Outline upgrade worked anyway.

The result is however still the same.

Here is the log.

It tried too from the page where I found it to restart Outline and it didn’t send any error, but didn’t restart Outline properly (502 bad gateway).

Restarting it server side with sudo yunohost service start outline did work.

-- Journal begins at Mon 2023-09-25 05:48:30 UTC, ends at Thu 2024-02-22 08:30:11 UTC. --
Nov 12 05:56:02 systemd[1]: Started Outline server.
Nov 12 20:22:45 systemd[1]: Stopping Outline server...
Nov 12 20:22:50 systemd[1]: outline.service: Succeeded.
Nov 12 20:22:50 systemd[1]: Stopped Outline server.
Nov 12 20:22:50 systemd[1]: outline.service: Consumed 3min 9.236s CPU time.
-- Boot bc369003de804209bf84207f74fd1541 --
Nov 12 20:25:12 systemd[1]: Started Outline server.
-- Boot e5badfc12ef645f2beb1dd83220d6313 --
Jan 09 18:55:33 systemd[1]: Started Outline server.
-- Boot 77ede8aa35b543e4b4a40b40e077da51 --
Jan 29 13:09:18 systemd[1]: Started Outline server.
-- Boot c784b5b7a15a426cadd50b0e757f138d --
Jan 30 09:04:50 systemd[1]: Started Outline server.
-- Boot 74dba56b4c324c9a8c6b9f3ea927b634 --
Jan 31 16:15:24 systemd[1]: Started Outline server.
-- Boot 6fc38c3b68c746c1a04aa9b7d66840b4 --
Feb 20 06:41:52 systemd[1]: Started Outline server.
-- Boot 489bd9caf0034fc9b8be687f0633ae57 --
Feb 20 09:59:15 systemd[1]: Started Outline server.
-- Boot e2fde695e9394eea822b8f454614db16 --
Feb 22 06:55:43 systemd[1]: Started Outline server.
Feb 22 08:20:40 systemd[1]: Stopping Outline server...
Feb 22 08:20:45 systemd[1]: outline.service: Succeeded.
Feb 22 08:20:45 systemd[1]: Stopped Outline server.
Feb 22 08:20:45 systemd[1]: outline.service: Consumed 1min 15.082s CPU time.
Feb 22 08:28:54 systemd[1]: Started Outline server.
Feb 22 08:30:06 systemd[1]: Stopping Outline server...
Feb 22 08:30:11 systemd[1]: outline.service: Succeeded.
Feb 22 08:30:11 systemd[1]: Stopped Outline server.
Feb 22 08:30:11 systemd[1]: outline.service: Consumed 30.658s CPU time.
Feb 22 08:30:11 systemd[1]: Started Outline server.


{"label":"http","level":"info","message":"  <-- GET /static/assets/Star-1rJAKPpW.js"}
{"label":"http","level":"info","message":"  -x- GET /static/assets/Star-1rJAKPpW.js 200 4ms 4.67kb"}
{"label":"http","level":"info","message":"  <-- GET /static/assets/Styles-erpSB4kf.js"}
{"label":"http","level":"info","message":"  -x- GET /static/assets/Styles-erpSB4kf.js 200 6ms 31.52kb"}
{"label":"http","level":"info","message":"  <-- GET /static/assets/Switch-Tmpfbrvg.js"}
{"label":"http","level":"info","message":"  -x- GET /static/assets/Switch-Tmpfbrvg.js 200 4ms 16.54kb"}
{"label":"http","level":"info","message":"  <-- GET /static/assets/Table-zpj8AkrD.js"}
{"label":"http","level":"info","message":"  --> GET /static/assets/Table-zpj8AkrD.js 200 3ms 60.97kb"}
{"label":"http","level":"info","message":"  <-- GET /static/assets/TableFromParams-FhctQsb2.js"}
{"label":"http","level":"info","message":"  -x- GET /static/assets/TableFromParams-FhctQsb2.js 200 6ms 1.07kb"}
{"label":"http","level":"info","message":"  <-- GET /static/assets/Tabs-UqmLnIUn.js"}
{"label":"http","level":"info","message":"  --> GET /static/assets/Tabs-UqmLnIUn.js 200 5ms 9.14kb"}
{"label":"http","level":"info","message":"  <-- GET /static/assets/Templates-be-4Uadm.js"}
{"label":"http","level":"info","message":"  --> GET /static/assets/Templates-be-4Uadm.js 200 4ms 2.33kb"}
{"label":"http","level":"info","message":"  <-- GET /static/assets/Trash-nbdsy71R.js"}
{"label":"http","level":"info","message":"  --> GET /static/assets/Trash-nbdsy71R.js 200 4ms 949b"}
{"label":"http","level":"info","message":"  <-- GET /static/assets/Twitter-KNeFqGQ0.js"}
{"label":"http","level":"info","message":"  --> GET /static/assets/Twitter-KNeFqGQ0.js 200 5ms 3.76kb"}
{"label":"http","level":"info","message":"  <-- GET /static/assets/uniq-NluhrbSw.js"}
{"label":"http","level":"info","message":"  -x- GET /static/assets/uniq-NluhrbSw.js 200 5ms 172b"}
{"label":"http","level":"info","message":"  <-- GET /static/assets/useCommandBarActions-UMI3ZlQ4.js"}
{"label":"http","level":"info","message":"  -x- GET /static/assets/useCommandBarActions-UMI3ZlQ4.js 200 4ms 364b"}
{"label":"http","level":"info","message":"  <-- GET /static/assets/useFocusedComment-AzN52yIv.js"}
{"label":"http","level":"info","message":"  --> GET /static/assets/useFocusedComment-AzN52yIv.js 200 3ms 354b"}
{"label":"http","level":"info","message":"  <-- GET /static/assets/useLastVisitedPath-t6WueU9k.js"}
{"label":"http","level":"info","message":"  -x- GET /static/assets/useLastVisitedPath-t6WueU9k.js 200 6ms 308b"}
{"label":"http","level":"info","message":"  <-- GET /static/assets/VisualElementDragControls-GtxrLRV5.js"}
{"label":"http","level":"info","message":"  --> GET /static/assets/VisualElementDragControls-GtxrLRV5.js 200 4ms 40.89kb"}
{"label":"http","level":"info","message":"  <-- GET /static/assets/Zapier-av3W3sgR.js"}
{"label":"http","level":"info","message":"  --> GET /static/assets/Zapier-av3W3sgR.js 200 6ms 1.3kb"}
{"label":"http","level":"info","message":"  <-- GET /static/images/camunda.png"}
{"label":"http","level":"info","message":"  --> GET /static/images/camunda.png 200 5ms 2.81kb"}
{"label":"http","level":"info","message":"  <-- GET /static/images/gitlab.png"}
{"label":"http","level":"info","message":"  --> GET /static/images/gitlab.png 200 6ms 2.57kb"}
{"label":"http","level":"info","message":"  <-- GET /static/images/google-maps.png"}
{"label":"http","level":"info","message":"  --> GET /static/images/google-maps.png 200 4ms 6.9kb"}
{"label":"http","level":"info","message":"  <-- GET /static/images/icon-192.png"}
{"label":"http","level":"info","message":"  -x- GET /static/images/icon-192.png 200 4ms 26.99kb"}
{"label":"http","level":"info","message":"  <-- GET /static/images/icon-512.png"}
{"label":"http","level":"info","message":"  -x- GET /static/images/icon-512.png 200 4ms 9.07kb"}
{"label":"http","level":"info","message":"  <-- GET /static/images/instagram.png"}
{"label":"http","level":"info","message":"  --> GET /static/images/instagram.png 200 7ms 7.13kb"}
{"label":"http","level":"info","message":"  <-- GET /static/images/linkedin.png"}
{"label":"http","level":"info","message":"  -x- GET /static/images/linkedin.png 200 3ms 3.75kb"}
{"label":"http","level":"info","message":"  <-- GET /static/images/smartsuite.png"}
{"label":"http","level":"info","message":"  -x- GET /static/images/smartsuite.png 200 5ms 2.13kb"}
{"label":"http","level":"info","message":"  <-- GET /static/images/valtown.png"}
{"label":"http","level":"info","message":"  -x- GET /static/images/valtown.png 200 4ms 1.85kb"}
{"label":"http","level":"info","message":"  <-- GET /static/manifest.webmanifest"}
{"label":"http","level":"info","message":"  --> GET /static/manifest.webmanifest 200 6ms 412b"}

So now back to reverting the server to a functional state again.

Current state before reversion btw :

Sorry I’m not sure to understand - is your problem solved ?


Sorry if I was not clear enough.

I am still stuck with this after the Outline update.

You can see the realted log you asked for in the previous message.

And Dex upgrade doesn’t work anymore either btw (reverted back to the initial bug).
But I had this same Outline bug with and without an updated Dex.

OK, thanks for your reply.

  • What was your latest working Outline version ?
  • Can’t you revert to it while we debug your problem ?
  • Please screenshot your web inspector console
  • Please share your latest Outline installation log
  • Apparently you can log in so Dex problem is out of the equation (although it needs to be tackled too)
    Sorry for the inconvenience with Outline app, I try my best but it’s a quite complex app and I still discover bugs here and there…

Hello Limezy, thanks for the help.

I did revert it as I revert the whole server to its previous backup each time something fail without any functional rollback.

No problem, your work is kind of amazing.Outline is tremendouly orrendous to fully grasp.

The web inspector

The outline app upgrade fails sometimes (like this time right now) and don’t return any error, yunohost just crashes.
And if I try to update after that, it return this :

I am restoring the server again back to start and retrying in one hour.

And it crashes again with this error :

And this log:

Mise à jour de outline…

Creating a safety backup prior to the upgrade

Collecte des fichiers devant être sauvegardés pour outline…

Loading installation settings…

Declaring files to be backed up…

‘/var/www/minio/mc/outlinestorage’ wasn’t deleted because it doesn’t exist.

Backing up the PostgreSQL database…

Backup script completed for outline. (YunoHost will then actually copy those files to the archive).

Création d’une archive de sauvegarde à partir des fichiers collectés …

L’archive contiendra environ 792.9MB de données.

Sauvegarde créée : outline-pre-upgrade2

Sauvegarde supprimée : outline-pre-upgrade1

Provisioning sources…

Updating system_user…

Updating install_dir…

Provisioning ports…

Provisioning permissions…

Provisioning apt…

Provisioning database…

Stopping a systemd service…

Upgrading source files…

Checking if a migration is needed

Migrating MinIO data to local directory

Data migration finished

Data bucket was kept for safety, just in case !

Don’t forget to remove MinIO app if you don’t use it !

ERROR: syntax error at or near “-”



Upgrading NGINX web server configuration…

Building outline. This can be very long, be patient !

Your Outline looks very old since it still uses MinIO.
Can you please go to the Yunohost admin panel and tell me exactly what version your Outline is ?

As mentioned in the first post it is Outline 69.9.2.
I think it is from July 2023.