Collabora ne fonctionne pas / Collabora not working



Je n’arrive pas à faire fonctionner Collabora online avec Nextcloud.
J’ai suivi le tuto: mais j’ai toujours un message message d’erreur quand j’essaie d’accéder à un ficher (.ods, .odt, .odp)
“Impossible de se connecter à Collabora en ligne”

Dans les logs docker, j’ai un message :
“WRN WOPI host did not pass optional access_token_ttl| wsd/FileServer.cpp:611”
A part ça pas d’autre erreur.
Configuration :
Domaine principal : < mondomaine >.fr
Domaine Nextcloud : next.< mondomaine >.fr
Domaine Collabora : collab.< mondomaine >.fr
Tous les domaines ont un certificat Let’s Encrypt

La page https://collab.< mondomaine >.fr/hosting/discovery semble renvoyer le résultat attendu :
< wopi-discovery >
< net-zone name=“external-http” >

Je ne comprends pas pourquoi ça ne fonctionne pas.
Merci de votre aide.


I can’t make Collabora Online working with Nextcloud.
I followed the tutorial but I always get an error message when I try to access a file (.ods, .odt, .odp)
“Cannot connect to Collabora Online”

In docker logs I have a message :
“WRN WOPI host did not pass optional access_token_ttl| wsd/FileServer.cpp:611”
And nothing else.

Configuration :
Main domain : < mondomaine >.fr
Nextcloud domain : next.< mondomaine >.fr
Collabora domain : collab.< mondomaine >.fr
All domains have their own Let’s Encrypt certificates.

The page seems to give the expected result :
< wopi-discovery >
< net-zone name=“external-http” >

I can’t understand why this does not work.
Thanks in advance.


I have the same problem:

My YunoHost server

Hardware: VPS bought online
YunoHost version:
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
Collabora docker instance version: collabora/code:

Description of my issue

Same as @denisbg:

  • “Impossible de se connecter à Collabora en ligne” when trying to open a .odt document
  • Message in docker logs: WRN WOPI host did not pass optional access_token_ttl
  • Webpage https:// collabora-domain.mydomain.tld/hosting/discovery seems OK

Already tried

  • Rebooted system as documented in (even if I don’t understand the reason)
  • Tried changing the nginx configuration with the example provided here
  • Updated kernel (3.16 -> 4.9) and tried changing Docker storage driver (devicemapper/overlay2)

I can provide full docker log, but I don’t see anything interesting in it.

Hi, you can try this : Installer Collabora avec Nextcloud. It works for me.