Changing Wordpress configuration PHP-FPM cause 502 error


My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.2.3
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : No
If yes, please explain:
If your request is related to an app, specify its name and version: WordPress 6.2.2~ynh1

Description of my issue

I installed the WordPress application. All worked fine. I tried to change the configuration “Expected usage” under " PHP-FPM configuration". After saving the changes, the WordPress doent work anymore. It show an error 502 Gateway :

502 Bad Gateway
If you see this page, your connection with the server is working but the internal service providing this path is not responding.

I plan to migrate my blog from my actual shared hosting to my new VPS server. I had migrated all things when this error happened. No choice to uninstall WordPress and reinstall it. I tried again to change the PHP-FPM option (High), did the same thing. But i created a Yunohost backup before.


1 Like

I also have this issue. do you also have any of the other issues I described in Need Help with Yunohost Issues: 502 Error, Custom App Folder Ownership, and Nginx/PHP Problems ?

Please cleanup the header of the message template.

You are the administrator. :wink: What is the status of the PHP8.2-FPM service? Its logs?

Sorry for the template, it’s my first time here.

The service PHP8.2-FPM is enabled and running fine (all services are OK). The log show only yesterday. Do you want that I try to change again the usage level of my WordPress app and check the logs after that ? I will do a backup of my YunoHost before (cause the restore fix the issue).

Sorry I can’t tell for your second issue.

Maybe the bug can come from a change in a configuration file (Nginx, PHP, etc)…

First time it happened, I did a fresh install of WordPress (for now i’m running a VPS test, this is not my prod website). Next time, I created a backup of YunoHost settings and WordPress app. I restored this backup when I got again the 502 error. I don’t know if its the WordPress restore or the settings restore that fixed the issue.


I’ve tried the same thing with the application SnappyMail (2.28.4~ynh1) where the same PHP-FPM configuration is offered. Changed both options for Medium. The application return now a 502 bad gateway. Here is the log at the moment I have tried to change the settings :

[17-Aug-2023 16:50:56] NOTICE: Reloading in progress ...
[17-Aug-2023 16:50:56] NOTICE: reloading: execvp("/usr/sbin/php-fpm8.2", {"/usr/sbin/php-fpm8.2", "--nodaemonize", "--fpm-config", "/etc/php/8.2/fpm/php-fpm.conf"})
[17-Aug-2023 16:50:56] NOTICE: using inherited socket fd=8, "/var/run/php/php8.2-fpm-ttrss.sock"
[17-Aug-2023 16:50:56] NOTICE: using inherited socket fd=9, "/var/run/php/php8.2-fpm-wordpress.sock"
[17-Aug-2023 16:50:56] NOTICE: using inherited socket fd=10, "/run/php/php8.2-fpm.sock"
[17-Aug-2023 16:50:56] NOTICE: using inherited socket fd=11, "/var/run/php/php8.2-fpm-snappymail.sock"
[17-Aug-2023 16:50:56] NOTICE: fpm is running, pid 2264771
[17-Aug-2023 16:50:56] NOTICE: ready to handle connections
[17-Aug-2023 16:50:56] NOTICE: systemd monitor interval set to 10000ms
[17-Aug-2023 16:54:14] NOTICE: configuration file /etc/php/8.2/fpm/php-fpm.conf test is successful

[17-Aug-2023 16:54:45] NOTICE: configuration file /etc/php/8.2/fpm/php-fpm.conf test is successful

[17-Aug-2023 16:54:50] NOTICE: configuration file /etc/php/8.2/fpm/php-fpm.conf test is successful

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.