Need Help with Yunohost Issues: 502 Error, Custom App Folder Ownership, and Nginx/PHP Problems

Hardware: AMD64
YunoHost version: 11.2.3 (stable).
I have access to my server : Yes.

Description of my issue

Hey fellow Yunohost users,

I’ve been encountering some rather strange issues lately, and I’m hoping someone can help shed some light on them. I’m using Yunohost, and while it’s been generally great, I’ve run into a couple of roadblocks that I just can’t seem to figure out.

  1. 502 Error with Higher Usage Level for WordPress Apps:
    I’ve noticed that when I try to set the usage level to a higher setting for my WordPress apps in the pool, it results in a frustrating 502 error. It’s really puzzling because everything seems fine at lower usage levels, but as soon as I ramp it up, I hit this roadblock. Has anyone else experienced this? Is there a fix or workaround you’ve come across?

  2. Custom App Folder Ownership Mix-up:
    Another odd occurrence I’ve encountered is when creating a custom app. The folder ownership in /var/www/my_webapp_9 gets set to Wordpress__4, an app which I deleted, before creating the custom app (am I maybe going too fast and are there still things running on the background)? I’m not sure why this is happening, and I’m worried it might be causing some of the issues I’ve been facing. How can I rectify this situation without losing any important details or data?

  3. Resetting Nginx, PHP, and Web server Related Settings:
    Given these multiple issues, I’m wondering if there’s a way to perform a kind of reset for all things related to Nginx, PHP, and the web server. I’m concerned that something might have gone awry in these areas, and starting fresh could potentially help. However, I really don’t want to lose any of my existing data or configurations in the process. Is there a safe way to do this? Any guidance or step-by-step instructions would be greatly appreciated.

I’m hoping that someone out there has encountered similar problems or has expertise in troubleshooting Yunohost intricacies. Your insights and suggestions would be immensely helpful in getting me back on track. Thanks in advance for your assistance!

Best regards,

Note to Aleks, i even got fewer domains now :wink: but YH seems to be confused, what I ask myself… maybe it’s due to old config files. since YH doesn’t change altered files on updates?

It is quite possible that it consumes too much RAM when tuning these settings up. Check the PHP services status and logs. Tune the settings down.

Were you restoring your server?
Try force-upgrading your app: yunohost app upgrade my_webapp__9 -F

You will not be able to reset PHP app settings. I would advise you to all set them to “low”.
As for NGINX and general PHP configuration, yunohost tools regen-conf --help should do the trick. I’ll let you read on the help to properly use it.

I kindly ask you not to ping me if you answer. Anyone can help.


The PHP logs are not displaying any errors; only notifications are being logged, which is quite unusual. This issue seems to be specific to WordPress installations, as other applications are functioning properly. It’s important to note that I’m not the only one experiencing this problem. Several reports of the same issue can be found on this forum.

Furthermore, I’ve noticed that even when I install WordPress and give it a specific name, such as ‘some site’, the name doesn’t appear as expected. After the installation, when I check the list of installed apps, it’s listed as ‘WordPress’ rather than ‘some site’, which is perplexing.

Regarding the RAM usage, my system has a considerable amount of free memory, as indicated by the diagnostics:

“The system currently has 17 GiB (58%) of available RAM out of the total 29 GiB.”

In the PHP configuration, I’ve configured the websites to utilize up to 1 GB of RAM. This allocation is particularly necessary for tasks that demand intensive processing, such as visual builders, automated operations, and complex calculations – essentially, the types of tasks that computers excel at handling! :wink:

No, I was attempting to set up a fresh WordPress site. However, the automated installation process failed even after I adjusted the allocated resources. As a result, I decided to give manual installation a shot. Unfortunately, the manual installation also encountered issues, and it couldn’t establish a connection to the database. Upon further investigation, I realized that the ownership permissions were in disarray. I utilized the “chmod” command to rectify this situation, but unfortunately, the problem persisted. Then i removed it and stopped, and wrote this topic.

Ah, I see. In that case, I followed the right approach, as I’ve already completed those steps. I began with a dry run, which appeared to be successful, and then proceeded with the actual ‘effective’ run.

Regarding resetting PHP and similar actions in a general context, the typical method would involve using the “apt-get install PHP” command again. However, I’ve noticed that this approach is not recommended when working with YH. Could you please explain why this is the case? I’m simply curious about the reasoning behind this.

I won’t undertake that action. However, I’m unable to prevent any references to you when I quote your words. :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.