Cant access instance using domain ( in WAN\LAN

My YunoHost server

Hardware: Old laptop or computer
YunoHost version: 4.2.61
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

Yesterday I lost the abillity to access my instance using my domain name. At first I thought it was a problem with my internet, but everything else works. pinging my domain also works. connection using local ip whilst connected to LAN also works. I think it’s a problem with nginx, my browser gives my a CONNECTION_REFUSED error. and nginx gives the following error:

Jul 31 21:51:57 nginx[13561]: nginx: [warn] could not build optimal proxy_headers_hash, you should increase either proxy_headers_hash_max_size: 512 or proxy_headers_hash_bucket_size: 64; ignoring proxy_headers_hash_bucket_size

I tried regen-conf, didn’t help. I tried Diagnose, but everything comes out OK. I tried updating the entire system and that also didn’t work.

Thanks for the help in advance

Check first if it’s an hairpinning issue

Checked, not hairpinning. Besides the server did work before. Any suggestions?

Any ideas? Sorry for bumping i’m just kinda lost at this point

So if I understand correctly, you’re able to reach the webadmin interface using the local IP, but not the domain name ?

If that’s the case, I doubt the problem comes from nginx otherwise neither would work. (Also the message you’re showing only seems to be a warning)

Can you elaborate on what exactly happens when you try to reach the web server using the domain : you mention ‘CONNECTION_REFUSED’, can you share a screenshot of the page maybe ?

Here is a sample photo of the error

Also, I tried pinging and the ping failed. If that is relevent

again missed the replay, sorry for double-posting

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.