Cannot run system update

My YunoHost server

Hardware: DigitalOcean Droplet
YunoHost version: 11.1.19 (stable).
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

I’m seeing some similar error 500 posts but not sure if mine is the same or not…

I was trying to install some applications, but it tells me to update my Yunohost system first. However, it seems like I cannot run a system update. I have rebooted the system as well as rebooted my DigitalOcean Droplet… neither seemed to solve the problem.

Here’s the diagnosis:

The system update error message is 500, with Action : "PUT" /yunohost/api/update/all

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/moulinette/interfaces/", line 457, in process
    ret = self.actionsmap.process(arguments, timeout=30, route=_route)
  File "/usr/lib/python3/dist-packages/moulinette/", line 584, in process
    return func(**arguments)
  File "/usr/lib/python3/dist-packages/yunohost/", line 372, in tools_update
    upgradable_apps = _list_upgradable_apps()
  File "/usr/lib/python3/dist-packages/yunohost/", line 2621, in _list_upgradable_apps
    app["notifications"]["PRE_UPGRADE"] = _filter_and_hydrate_notifications(
  File "/usr/lib/python3/dist-packages/yunohost/", line 3142, in _filter_and_hydrate_notifications
    return {
  File "/usr/lib/python3/dist-packages/yunohost/", line 3148, in <dictcomp>
    or is_version_more_recent_than_current_version(name)
  File "/usr/lib/python3/dist-packages/yunohost/", line 3134, in is_version_more_recent_than_current_version
    current_version = str(current_version)
UnboundLocalError: local variable 'current_version' referenced before assignment

Thank you so much!!!

yep the warning about sury repo ket can be solve with following this thread

Hope that help you :wink:

1 Like

Thank you for the lead! But I tried with sudo apt-key del 95BD4743; wget -nv -O - “” | sudo apt-key add - and getting this:

Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).

This warning is not a problem ^w^

ooo really? and i tried updating again on yunohost and receiving the still error messages there :frowning:

can you try yunohost tools regen-conf please?

tried yunohost tools regen-conf and got this:
Screen Shot 2024-02-24 at 1.08.56 PM

and i ran sudo apt-key del 95BD4743; wget -nv -O - “” | sudo apt-key add - again

still got the same warnings and error message when trying to update on yunohost :confused:

humm yes yunohost tools regen-conf can’t work for this issue since you’re not using yunohost

can you rerun this exact line, by copying it and not typing it (the line that you put in your last message is not good, because of the wrong kind of quotes":
sudo apt-key del 95BD4743; wget -nv -O - "" | sudo apt-key add -

then, to upgrade your system while not using the web interface:
sudo apt update && sudo apt upgrade

ah yes, thank you for catching the quotes!

just tried both
sudo apt-key del 95BD4743; wget -nv -O - "" | sudo apt-key add -

sudo apt update && sudo apt upgrade

and now i’m at !!! :slight_smile: thank you so much!

1 Like


is the update using the web admin working properly now?

yes! just tried the web admin updates. now all update to date with the version.

was it because the previous version needed archived key to update manually?

thank you again!!

1 Like

I think not, i don’t understand exactly what happened :confused:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.