Cannot raise network after failed drive?!

My YunoHost server

Hardware: AMD64
YunoHost version: Latest (but cannot check right now)
I have access to my server : Not via network only physical with a keyboard and screen attached.
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: it’s behind a VPN exactly like: Homemade WireGuard VPN on a VPS server by @rungeard

Description of my issue

Since my other failed hard drive is removed, the YH server cannot make a connection with the internet or connect local. In other words Debian fails to raise the network.

I tried disabling the VPN on the YH server it did not work.

If I run the status networking command and journal -xe I get these errors (sorry I couldn’t copy and paste, so I had to make some sloppy pictures).

So what can I do to make it work again, no network file is changed after I did the VPN setup I never touched them again?

Thanks for your help in advance I’m to long offline now :frowning:

So the important error message in all that mess seems to be ifup: failed to bring up eth0

but that doesn’t tell much about exactly it failed

Can you possibly share the output of journalctl -u networking.service -n 200 --no-hostname --no-pager ?

Also ip -br a could be helpful

1 Like

Hi Aleks,

Glad to see your message :smiling_face_with_tear:

Gives me these errors;

That command shows how to usage ip etc.

EDIT:

This is the file in nano where it complains about in red:

Sorry again for the rough images.

The command was

ip -br a

but nvm the actual issue is the line you found in /etc/dhcp/dhclient.conf

Not sure what that supersede name line is about exactly … it complains that there’s no semicolon, but I can see them on your screenshot … did you fix it manually somehow ?

Anyway otherwise I would just yolo try to comment that line (supersede name...) by prefixing it with #. It’s not super important

Well actually, not sure that it will solve the issue entirely so please share ip -br a anyway :stuck_out_tongue_winking_eye:

1 Like

Output:

No I haven’t touched this file. So I did not fix anything.

Eeeh okay so turns out there’s no interface eth0 indeed, but there is an interface named enp5s0 which seems to be the one we want. This seem related to “predictable” vs. “non-predictable” interface naming which is a changed that happened a while ago now … But what’s puzzling is why suddenly your interface naming scheme would change

Anyway, let’s investigate further with grep -nr eth0 /etc/

Crazy right…

Wokay then, sounds simpler to revert back the interface itself to eth0 …

The trick to re-enable “non-predictable” (but human-friendly, sortof) interface names is :

rm -f /etc/systemd/network/99-default.link
ln -s /dev/null /etc/systemd/network/99-default.link

Then probably restarting the system

I typed those commands, but they seem to have no effect after rebooting.

Zbleuarg, so ip -br a still shows enp5s0 ?

Yes it does.

Also, I tried to run the yunohost setup but got all garbage screens after selecting graphical or text installer. Maybe a resolution issue? I was thinking and wanted to try to do a clean YH install on a clean SSD then grab the networking files from there and move them over to my current disk. Possibly a stupid idea I don’t know what else to do at this stage. I’m just scared of loosing everything.

Is there a command to re-initiate the network like making a new network setup to get it back to its original state?

Zblerg just be patient and let’s keep investigating / attempting stuff … naively this doesn’t look like a huge issue to solve (yes there’s no internet and it’s not 100% clear why but most of the time it’s just a matter of flipping the right switch to get things back on)

Re-reading the log, maybe replacing eth0 in the conf is in fact not a huge deal

So lets :

sed -i 's/eth0/enp5s0/g' /etc/network/interfaces.d/setup

and restart the server, see if ip -br a still reports enp5s0 as down or if it’s up (and try to ping -c 8.8.8.8 to check if internet is working)

True, but is just :frowning:

I saw something positive happening and it says

enp5s0 UP!!!

Also everything is working again, also thanks, also OMG you @Aleks again you saved my life!