Besoin d'aide, plus rien ne fonctionne sauf SSH

Bonjour tout est dans le titre, seul SSH fonctionne. J’ai un doute sur l’identité direct ou indirect du soucis: nginx qui refuse de démarrer. J’ai l"impression que c’est la dernière mise a jour (yunohost-admin) qui a déclenché le problème.

Du coup est-ce que tu peux faire un nginx -t ?

oui, et d’avance merci de te pencher sur mon soucis. voici le retour:
nginx: [emerg] could not build server_names_hash, you should increase server_names_hash_bucket_size: 64
nginx: configuration file /etc/nginx/nginx.conf test failed

Hokay…

Alors que raconte : grep -nr "server_names_hash" /etc/nginx/

/etc/nginx/nginx.conf:24: # server_names_hash_bucket_size 64;
/etc/nginx/conf.d/ssowat.conf:3:server_names_hash_bucket_size 64;

Well I have the same thing on my side … Some thread on the internets tell it might be related to having long domain names ?

I don’t really understand how that has anything to do with 3.8 :confused:

Anyway, if you want you can try to increase the parameter to 128 using 'nano /etc/nginx/conf.d/ssowat.conf' then edit the file and use Ctrl+X to save (confirm with Y + Enter)

Then try again nginx -t to validate that nginx is happy, and if yes, systemctl restart nginx

Great, it works. it sounds so simple. Thank you very much for your help.