Autoresponder messages from Roundcube does not work with all remoter servers

My YunoHost server

Hardware: VPS OVH
YunoHost version:
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

If your request is related to an app, specify its name and version: app RoundCube 1.6.6~ynh2

Description of my issue

We have noticed that some remote servers are not receiving the autoresponder messages (such as out-of-office replies) set up by our users in Roundcube. It is always the same servers, for example: Google Gmail, ORANGE in France, BREVO (SMTP gateway). Whereas others work well, like Yahoo or Apple.

What I have noticed in the messages that go through well, for example to Apple, is that the ‘mail from:’ and ‘Return-Path:’ fields are empty.

Authentication-Results :; bimi=skipped reason="insufficient dmarc"
Authentication-Results :; arc=none
Authentication-Results :; dmarc=fail
Authentication-Results :; dkim=none
Authentication-Results :; spf=none ( does not designate permitted sender hosts) smtp.mailfrom=
X-Sieve : Pigeonhole Sieve 0.5.13 (cdd19fe3)
X-Proofpoint-Guid : lkPNenQHt30u07EzjaglQ2J5pHrGU6MS
Auto-Submitted : auto-replied (vacation)
Return-Path : <>

In our logs from /var/log/mail.log I have seen that with one of remote SMTP server which is denying our autoresponders mails:

May  2 16:37:06 ynh postfix/smtp[1175255]: 0E597607F0: to=<>, orig_to=<>,[]:587, delay=0.17, delays=0.01/0/0.14/0.01, dsn=4.0.0, status=deferred (host[] said: 451 4.0.0 Invalid from (in reply to MAIL FROM command))

I understand that it works with Dovecot, but I don’t know how to troubleshoot.

I already posted a similar message, in French, more than a month ago, when I was already having this autoresponder issue while wanting to relay all outgoing mails to BREVO’s SMTP gateway, but no one responded.

Many thanks to the kind souls who will spare me some time!

I have found that the issue might be related to the Dovecot parameter sieve_vacation_send_from_recipient = no.

I understand that this parameter is set to “no” by default to prevent mail bounces, but in some cases, and increasingly so today, it prevents autoresponder messages from working properly, as they get rejected with a 451 error by remote servers, likely as part of anti-spam measures. This is the case with Google Gmail and some others.

So, I don’t know where and how to properly configure this parameter to “yes” and I need help to do it correctly :slight_smile:

Thank you in advance to the wonderful volunteers of this project who might assist with this issue!

After further investigation, I realized that the issue was not related to the empty MAIL FROM field but rather to an error in the DNS records related to SPF. There was indeed an SPF record for the domain but not for the mail server within this domain:!

I created additional SPF, DMARC, and DKIM records for this FQDN, and all tests have been successful.

Thank you to everyone who took the time to look into my question.