[Autofs] : Montage automatique disque dur externe chiffré Luks

Mon serveur YunoHost

Matériel: Odroid N2.
Version de YunoHost: 4.0.7 (stable)
J’ai accès à mon serveur : En direct avec un clavier/écran
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Bonjour à tous,

depuis quelques jours je progresse pas à pas dans la découverte de Yunohost (merci à tous ceux qui travaillent sur ce projet).

J’en suis au stade où j’aimerai monter automatiquement un disque dur externe (DDE) sur mon Odroid N2 pour que je puisse, en tant qu’admin, ajouter des catalogues sur Ampache depuis ce DDE.

Afin d’utiliser la commande autofs (la plus adaptée non ?), j’ai suivi attentivement ceci https://forum.yunohost.org/t/montage-automatique-disque-dur-externe/1192 sans succès.

Quatre précisions :

  1. ma partition unique (en ext4) sur le DDE est chiffrée (LUKS) ;
  2. j’ai configuré ainsi les deux fichiers requis :
    2.1 pour le fichier auto.master
    /net /etc/auto.ext4 --ghost,–timeout=30
    2.2 pour le fichier auto.ext4 (créé dans /etc) :
    wd2to -fstype=ext4, rw UUID=xxx
  3. j’ai bien fait service autofs restart (en root) après l’édition des deux fichiers
  4. je suis plutôt débutant sur Debian (en l’espèce Armbian) et sur les configs réseau (d’où yunohost :slight_smile:)

Pouvez-vous m’indiquer ce qui cloche ?
Est-ce parce que le disque est chiffré ?
L’erreur vient peut-être aussi de l’UUID.
quand je fais blkid j’obtiens :
/dev/mapper/luks-xxxxx (JE N’AI PAS PRIS CES XXX LA): LABEL=“xxxxxx” UUID=“xxxxx” (NUMERO QUE J’AI CHOISI) TYPE=“ext4”

D’avance merci beaucoup !

Bonjour,

Ce ne serait pas à cause de l’espace avant le rw ? Normalement il ne doit pas y en avoir à cet endroit.

Ton disque est-il bien déchiffré ?

Bonjour Niltugor,

merci pour ta réponse.
J’ai modifié le fichier en supprimant l’espace comme conseillé.
J’ai donc maintenant :

  1. pour le fichier auto.master :
    +auto.master
    /net /etc/auto.ext4 --ghost,–timeout=30
  2. pour le fichier auto.ext4 :
    wd2to -fstype=ext4,rw UUID=xxxxxx

J’ai, dans l’ordre, :
a) édité les fichiers ;
b) exécuté la commande service autofs restart (en root) ;
c) branché le DDE sur l’Odroid ;
d) rentré la phrase de passe (comme demandé par l’invite xfce après avoir cliqué sur l’icone sur le bureau avec le cadenas fermé) en indiquant “se souvenir du mot de passe jusqu’à la fin de la session”.

Ce qui a provoqué :
a) un message “Impossible de monter « Volume de 2.0 To ». Operation was cancel”
b) un montage du DDE dans le point de montage standard des disques amovibles (si j’ai bien compris) : /media/mon_nom/2To_WD_BD_Videos/

Est-ce que, dans le fichier auto.ext4, je ne pourrai pas essayer avec le LABEL ? (je vais essayé cet après-midi quand le petit dormira :slight_smile:)

Bonne matinée

Il faudrait déchiffrer ton disque avant de relancer autofs.

Donc dans l’ordre :
− Déchiffre ton disque avec ta phrase de passe
− Vérifie que l’UUID enregistré dans ton fichier de config autofs soit bien celui de la partition du disque déchiffré (ce qui doit apparaître a priori dans ta ligne /dev/mapper/luks-xxxx TYPE=“ext4” avec blkid) et non celui du disque chiffré (qui doit apparaître sur la ligne /dev/sdx1 TYPE=“crypto_LUKS” par exemple).
− Si besoin, fais la modification dans ton fichier auto.ext4
− Puis sudo service autofs restart

Re-bonjour Niltugor,

j’ai suivi le step by step (en effet je m’étais trompé d’UUID merci) mais :

  1. toujours le même message d’erreur :
    “Impossible de monter « Volume de 2.0 To ». Operation was cancel”
  2. et un montage du DDE dans le point de montage standard des disques amovibles : /media/mon_nom/2To_WD_BD_Videos/

J’ai rebooté ; refait les étapes…mais toujours la même chose :pensive:

Dans ton fichier auto.master, as-tu bien 2 traits d’union avant l’option timeout (--ghost,--timeout=30) ? Tu n’en as mis qu’un dans ton message précédent.

Sinon je ne comprends pas bien : tu as déjà monté ton disque chiffré manuellement ? Car si oui, il ne pourra pas être monté une deuxième fois par autofs.
Pourrais-tu donner le résultat de sudo blkid une fois ton disque déchiffré pour que ça soit plus clair ?

Dans ton fichier auto.master, as-tu bien 2 traits d’union avant l’option timeout ( --ghost,--timeout=30 ) ? Tu n’en as mis qu’un dans ton message précédent.

Oui. Mon auto.master est bien ainsi :
/net /etc/auto.ext4 - -ghost,- -timeout=30

Sinon je ne comprends pas bien : tu as déjà monté ton disque chiffré manuellement ? Car si oui, il ne pourra pas être monté une deuxième fois par autofs.

Non il se monte automatiquement sur media après le message d’erreur.

Pourrais-tu donner le résultat de sudo blkid une fois ton disque déchiffré pour que ça soit plus clair ?

Output de sudo blkid
/dev/mmcblk1p1: UUID=“xxxn°1” TYPE=“ext4” PARTUUID=“xxn°2”
/dev/zram0: LABEL=“log2ram” UUID=“xxxn°3” TYPE=“ext4”
/dev/mmcblk1: PTUUID=“xxxn°4” PTTYPE=“dos”
/dev/zram1: UUID=“xxxn°5” TYPE=“swap”
/dev/sda1: UUID=“xxxxn°6 [CELUI QUE J UTILISE DANS AUTO.EXT4]” TYPE=“crypto_LUKS” PARTUUID=“a2721442-01”

Là ça veut dire que ton disque n’a pas été déchiffré. Il devrait apparaître dans /dev/mapper/lenomquetuluidonnes
Pour le déchiffrer manuellement (à refaire à chaque démarrage) : sudo cryptsetup luksOpen /dev/sda1 sonnom
Pour un déchiffrage automatique, il faut ajouter une ligne dans /etc/crypttab. Voir la doc Ubuntu si besoin.

Oui. Pardon.

output blkid après phrase de passe :
/dev/mmcblk1p1: UUID=“xxxn°1” TYPE=“ext4” PARTUUID=“0419cee1-01”
/dev/zram0: LABEL=“log2ram” UUID=“xxxn°2” TYPE=“ext4”
/dev/zram1: UUID=“xxxn°3” TYPE=“swap”
/dev/sda1: UUID=“xxxn°4 celui que j’utilise” TYPE=“crypto_LUKS” PARTUUID=“a2721442-01”
/dev/mmcblk1: PTUUID=“0419cee1” PTTYPE=“dos”
/dev/mapper/luks-xxxxn°4: LABEL=“2To_WD_BD_Videos” UUID=“xxxxn°5” TYPE=“ext4”

J’aimerai donc que ce DDE se monte automatiquement au même endroit à chaque démarrage (d’où autofs) (afin que je puisse ajouter un catalogue dans Amapache) et je préfererai déchiffrer manuellement à chaque démarrage.

L’UUID à mettre dans ton auto.ext4 est celui-ci. Modifie ton fichier puis réessaie sudo service autofs restart

le xxxn°4 ou le xxxxn°5 ?

Le 5

Merci je teste.

EDIT : toujours le même message d’erreur :
“Impossible de monter « Volume de 2.0 To ». Operation was cancel”
et un montage du DDE dans le point de montage standard des disques amovibles : /media/mon_nom/2To_WD_BD_Videos/

À quel moment as-tu ce message d’erreur ?

As-tu essayé de le monter manuellement avec la commande sudo mount /dev/mapper/tondisque /lendroitquetuveux pour voir si ça marche ?

As-tu essayé de le monter manuellement avec la commande sudo mount /dev/mapper/tondisque /lendroitquetuveux pour voir si ça marche ?

Je viens d’essayer de le mettre dans /net , avec la commande mount, et ça marche. Mais mount n’est que temporaire c’est ça ?

À quel moment as-tu ce message d’erreur ?

Quand je rentre la phrase de passe (cad que ne voyant pas d’effet à autofs, je débranche et rebranche le DDE).

Que veux-tu dire quand tu ne vois pas d’effet à autofs ? La commande ne retourne rien et c’est normal. Il faut aller voir dans /net si ton disque est monté.

Par contre, ne débranche pas ton disque, car il n’est ensuite plus déchiffré, donc aucune chance que ça marche et je ne vois pas ce que ça peut faire d’autre.

La commande mount fonctionne jusqu’au prochain redémarrage ou un démontage manuel.

Pourrais-tu réessayer de déchiffrer ton disque, redémarrer autofs, vérifier qu’il n’y a toujours rien dans /net (sudo ls - l /net) puis éventuellement le retour de sudo service autofs status ?

Il y a bien les fichiers dans /net. Merci bcp.

Mais ce qui me troublait (et me questionne toujours un peu) c’est que ces fichiers sont aussi à /media.

C’est normal ?

puis éventuellement le retour de sudo service autofs status ?

autofs.service - Automounts filesystems on demand
Loaded: loaded (/lib/systemd/system/autofs.service; enabled; vendor preset: e
Active: active (running) since Sat 2020-09-12 22:15:53 CEST; 3min 11s ago
Process: 7963 ExecStart=/usr/sbin/automount $OPTIONS --pid-file /var/run/autof
Main PID: 7964 (automount)
Tasks: 4 (limit: 3260)
Memory: 4.0M
CGroup: /system.slice/autofs.service
└─7964 /usr/sbin/automount --pid-file /var/run/autofs.pid

Sep 12 22:15:53 monnom.nohost.me systemd[1]: Starting Automounts filesys
Sep 12 22:15:53 monnom.nohost.me systemd[1]: Started Automounts filesyst
Sep 12 22:16:14 monnom.nohost.me automount[7964]: key “.hidden” not foun
Sep 12 22:16:15 monnom.nohost.me automount[7964]: rmdir_path: lstat of /
Sep 12 22:17:59 monnom.nohost.me automount[7964]: key “.hidden” not foun
Sep 12 22:18:02 monnom.nohost.me automount[7964]: rmdir_path: lstat of /

Je ne sais pas, c’est étrange qu’il soit monté dans deux endroits en même temps effectivement.

Tu peux éventuellement jeter un coup d’œil dans /etc/mtab pour voir si c’est bien le même disque qui est monté 2 fois où s’il y a un lien symbolique quelque part qui a été créé.

Bonjour Niltugor,
il n’y a qu’un point de montage en /net.
Le point de montage en media disparait dès que j’accède pour la première fois (de la session) au pojnt de montage d’autofs (/net).
Je te remercie beaucoup et te souhaite un bon dimanche.