App_ffsync can't be installed

,

Firefox Sync App: app_ffsync can’t be installed (log see here: https://paste.yunohost.org/raw/yidojumila)
Problem about old python? Updated it to 3.9.2 succesfully using how to update python in raspberry pi - Stack Overflow but still the same error?
Any ideas?

System is up2date in general: 4.1.7.4 (stable) on a RPi 3

EDIT:

works after 2 reboots and with the messages on installation:

Summary

Installation of ffsync completed
The service uwsgi-app@ffsync.service has correctly executed the action start.
Starting ffsync services…
Restart services…
/!\ Packagers! This app is still using the skipped/protected/unprotected_uris/regex settings which are now obsolete and deprecated… Instead, you should use the new helpers ‘ynh_permission_{create,urls,update,delete}’ and the ‘visitors’ group to initialize the public/private access. Check out the documentation at the bottom of yunohost.org/groups_and_permissions to learn how to use the new permission mechanism.
Configuring permissions
Protecting directory
Configuring application…
Configuring system user…
Configuring nginx
tokenserver 1.5.11 requires WebOb==1.8.5, but you’ll have webob 1.4.1 which is incompatible.
tokenserver 1.5.11 requires requests==2.22.0, but you’ll have requests 2.20.0 which is incompatible.
tokenserver 1.5.11 requires pyramid==1.10.4, but you’ll have pyramid 1.5.3 which is incompatible.
tokenserver 1.5.11 requires mozsvc==0.10, but you’ll have mozsvc 0.9 which is incompatible.
tokenserver 1.5.11 requires gunicorn==19.10.0, but you’ll have gunicorn 19.6.0 which is incompatible.
tokenserver 1.5.11 requires cornice==3.5.1, but you’ll have cornice 0.16.2 which is incompatible.
tokenserver 1.5.11 requires configparser==3.7.4, but you’ll have configparser 3.5.0 which is incompatible.
google-api-core 1.26.1 requires futures>=3.2.0; python_version < “3.2”, but you’ll have futures 3.0.0 which is incompatible.
gevent 1.4.0 requires greenlet>=0.4.14; platform_python_implementation == “CPython”, but you’ll have greenlet 0.4.13 which is incompatible.
requests 2.20.0 requires urllib3<1.25,>=1.21.1, but you’ll have urllib3 1.25.2 which is incompatible.
requests 2.20.0 requires idna<2.8,>=2.5, but you’ll have idna 2.8 which is incompatible.
ERROR: pip’s legacy dependency resolver does not consider dependency conflicts when selecting packages. This behaviour is the source of the following dependency conflicts.
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at Release process - pip documentation v21.1.dev0 pip 21.0 will remove support for this functionality.
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at Release process - pip documentation v21.1.dev0 pip 21.0 will remove support for this functionality.
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at Release process - pip documentation v21.1.dev0 pip 21.0 will remove support for this functionality.
/usr/bin/which: 10: printf: printf: I/O error

?!?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.