Alpha-stage testing for YunoHost 4.0 on Debian Buster (and migration shipped in Yunohost 3.8.5)

Hey there!

We are happy to announce that we are officially starting the transition to Buster :tada: !

If you are familiar with server administration, you may understand that this is a delicate operation even though the Yunohost team will do its best to provide the smoothest possible transition with a one-click upgrade through the webadmin.

In order to test this mechanism and identify issues that cannot be spotted just on development environment, we are first opening this as an alpha-stage testing : the purpose is to gather feedback from tech-savvy users who are not afraid to tinker. Especially, we encourage you to only run these tests if you have a way to entirely rollback your system (using snapshots or other mechanism). Depending on feedback and issues found, we will then open a beta-testing that should be deemed more stable

:construction: AT THIS STAGE, WE ABSOLUTELY DISCOURAGE ANY USE OF YUNOHOST 4.x (or running the migration shipped in 3.8.5) ON A PRODUCTION SERVER - IT WILL BREAK. :construction:

:space_invader: What to test ?

There are two independent pieces to test.

Installing a fresh YunoHost on top of a fresh Debian 10/Buster

This is done with :

$ wget https://install.yunohost.org/buster -O install_script
$ chmod +x install_script
$ ./install_script
# You will get a disclaimer intended to make sure what you're doing. 
# Read it and follow the instructions.

Apart from validating that the install does work, we encourage you to test every apps and features that you would typically use in a real-life server (so including the webadmin, the user portal, diagnosis, emails, …). Note that some apps are still known to not support Buster yet though fixes are on the way for most of them.

Migrating an existing Debian 9/Stretch + YunoHost 3.8.x server

YunoHost 3.8.5 (currently testing) ships a migration that allows to upgrade to Debian 10/Buster + Yunohost 4.x.

Before going through this process, we reiterate that ideally, you should have a way to entirely rollback your server before proceeding with the upgrade. That way, if you spot issues, we’ll be able to provide a fix then validate that the fix works by re-running the upgrade from the same starting point.

  1. Switch to testing by running:

curl https://install.yunohost.org/switchToTesting | bash

  1. After upgrading, in the webadmin, under Tools > Migrations, you should now see an available migration to upgrade to Buster. Read the disclaimer and start the migration.

  2. … be patient, this will take a while. But try to stay attentive to what’s going on. Share the detailed log if anything that goes wrong.

  3. Ideally after the upgrade, test that everything (e.g. apps installed) still works as expected.

19 Likes

I made the migration from Stretch to Buster on a testing VPS (VPS S SSD from Contabo), it took about 15 minutes. After the installation I had to:

  • restart yunohost-api
  • migrate from PostgreSQL 9.6 to 11 (in the migration panel)
  • restart mattermost service
  • JupyterLab gives 500 : Internal Server Error after log in.
    update: jupyterLab was a custom version… after reinstalling the official version it worked).

Also, there are 2 warnings in the Configurations système part of the diagnosis panel : /etc/nslcd.conf and /etc/nsswitch.conf “seem to have been modified manually”.

Apart from the two warnings the migration went surprisingly well for an alpha, congrats to everybody !

Hi there :wave:
Since my server is still down (could not find a way to reinstall yunohost image 3.6 w/ EFI), I think I am installing debian 10.4 netinst and will try to migrate to YNH 4 to see how it goes. If everything goes well, I intend to switch back to stable release once the official 4.0 is out.

Meanwhile I’ll provide feedback on what I see/experience.

Just a dumb question though, (it is not critical but) what is the default partitioning for YNH ? could not find it in the documentation and I would like to keep it “standard”.

1 Like

Bonjour,

La migration s’est très bien déroulée en ce qui me concerne.

J’ai dû relancer manuellement 2 services (coturn-synapse et mattermost). A première vue, les apps Synapse, Riot, Roundcube, Nextcloud et Wordpress semblent fonctionnelles (voir à l’usage). La seule qui ne fonctionne plus est une custom web-app (2 sont configurées sur mon instance) dont le lien me renvoie au portail mais l’accès sftp fonctionne.

Pour ce qui est du diagnostic, hormis :

  • Le fichier de configuration /etc/nslcd.conf semble avoir été modifié manuellement.
  • Le fichier de configuration /etc/nsswitch.conf semble avoir été modifié manuellement.

tout est comme avant. J’avais déjà des “soucis” d’IP sur liste noire et de rDNS non configuré sur IPV6, un avertissement car j’ai modifié le port ssh et les “classiques” avertissements de dns pour les domaines n’ayant pas été configurés avec la conf conseillée. Si ce n’est les 2 points ci-dessus, rien d’anormal donc.

Pour une alpha, très honnêtement je m’attendais rencontrer plus de problèmes. Je reste évidemment attentif au fonctionnement à l’usage et vous ferai mes retours mais je tiens quand même à vous féliciter. Well done !

Update :

  • j’ai dû reconfigurer la timezone
  • concernant la custom webapp, je reçois ce message via le portail :

Erreur de redirection : domaine non géré

Je précise que mes 2 webapps sont configurée en sous-répertoire d’un domaine sousdomaine.domaine.tld/site (celle qui ne fonctionne plus et la première à avoir été configurée) et sousdomaine.domaine.tld/test (qui elle fonctionne)

  • Après reboot, le service Synapse ne se lance plus, voilà une partie du log :

– A start job for unit matrix-synapse.service has begun execution.

– The job identifier is 115.
Jun 06 12:21:57 python[719]: /opt/yunohost/matrix-synapse/bin/python: Error while finding module specification for ‘synapse.app.homeserver’ (ModuleNotFoundError: No module named ‘synapse’)
Jun 06 12:21:57 systemd[1]: matrix-synapse.service: Control process exited, code=exited, status=1/FAILURE
– Subject: Unit process exited
– Defined-By: systemd

Firstly, a big thanks to the contributors for the work already done on Yunohost 4.0 :wink:

Unfortunately, for me it’s a failure (full logs) under Raspberry Pi 3B+! I used a fresh install, switch to testing after post install.

Migration stopped after several warnings: pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I remain available if it will help you!

2 Likes

So, I installed Debian 10.4 and did the migration script to yunohost
the script ended with sucess.
Before postinstall I tried a few things that did not work :

  • cannot login using admin user (either on local or through SSH)
  • /home directory lacks the yunohost folders (i.e only 1user forled in /home, no yunohost.backup for instance)

I created the /home/yunohost.backup/archives folder and tried restoring :

 
root# yunohost backup restore 20200503-161741.tar.gz
Error: Unknown local backup archive named '20200503-161741.tar.gz'
root# yunohost backup restore /home/yunohost.backup/archives/20200503-161741.tar.gz
Error: Unknown local backup archive named '/home/yunohost.backup/archives/20200503-161741.tar.gz'

edit : after doing a classic post install, I could see my backups in the folder through the web interface. However, selecting a achieve (~30 Gib) does not seem to work. After 1h30 min I am still at the step "Preparing archive for restoration…" nothing has moved ever since

Edit2 : even w/o Nextcloud (28 Gib) the backup does not work
Edit3 : actually it did after taking ~6 hours on 1 proc thread, long but ok (W/o Nextcloud)
Trying to add nextcloud afterward does not work though

The font style is not applied to these two buttons : admin > utilisateurs > user panel

1 Like

Migrations done on a Scaleway ARM instance.
Everything works so far.
Diagnosis tool told me to regenerate config files for nsswitch and nslcd, which I did, and it does not complain anymore so it sounds good.
Also, metronome exited, I restarted it and XMPP works so this is great.
Nextcloud works so far, lufi as well, the custom webapp and the redirect apps are working.
Really good job ! I wouldn’t call this an alpha though…

2 Likes

J’ai juste fait une mise à jour d’un serveur de test qui avait la version antérieure sur un raspberry pi4 pour l’instant avec un autre nom de domaine que celui de mon serveur auto-hébérgé. Ça ce passe bien…

Je n’ouvre pas encore les ports tant que je ne peux pas encore migrer correctement mon autre serveur. Pour l’instant pas mal d’applications ne sont pas encore compatibles…

Du coup je vois ces messages dans Diagnosis:
Votre IP ou domaine XX.XX.XX.XXX est sur liste noire sur SpamRATS! all Votre IP ou domaine XX.XX.XX.XXX est sur liste noire sur SPFBL.net RB
Mais je pense que c’est parce que rien n’est configuré, j’espère que cela ne va pas blacklisté l’autre mail de la machine en prod…
Finalement, j’ai ajouté vpnclient et configurer le Pi4 avec une adresse vpn… Du coup je n’ai pas de reverse dns configuré avec cette méthode…

It works on my Raspberry Pi 4, wow. Thanx a lot. Already tested Wordpress, Rainloop, Netdata and Plex. Everything works fine.

But not :frowning: I was excited early. When I try to open a website on Wordpress, for some reason it’s redirected to https://mydomain.com/yunohost/sso/ How to fix it?

Well what are you trying exactly …

I figure out how to fix this issue. I just forgot to specify in Wordpress settings to use this domain by default. Sorry.

1 Like

Upgrade went well on my testing VM, from 3.8 to Alpha, and stretch to buster 10.4.

The apps installed are Moodle, Monitorix, LimeSurvey, Framaforms and Friendica. They were not fully functionnal before upgrade, but they did not break further.

I also have the 2 warnings about changed files in system conf : /etc/nslcd.conf and /etc/nsswitch.conf. No public IP so I could not test the rest of it.

But so and so : it went well :smiley: Thanks for all the hard work, hopefully we can help you do more testing later on.

Hello and thank you devs, for the good work. I installed the yunohost 4.0.1~alpha (testing) on a virtual machine and I’m impressed!
After installing roundcube, Keeweb and FirefoxSync server, I struggled on installing Nextcloud (but this is a known problem, I suppose).
Such a nice project - looking forward to run yunohost on my raspPi4 soon.

P.S. Installing synapse and calibreweb failed too. In the later case, python 3.5 is missing on the system. Also pip is warning: "DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. pip 21.0 will drop support for Python 2.7 in January 2021. " Would it make sense, to share logfiles somewhere?

2 Likes

Installation réussi sur un Raspberry PI 4 Model B 8 Go avec la version beta 64 bits de Raspberry Pi OS :smiley:

1 Like

Soucis pour l’installation Nextcloud

Le Yunopaste au cas ou : https://paste.yunohost.org/raw/eyikitexob

It’s great to see that buster starts to be working. Thank you so much.

Maybe this is a possibility to further verify the migration success: After testing the migration manually, the filesystem of a migrated default install could then be compared to a newly installed buster system.

For example, with the meld GUI program and selecting the remote filesystem(s).

Raspberry Pi3B+
Fresh install, upto testing, them migration: failed with held dependancies. Logs gone somewhere, I’ll post if and when I find them!

Will try another route and report back