Yunohost sur reseau local avec un syno possible?

Contexte un réseau local en 192.168.0.x derrière une frebox mini4k
avec sur le réseau local un serveur synology accessible depuis Internet et plusieurs raspi avec des ip locale fixe,une imprimante, un routeur wifi.

Objectif:
Installer un serveur Yunohost sur un raspi pour mon fils afin de lui permettre de découvrir l’environnement et services sans mettre le bazar sur le réseau local.

Question:
d’après vous est il possible lors de l’installation de configurer yunohost sur une plage réseau différente par exemple : 192.168.5.x

Comment faire pour prévenir les conflits de serveur entre le serveur syno et Yunohost ?

Quelle piste me conseillerez-vous pour arriver à installer Yunohost dans mon contexte ?
Merci pour vos retours,

La plage d’ip me semble pas si importante que ça. Mais bon ça se configure en ligne de commande si besoin d’autres chose qu’une IP attribuée via DHCP.

Le vrai soucis c’est plus pour la question de l’ip publique et de l’exposition du yunohost sur l’internet. La solution la plus simple pour régler ça, c’est de prendre un vpn à ip publique. Sinon, il faut que le serveur qui a l’ip publique fasse du reverse proxy pour l’autre. Ou encore abandonner l’idée d’avoir une ip publique, le serveur devant accessible que sur le réseau local.

Merci pour ta réponse et pistes à explorer,
J’aimerai éviter de passer par un service vpn tiers, payant de surcroit. La possibilité de créé un reverse proxy parait réalisable sur le syno, j’ai trouvé des exemples de config sur internet. Après, c’est la mise en pratique, comment le mettre en place lors de l’installation de Yunohost, il y a-t-il une possibilité d’installation personnalisable et adapter au contexte ?

Non il y a rien de tout ça, mais si tu cherches des info dans ce forum sur les reverse proxy tu peux trouver des choses. EN général, c’est pour 2 ynh donc les personnes utilisent l’application redirect. Il y a peut être un howto sur le sujet (dans la catégorie howto)

Après divers tests et tâtonnement, j’arrive à pointer sur le RASPI Yunohost grâce a l’utilisation du domaine *.ynh.fr - MERCI

cependant, tout n’est pas réglé, car c’est le certificat ssl https qi apparemment ne suit pas, j’ai beau avoir un Statut du certificat qui me donne :

Bien, le certificat actuel a l’air correct !
Autorité de certification
Other / Unknown (*****.ynh.fr)
Validité
3649 jours

et en faisant un yunohost dyndns update --debug
j’ai ce retour :
capture

Une idée ?

tout n’est pas réglé, car c’est le certificat ssl https qi apparemment ne suit pas

Pas de poésie, c’est quoi l’erreur qui te fait dire que ça ne suit pas? :stuck_out_tongue:
As-tu vraiment généré un certificat Let’s Encrypt? Une validité de 10 ans, ça me fait plutôt penser à un certificat auto-généré, et donc source de page d’erreur de la part des navigateurs.

Alors petit topo sur mon infra et les configurations tester :

  • Premièrement la freebox qui fournis l’accès Internet
  • ensuite branché le serveur synology

L’accès du syno sur le web fourni par un nom de domaine chez ovh

  • J’ai créé chez OVH sur le nom de domaine patate.chd un dynhost de type frite.patate.chd
    sur le syno un ddns frite.patate.chd point sur l’adresse ip de le freebox

de même un certificat lets encrypt est configuré sur le syno frite.patate.chd
de cette sorte le serveur syno est visible sur le web avec un certificat https

La tout est Ok

Mon souci est maintenant que je souhaite ajouter un raspi avec Yunohost
1 - j’attribue une adresse ip en réseau :local pour yunohost: OK
2 - les maj se font convenablement, j’ai un acces internet
3 - Je souhaite ouvrir yunohost sur le web

  • Je configure le domaine yunohost par ketchup.frite.patate.chd
    sur le synology je configure un reverse proxy de l’hote ketchup.frite.patate.chd en https sur l’ip de la freebox
    sur le nom de domaine ovh patate.chd je cree un dynHOST ketchup.frite.patate.chd sur l’ip de le freebox

résultat

sur le domaine ketchup.frite.patate.chd le certificat me renvoi
Ce domaine ne semble pas prêt pour installer un certificat Let’s Encrypt. Veuillez vérifier votre configuration DNS et l’accessibilité HTTP de votre serveur. Les sections ‘enregistrement DNS’ et ‘Web’ dans la page de diagnostic peuvent vous aider à comprendre ce qui est mal configuré.

Quand je pointe sur ketchup.frite.patate.ch je dois accepter une connexion non sécurisé et une redirection est faite sur une page 404 du serveur du syno

je n’arrive pas à pointer sur la page de connexion yunohost à partir de ketchup.frite.patate.chd


Changement de stratégie, Je crée le domaine saucisse.ynh.fr

sur le synology je configure un reverse proxy de l’hote saucisse.ynh.fr en https sur l’ip de la freebox

Statut du certificat
Bien, le certificat actuel a l’air correct !
Autorité de certification
Other / Unknown (saucisse.ynh.fr)
Validité
3647 jours

la config dns de yunohost donne :

; Basic ipv4/ipv6 records
@ 3600 IN A 78...*
@ 3600 IN AAAA 2a01:e34:ec45:::::*

; XMPP
_xmpp-client._tcp 3600 IN SRV 0 5 5222 saucisse.ynh.fr.
_xmpp-server._tcp 3600 IN SRV 0 5 5269 saucisse.ynh.fr.
muc 3600 IN CNAME @
pubsub 3600 IN CNAME @
vjud 3600 IN CNAME @
xmpp-upload 3600 IN CNAME @

; Mail
@ 3600 IN MX 10 saucisse.ynh.fr.
@ 3600 IN TXT “v=spf1 a mx -all”
mail._domainkey 3600 IN TXT “v=DKIM1; h=sha256; k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDYaY6iAShhx+U2oh1xM8qWg7oV2tlY5AdClSQhy75zbbvjjrxDQN/9PQFviK+JMNiPa4LOONzL8vW9yjy1PI3lFDuvyLMJQR56s+X8pC5+4+7rQJUmqqJXGT9JtTQgyiexFYWBNq25D5oSI+9ki/tskz4EurD4TmWBssMLEQaBFwIDAQAC”
_dmarc 3600 IN TXT “v=DMARC1; p=none”

; Extra

  • 3600 IN A 78...*
  • 3600 IN AAAA 2a01:e34:ec45:::::*
    @ 3600 IN CAA 128 issue “letsencrypt.org

quand je pointe mon navigateur internet sur saucisse.ynh.fr

j’ai une annonce de risque de certificat avec un Code d’erreur : SEC_ERROR_UNKNOWN_ISSUER

quand j’affiche le détail du certificat j’ai deux retours:
le premier :
Nom du sujet : Nom courant saucisse.ynh.fr
Nom de l’émetteur : ketchup.frite.patate.chd
Noms alternatifs du sujet:Nom DNS saucisse.ynh.fr www.saucisse.ynh.fr ns.saucisse.ynh.fr xmpp-upload.saucisse.ynh.fr

le second :
Nom du sujet : ketchup.frite.patate.chd
Nom de l’émetteur : ketchup.frite.patate.chd

J’accepte le risque et poursuit et ça marche je suis sur la page d’identification
https://saucisse.ynh.fr/yunohost/sso/?r=aHR0cHM6Ly90b3A3Ym94LnluaC5mci9=

Voilà pour le topo, la ‘poésie’ est uniquement sur l’appellation des noms de domaines,
Si vous voyer où sont les erreurs de config que ce soit avec la méthode ketchup.frite.patate.chd ou saucisse.ynh.fr

Je suis preneur, d’avance merci pour votre retour

(j’espère que je ne t’ai pas vexé avec ma référence à la poésie, je te taquinais juste sur le manque d’erreur nommée :stuck_out_tongue: )

Ici ce n’est à mon avis pas possible, car YunoHost cherchera toujours à te servir des pages en SSL. Il y a des sujets sur le forum (“disable SSL”, “no HTTPS”, etc.) qui y font référence. Je crains que cette option soit une impasse.


Même problème. Ici c’est ton Synology qui tente de proposer un certificat SSL pour ton YunoHost, ergo ton erreur “SEC_ERROR_UNKNOWN_ISSUER”.

Par contre, il me semble après une rapide recherche que NGINX peut en fait être proxy pour du trafic SSL, sans injecter son propre certificat (ici ou là, juste pour un autre exemple plus avancé.) Si tu peux implémenter ça dans la config de ton Synology, ça devrait mieux marcher. Par contre je n’ai pas d’expérience dans ce cas là, je ne garantis pas que ça marche.